summaryrefslogtreecommitdiff
path: root/dev-db/schemaspy/schemaspy-3.1.1.ebuild
Unidiff
Diffstat (limited to 'dev-db/schemaspy/schemaspy-3.1.1.ebuild') (more/less context) (show whitespace changes)
-rw-r--r--dev-db/schemaspy/schemaspy-3.1.1.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-db/schemaspy/schemaspy-3.1.1.ebuild b/dev-db/schemaspy/schemaspy-3.1.1.ebuild
index 6e18518..04f95e8 100644
--- a/dev-db/schemaspy/schemaspy-3.1.1.ebuild
+++ b/dev-db/schemaspy/schemaspy-3.1.1.ebuild
@@ -1,34 +1,34 @@
1# Copyright 1999-2006 Gentoo Foundation 1# Copyright 1999-2007 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: $ 3# $Header: $
4 4
5inherit eutils java-pkg-2 java-ant-2 5inherit eutils java-pkg-2 java-ant-2
6 6
7DESCRIPTION="Graphical database schema metadata browser" 7DESCRIPTION="Graphical database schema metadata browser"
8HOMEPAGE="http://schemaspy.sourceforge.net/" 8HOMEPAGE="http://schemaspy.sourceforge.net/"
9SRC_URI="mirror://sourceforge/${PN}/schemaSpy_${PV}.source.jar" 9SRC_URI="mirror://sourceforge/${PN}/schemaSpy_${PV}.source.jar"
10LICENSE="LGPL" 10LICENSE="LGPL-2.1"
11SLOT="0" 11SLOT="0"
12KEYWORDS="~x86 ~amd64" 12KEYWORDS="~x86 ~amd64"
13IUSE="postgres firebird oracle mysql" 13IUSE="postgres firebird oracle mysql"
14 14
15DEPEND=" 15DEPEND="
16 >=virtual/jdk-1.4 16 >=virtual/jdk-1.4
17 dev-java/ant-core 17 dev-java/ant-core
18 app-arch/unzip 18 app-arch/unzip
19" 19"
20RDEPEND=" 20RDEPEND="
21 >=virtual/jre-1.4 21 >=virtual/jre-1.4
22 postgres? ( dev-java/jdbc3-postgresql ) 22 postgres? ( dev-java/jdbc3-postgresql )
23 firebird? ( dev-java/jdbc3-firebird ) 23 firebird? ( dev-java/jdbc3-firebird )
24 oracle? ( dev-java/jdbc3-oracle ) 24 oracle? ( dev-java/jdbc3-oracle )
25 mysql? ( dev-java/jdbc-mysql ) 25 mysql? ( dev-java/jdbc-mysql )
26 !dev-db/schemaspy-svn 26 !dev-db/schemaspy-svn
27" 27"
28 28
29src_unpack() { 29src_unpack() {
30 mkdir "${S}" 30 mkdir "${S}"
31 cd "${S}" 31 cd "${S}"
32 unpack "${A}" 32 unpack "${A}"
33 cp ${FILESDIR}/build.xml ./ 33 cp ${FILESDIR}/build.xml ./
34 rm -rf META-INF/ 34 rm -rf META-INF/