summaryrefslogtreecommitdiff
path: root/dev-lang/lazarus/lazarus-0.9.22.ebuild
Unidiff
Diffstat (limited to 'dev-lang/lazarus/lazarus-0.9.22.ebuild') (more/less context) (ignore whitespace changes)
-rw-r--r--dev-lang/lazarus/lazarus-0.9.22.ebuild75
1 files changed, 0 insertions, 75 deletions
diff --git a/dev-lang/lazarus/lazarus-0.9.22.ebuild b/dev-lang/lazarus/lazarus-0.9.22.ebuild
deleted file mode 100644
index 02c80a4..0000000
--- a/dev-lang/lazarus/lazarus-0.9.22.ebuild
+++ b/dev/null
@@ -1,75 +0,0 @@
1# Copyright 1999-2007 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2
3# $Header: $
4
5inherit eutils
6
7FPCVER="2.0.4"
8
9SLOT="0" # Note: Slotting Lazarus needs slotting fpc, see DEPEND.
10LICENSE="GPL-2 LGPL-2.1 LGPL-2.1-linking-exception"
11KEYWORDS="~amd64 ~ppc ~x86"
12DESCRIPTION="Lazarus IDE is a feature rich visual programming environment emulating Delphi."
13HOMEPAGE="http://www.lazarus.freepascal.org/"
14IUSE=""
15SRC_URI="mirror://sourceforge/lazarus/${P}-1.tar.gz"
16
17DEPEND="~dev-lang/fpc-${FPCVER}
18 net-misc/rsync
19 >=x11-libs/gtk+-2.0"
20
21S=${WORKDIR}/${PN}
22
23pkg_setup() {
24 if ! built_with_use "dev-lang/fpc" source; then
25 eerror "You need to build dev-lang/fpc with the 'source' USE flag"
26 eerror "in order for lazarus to work properly."
27 die "lazarus needs fpc built with the 'source' USE to work."
28 fi
29}
30
31src_unpack() {
32 # check for broken fpc.cfg
33 # don't check in pkg_setup since it won't harm binpkgs
34 if grep -q '^[ ]*-Fu.*/lcl$' /etc/fpc.cfg
35 then
36 eerror "Your /etc/fpc.cfg automatically adds a LCL directory"
37 eerror "to the list of unit directories. This will break the"
38 eerror "build of lazarus."
39 die "don't set the LCL path in /etc/fpc.cfg"
40 fi
41
42 unpack ${A}
43 sed -e "s/@FPCVER@/${FPCVER}/" "${FILESDIR}"/${P}-fpcsrc.patch \
44 > "${T}"/fpcsrc.patch || die "could not sed fpcsrc patch"
45
46 cd "${S}"
47 epatch "${T}"/fpcsrc.patch
48}
49
50src_compile() {
51 LCL_PLATFORM=gtk2 emake -j1 || die "make failed!"
52}
53
54src_install() {
55 diropts -m0755
56 dodir /usr/share
57 # Using rsync to avoid unnecessary copies and cleaning...
58 # Note: *.o and *.ppu are needed
59 rsync -a \
60 --exclude="CVS" --exclude=".cvsignore" \
61 --exclude="*.ppw" --exclude="*.ppl" \
62 --exclude="*.ow" --exclude="*.a"\
63 --exclude="*.rst" --exclude=".#*" \
64 --exclude="*.~*" --exclude="*.bak" \
65 --exclude="*.orig" --exclude="*.rej" \
66 --exclude=".xvpics" --exclude="*.compiled" \
67 --exclude="killme*" --exclude=".gdb_hist*" \
68 "${S}" "${D}"usr/share \
69 || die "Unable to copy files!"
70
71 dosym ../share/lazarus/startlazarus /usr/bin/startlazarus
72 dosym ../lazarus/images/mainicon.xpm /usr/share/pixmaps/lazarus.xpm
73
74 make_desktop_entry startlazarus "Lazarus IDE" "lazarus.xpm" || die "Failed making desktop entry!"
75}