summaryrefslogtreecommitdiff
path: root/dev-libs/ibpp/ibpp-2.3.5.0.ebuild
Unidiff
Diffstat (limited to 'dev-libs/ibpp/ibpp-2.3.5.0.ebuild') (more/less context) (ignore whitespace changes)
-rw-r--r--dev-libs/ibpp/ibpp-2.3.5.0.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-libs/ibpp/ibpp-2.3.5.0.ebuild b/dev-libs/ibpp/ibpp-2.3.5.0.ebuild
new file mode 100644
index 0000000..02ffb39
--- a/dev/null
+++ b/dev-libs/ibpp/ibpp-2.3.5.0.ebuild
@@ -0,0 +1,44 @@
1# Copyright 1999-2006 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/dev-libs/ibpp/ibpp-2.3.4.0.ebuild,v 1.2 2006/03/19 22:31:31 halcy0n Exp $
4
5inherit eutils
6
7MY_P=${P//./-}-src
8
9DESCRIPTION="IBPP, a C++ client API for firebird 1.0"
10HOMEPAGE="http://www.ibpp.org/"
11SRC_URI="mirror://sourceforge/ibpp/${MY_P}.zip"
12
13LICENSE="MPL-1.1"
14SLOT="0"
15KEYWORDS="~x86 ~amd64"
16IUSE="debug"
17
18RDEPEND=">=dev-db/firebird-1.5.1"
19DEPEND="${RDEPEND}
20 app-arch/unzip"
21
22src_unpack() {
23 mkdir ${P}
24 cd ${P}
25 unpack ${A}
26 cd ${S}
27
28 epatch ${FILESDIR}/${P}-CXXFLAGS.patch
29 use amd64 && epatch ${FILESDIR}/${P}-amd64.patch
30}
31
32src_compile() {
33 emake \
34 $(use debug && echo 'DEBUG=1') \
35 || die "emake failed"
36}
37
38src_install() {
39 insinto /usr/include
40 doins ibpp.h || die "doins failed"
41 cd $(if use debug ; then echo debug ; else echo release ; fi)/linux || die
42 dolib.so libibpp.so || die "dolib.so failed"
43 dolib.a libibpp.a || die "dolib.a failed"
44}