summaryrefslogtreecommitdiff
path: root/dev-libs/mimetic/mimetic-0.9.1.ebuild
Unidiff
Diffstat (limited to 'dev-libs/mimetic/mimetic-0.9.1.ebuild') (more/less context) (ignore whitespace changes)
-rw-r--r--dev-libs/mimetic/mimetic-0.9.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-libs/mimetic/mimetic-0.9.1.ebuild b/dev-libs/mimetic/mimetic-0.9.1.ebuild
new file mode 100644
index 0000000..739b018
--- a/dev/null
+++ b/dev-libs/mimetic/mimetic-0.9.1.ebuild
@@ -0,0 +1,34 @@
1# Copyright 1999-2007 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2
3# $Header: $
4
5inherit eutils
6
7DESCRIPTION="MIME library written in C++ designed to be easy to use and integrate but yet fast and efficient."
8HOMEPAGE="http://codesink.org/mimetic_mime_library.html"
9SRC_URI="http://codesink.org/download/${P}.tar.gz"
10LICENSE="GPL-2"
11SLOT="0"
12KEYWORDS="~amd64 ~x86"
13
14IUSE="stlport doc examples"
15
16DEPEND="stlport? ( dev-libs/STLport )"
17
18src_compile() {
19 econf \
20 $(use stlport && echo --with-stlport) \
21 || die "econf failed"
22 emake || die "emake failed"
23 use doc && ( emake -C doc docs || die "emake docs failed" )
24}
25
26src_install() {
27 emake DESTDIR=${D} install || die "emake install failed"
28 dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README TODO
29 use doc && dohtml -r doc/html/*
30 if use examples ; then
31 docinto examples
32 dodoc examples/{README,TODO,test.msg,*.cxx,*.h}
33 fi
34}