summaryrefslogtreecommitdiff
path: root/net-im/jabberd/files/jabberd-2.1.11-r1.patch
Unidiff
Diffstat (limited to 'net-im/jabberd/files/jabberd-2.1.11-r1.patch') (more/less context) (ignore whitespace changes)
-rw-r--r--net-im/jabberd/files/jabberd-2.1.11-r1.patch251
1 files changed, 251 insertions, 0 deletions
diff --git a/net-im/jabberd/files/jabberd-2.1.11-r1.patch b/net-im/jabberd/files/jabberd-2.1.11-r1.patch
new file mode 100644
index 0000000..441163c
--- a/dev/null
+++ b/net-im/jabberd/files/jabberd-2.1.11-r1.patch
@@ -0,0 +1,251 @@
1diff --git a/c2s/main.c b/c2s/main.c
2index a86e571..0bf89e6 100644
3--- a/c2s/main.c
4+++ b/c2s/main.c
5@@ -698,6 +698,7 @@ JABBER_MAIN("jabberd2c2s", "Jabber 2 C2S", "Jabber Open Source Server: Client to
6 if(sess->ip != NULL) free(sess->ip);
7 if(sess->result != NULL) nad_free(sess->result);
8 if(sess->jid != NULL) jid_free(sess->jid);
9+ if(sess->rate != NULL) rate_free(sess->rate);
10
11 free(sess);
12 }
13diff --git a/configure.ac b/configure.ac
14index 099aec9..29dca26 100644
15--- a/configure.ac
16+++ b/configure.ac
17@@ -494,37 +494,48 @@ AM_CONDITIONAL(STORAGE_MYSQL, [test "x-$have_mysql" = "x-yes"])
18
19 # PostgreSQL
20 AC_ARG_ENABLE([pgsql],
21- AC_HELP_STRING([--enable-pgsql], [enable PostgreSQL auth/reg/storage support (no)]),
22- [enable_pgsql=$enableval have_pgsql=no],
23+ AC_HELP_STRING([--enable-pgsql],
24 +[enable PostgreSQL auth/reg/storage support, you can provide path to
25 +pg_config executable (no)]),
26+ [enable_pgsql="$enableval" have_pgsql=no],
27 [enable_pgsql=no have_pgsql=no])
28-if test "x-$enable_pgsql" = "x-yes" ; then
29- for i in /usr /usr/local /usr/local/pgsql ; do
30- for j in include include/pgsql include/postgres include/postgresql "" ; do
31- if test -r "$i/$j/libpq-fe.h" ; then
32- PGSQL_INCLUDE=$i/$j
33- fi
34- done
35- for lib in lib lib64 ; do
36- for j in $lib $lib/pgsql $lib/postgres $lib/postgresql "" ; do
37- if test -f "$i/$j/libpq.so" || test -f "$i/$j/libpq.a" ; then
38- PGSQL_LIBDIR=$i/$j
39- fi
40- done
41- done
42- done
43- AC_CHECK_LIB([pq], [PQsetdbLogin], [
44- have_pgsql=yes
45- if test "x-$PGSQL_INCLUDE" != "x-"; then
46- PGSQL_CFLAGS="-I $PGSQL_INCLUDE"
47- fi
48- if test "x-$PGSQL_LIBDIR" != "x-"; then
49- PGSQL_LIBS="-L$PGSQL_LIBDIR -lpq"
50- fi
51- AC_DEFINE(STORAGE_POSTGRES, 1, [Define to 1 if you want to use PostgreSQL for storage.])
52- ])
53- if test "x-$have_pgsql" != "x-yes" ; then
54- AC_MSG_ERROR([PostgreSQL support requested, but headers/libraries not found.])
55- fi
56+if test "x-$enable_pgsql" != "x-no" ; then
57 +if test -x "$enable_pgsql" ; then
58 + PGSQL_INCLUDE="$($enable_pgsql --includedir)"
59 + PGSQL_LIBDIR="$($enable_pgsql --libdir)"
60 + PGSQL_CFLAGS="-I$PGSQL_INCLUDE"
61 + PGSQL_LIBS="-L$PGSQL_LIBDIR -lpq"
62 + have_pgsql=yes
63 + AC_DEFINE([STORAGE_POSTGRES],[1],[Define to 1 if you want to use PostgreSQL for storage.])
64 + else# leave legacy detection intact for now
65 + for i in /usr /usr/local /usr/local/pgsql ; do
66 + for j in include include/pgsql include/postgres include/postgresql "" ; do
67 + if test -r "$i/$j/libpq-fe.h" ; then
68 + PGSQL_INCLUDE=$i/$j
69 + fi
70 + done
71 + for lib in lib lib64 ; do
72 + for j in $lib $lib/pgsql $lib/postgres $lib/postgresql "" ; do
73 + if test -f "$i/$j/libpq.so" || test -f "$i/$j/libpq.a" ; then
74 + PGSQL_LIBDIR=$i/$j
75 + fi
76 + done
77 + done
78 + done
79 + AC_CHECK_LIB([pq], [PQsetdbLogin], [
80 + have_pgsql=yes
81 + if test "x-$PGSQL_INCLUDE" != "x-"; then
82 + PGSQL_CFLAGS="-I $PGSQL_INCLUDE"
83 + fi
84 + if test "x-$PGSQL_LIBDIR" != "x-"; then
85 + PGSQL_LIBS="-L$PGSQL_LIBDIR -lpq"
86 + fi
87 + AC_DEFINE(STORAGE_POSTGRES, 1, [Define to 1 if you want to use PostgreSQL for storage.])
88 + ])
89 + if test "x-$have_pgsql" != "x-yes" ; then
90 + AC_MSG_ERROR([PostgreSQL support requested, but headers/libraries not found.])
91 + fi
92 +fi
93 fi
94 AC_SUBST(PGSQL_CFLAGS)
95 AC_SUBST(PGSQL_LIBS)
96diff --git a/mio/mio_impl.h b/mio/mio_impl.h
97index 6f72a5c..cabdc67 100644
98--- a/mio/mio_impl.h
99+++ b/mio/mio_impl.h
100@@ -226,8 +226,12 @@ static void _mio_run(mio_t m, int timeout)
101 {
102 mio_fd_t fd = MIO_ITERATOR_FD(m,iter);
103
104- /* skip dead slots */
105- if(FD(m,fd)->type == type_CLOSED) continue;
106+ /* deferred closing fd */
107+ if(FD(m,fd)->type == type_CLOSED)
108+ {
109+ MIO_FREE_FD(m, fd);
110+ continue;
111+ }
112
113 /* new conns on a listen socket */
114 if(FD(m,fd)->type == type_LISTEN && MIO_CAN_READ(m,iter))
115@@ -259,12 +263,6 @@ static void _mio_run(mio_t m, int timeout)
116 if(ACT(m, fd, action_WRITE, NULL) == 0)
117 MIO_UNSET_WRITE(m, FD(m,fd));
118 }
119-
120- /* deferred closing fd */
121- if(FD(m,fd)->type == type_CLOSED)
122- {
123- MIO_FREE_FD(m, fd);
124- }
125 }
126 }
127
128diff --git a/sm/main.c b/sm/main.c
129index 2f1439d..9f27829 100644
130--- a/sm/main.c
131+++ b/sm/main.c
132@@ -392,6 +392,7 @@ JABBER_MAIN("jabberd2sm", "Jabber 2 Session Manager", "Jabber Open Source Server
133 xhash_free(sm->acls);
134 xhash_free(sm->features);
135 xhash_free(sm->xmlns);
136+ xhash_free(sm->xmlns_refcount);
137 xhash_free(sm->users);
138
139 sx_free(sm->router);
140diff --git a/sm/mod_privacy.c b/sm/mod_privacy.c
141index 06f9e6e..5abf065 100644
142--- a/sm/mod_privacy.c
143+++ b/sm/mod_privacy.c
144@@ -205,7 +205,7 @@ static int _privacy_user_load(mod_instance_t mi, user_t user) {
145 continue;
146 }
147
148- pool_cleanup(zlist->p, free, zitem->jid);
149+ pool_cleanup(zlist->p, jid_free, zitem->jid);
150
151 log_debug(ZONE, "jid item with value '%s'", jid_full(zitem->jid));
152
153@@ -696,7 +696,7 @@ static mod_ret_t _privacy_in_sess(mod_instance_t mi, sess_t sess, pkt_t pkt) {
154 return -stanza_err_BAD_REQUEST;
155 }
156
157- pool_cleanup(p, free, zitem->jid);
158+ pool_cleanup(p, jid_free, zitem->jid);
159
160 log_debug(ZONE, "jid item with value '%s'", jid_full(zitem->jid));
161
162diff --git a/storage/authreg_pgsql.c b/storage/authreg_pgsql.c
163index 1f15e83..8d3cf88 100644
164--- a/storage/authreg_pgsql.c
165+++ b/storage/authreg_pgsql.c
166@@ -304,7 +304,7 @@ int _ar_pgsql_check_sql( authreg_t ar, char * sql, char * types ) {
167
168 /** start me up */
169 int ar_init(authreg_t ar) {
170- char *host, *port, *dbname, *user, *pass;
171+ char *host, *port, *dbname, *user, *pass, *conninfo;
172 char *create, *select, *setpassword, *delete;
173 char *table, *username, *realm;
174 char *template;
175@@ -391,15 +391,22 @@ int ar_init(authreg_t ar) {
176 free(setpassword);
177 free(delete);
178
179- host = config_get_one(ar->c2s->config, "authreg.pgsql.host", 0);
180- port = config_get_one(ar->c2s->config, "authreg.pgsql.port", 0);
181- dbname = config_get_one(ar->c2s->config, "authreg.pgsql.dbname", 0);
182- user = config_get_one(ar->c2s->config, "authreg.pgsql.user", 0);
183- pass = config_get_one(ar->c2s->config, "authreg.pgsql.pass", 0);
184-
185- log_debug( ZONE, "pgsql connecting as '%s' to database '%s' on %s:%s", user, dbname, host, port );
186+ conninfo = config_get_one(ar->c2s->config,"authreg.pgsql.conninfo",0);
187+ if(conninfo) {
188 +conn = PQconnect(conninfo);
189 +/* don't log connection info for it can contain password */
190 +log_debug( ZONE, "pgsql connecting to the databse");
191+ }else{
192 +/* compatibility settings */
193 +host = config_get_one(ar->c2s->config, "authreg.pgsql.host", 0);
194 +port = config_get_one(ar->c2s->config, "authreg.pgsql.port", 0);
195 +dbname = config_get_one(ar->c2s->config, "authreg.pgsql.dbname", 0);
196 +user = config_get_one(ar->c2s->config, "authreg.pgsql.user", 0);
197 +pass = config_get_one(ar->c2s->config, "authreg.pgsql.pass", 0);
198 +log_debug( ZONE, "pgsql connecting as '%s' to database '%s' on %s:%s", user, dbname, host, port );
199 +conn = PQsetdbLogin(host, port, NULL, NULL, dbname, user, pass);
200+ }
201
202- conn = PQsetdbLogin(host, port, NULL, NULL, dbname, user, pass);
203 if(conn == NULL) {
204 log_write(ar->c2s->log, LOG_ERR, "pgsql: unable to allocate database connection state");
205 return 1;
206diff --git a/sx/sasl_gsasl.c b/sx/sasl_gsasl.c
207index 69eeec2..0036c0f 100644
208--- a/sx/sasl_gsasl.c
209+++ b/sx/sasl_gsasl.c
210@@ -338,6 +338,7 @@ static void _sx_sasl_client_process(sx_t s, sx_plugin_t p, Gsasl_session *sd, ch
211 if(ret != GSASL_OK && ret != GSASL_NEEDS_MORE) {
212 _sx_debug(ZONE, "gsasl_step failed, no sasl for this conn; (%d): %s", ret, gsasl_strerror(ret));
213 _sx_nad_write(s, _sx_sasl_failure(s, _sasl_err_MALFORMED_REQUEST), 0);
214+ if(buf != NULL) free(buf);
215 return;
216 }
217 }
218@@ -350,6 +351,7 @@ static void _sx_sasl_client_process(sx_t s, sx_plugin_t p, Gsasl_session *sd, ch
219 if(ret != GSASL_OK && ret != GSASL_NEEDS_MORE) {
220 _sx_debug(ZONE, "gsasl_step failed, no sasl for this conn; (%d): %s", ret, gsasl_strerror(ret));
221 _sx_nad_write(s, _sx_sasl_failure(s, _sasl_err_MALFORMED_REQUEST), 0);
222+ if(buf != NULL) free(buf);
223 return;
224 }
225
226diff --git a/util/jid.c b/util/jid.c
227index 695b15f..f4b0021 100644
228--- a/util/jid.c
229+++ b/util/jid.c
230@@ -332,7 +332,7 @@ static jid_t jid_reset_components_internal(jid_t jid, const unsigned char *node,
231 else {
232 /* allocate new data buffer */
233 jid->jid_data_len = node_l+domain_l+resource_l+3;
234- jid->jid_data = malloc(jid->jid_data_len);
235+ jid->jid_data = realloc(jid->jid_data, jid->jid_data_len);
236 }
237
238 /* copy to buffer */
239diff --git a/util/nad.c b/util/nad.c
240index 2ac8670..eec3c17 100644
241--- a/util/nad.c
242+++ b/util/nad.c
243@@ -61,7 +61,7 @@ static void _nad_ptr_check(const char *func, nad_t nad) {
244 #define _nad_ptr_check(func,nad)
245 #endif
246
247-#define BLOCKSIZE 1024
248+#define BLOCKSIZE 128
249
250 /** internal: do and return the math and ensure it gets realloc'd */
251 static int _nad_realloc(void **oblocks, int len)