summaryrefslogtreecommitdiff
path: root/x11-plugins/asmem/asmem-1.10-r1.ebuild
Unidiff
Diffstat (limited to 'x11-plugins/asmem/asmem-1.10-r1.ebuild') (more/less context) (ignore whitespace changes)
-rw-r--r--x11-plugins/asmem/asmem-1.10-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/x11-plugins/asmem/asmem-1.10-r1.ebuild b/x11-plugins/asmem/asmem-1.10-r1.ebuild
new file mode 100644
index 0000000..caba379
--- a/dev/null
+++ b/x11-plugins/asmem/asmem-1.10-r1.ebuild
@@ -0,0 +1,39 @@
1# Copyright 1999-2006 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/x11-plugins/asmem/asmem-1.10-r1.ebuild,v 1.6 2006/11/27 12:52:26 gustavoz Exp $
4
5inherit eutils toolchain-funcs
6
7IUSE="jpeg"
8DESCRIPTION="Memory statistics monitor utility for X Windows"
9SRC_URI="http://www.tigr.net/afterstep/download/asmem/${P}.tar.gz"
10HOMEPAGE="http://www.tigr.net"
11SLOT="0"
12LICENSE="GPL-2"
13KEYWORDS="amd64 ppc ppc64 sparc x86"
14
15RDEPEND="x11-libs/libXpm
16 x11-libs/libSM
17 jpeg? ( media-libs/jpeg )"
18
19DEPEND="${RDEPEND}
20 x11-proto/xproto"
21
22src_unpack() {
23 unpack ${A}
24 cd "${S}"
25 epatch "${FILESDIR}"/${P}-gentoo.patch
26}
27
28src_compile() {
29 econf $(use_enable jpeg) || die "econf failed"
30 emake CC="$(tc-getCC)" || die "emake failed"
31}
32
33src_install() {
34 dodir /usr/bin
35 dodir /usr/share/man/man1
36
37 emake DESTDIR="${D}" install || die
38 dodoc CHANGES README
39}