summaryrefslogtreecommitdiffabout
path: root/pwmanager/Makefile.am
authorulf69 <ulf69>2004-09-15 17:53:22 (UTC)
committer ulf69 <ulf69>2004-09-15 17:53:22 (UTC)
commitd3925ba5bd25224bc4a60d3d6a107c464994a1ea (patch) (side-by-side diff)
tree60f69da1d2b79ee3081e7ef5c09a46470ca6eda0 /pwmanager/Makefile.am
parentce83a3479d23b9e8a59c745ccd0a0b14f64ef4e8 (diff)
downloadkdepimpi-d3925ba5bd25224bc4a60d3d6a107c464994a1ea.zip
kdepimpi-d3925ba5bd25224bc4a60d3d6a107c464994a1ea.tar.gz
kdepimpi-d3925ba5bd25224bc4a60d3d6a107c464994a1ea.tar.bz2
initial revision
Diffstat (limited to 'pwmanager/Makefile.am') (more/less context) (ignore whitespace changes)
-rw-r--r--pwmanager/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/pwmanager/Makefile.am b/pwmanager/Makefile.am
new file mode 100644
index 0000000..91202d2
--- a/dev/null
+++ b/pwmanager/Makefile.am
@@ -0,0 +1,26 @@
+SUBDIRS = pwmanager
+
+AUTOMAKE_OPTIONS = dist-bzip2
+
+MAINTAINERCLEANFILES = subdirs configure.in acinclude.m4 configure.files
+
+EXTRA_DIST = rpm debian file-format keycard-format COPYING.LGPL CodingStyle
+
+# target to generate a .pot file manually (without scripty)
+messages_manually:
+ extractrc `find . -name "*.rc" -o -name "*.ui"` > rc.cpp
+ LIST=`find . -name \*.h -o -name \*.hh -o -name \*.H -o -name \*.hxx -o -name \*.hpp -o -name \*.cpp -o -name \*.cc -o -name \*.cxx -o -name \*.ecpp -o -name \*.C`; \
+ if test -n "$$LIST"; then \
+ xgettext -ki18n -kI18N_NOOP -o ./pwmanager.pot $$LIST ; \
+ fi
+ rm -f rc.cpp
+
+# target for automatic .pot file merging by scripty.
+# disable this target to disable automatic merging.
+#messages: rc.cpp
+# $(EXTRACTRC) `find . -name "*.rc" -o -name "*.ui"` > rc.cpp
+# LIST=`find . -name \*.h -o -name \*.hh -o -name \*.H -o -name \*.hxx -o -name \*.hpp -o -name \*.cpp -o -name \*.cc -o -name \*.cxx -o -name \*.ecpp -o -name \*.C`; \
+# if test -n "$$LIST"; then \
+# $(XGETTEXT) $$LIST -o $(podir)/pwmanager.pot; \
+# fi
+# rm -f rc.cpp