summaryrefslogtreecommitdiffabout
path: root/pwmanager/Makefile.am
Side-by-side diff
Diffstat (limited to 'pwmanager/Makefile.am') (more/less context) (ignore whitespace changes)
-rw-r--r--pwmanager/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/pwmanager/Makefile.am b/pwmanager/Makefile.am
new file mode 100644
index 0000000..91202d2
--- a/dev/null
+++ b/pwmanager/Makefile.am
@@ -0,0 +1,26 @@
+SUBDIRS = pwmanager
+
+AUTOMAKE_OPTIONS = dist-bzip2
+
+MAINTAINERCLEANFILES = subdirs configure.in acinclude.m4 configure.files
+
+EXTRA_DIST = rpm debian file-format keycard-format COPYING.LGPL CodingStyle
+
+# target to generate a .pot file manually (without scripty)
+messages_manually:
+ extractrc `find . -name "*.rc" -o -name "*.ui"` > rc.cpp
+ LIST=`find . -name \*.h -o -name \*.hh -o -name \*.H -o -name \*.hxx -o -name \*.hpp -o -name \*.cpp -o -name \*.cc -o -name \*.cxx -o -name \*.ecpp -o -name \*.C`; \
+ if test -n "$$LIST"; then \
+ xgettext -ki18n -kI18N_NOOP -o ./pwmanager.pot $$LIST ; \
+ fi
+ rm -f rc.cpp
+
+# target for automatic .pot file merging by scripty.
+# disable this target to disable automatic merging.
+#messages: rc.cpp
+# $(EXTRACTRC) `find . -name "*.rc" -o -name "*.ui"` > rc.cpp
+# LIST=`find . -name \*.h -o -name \*.hh -o -name \*.H -o -name \*.hxx -o -name \*.hpp -o -name \*.cpp -o -name \*.cc -o -name \*.cxx -o -name \*.ecpp -o -name \*.C`; \
+# if test -n "$$LIST"; then \
+# $(XGETTEXT) $$LIST -o $(podir)/pwmanager.pot; \
+# fi
+# rm -f rc.cpp