-rw-r--r-- | pwmanager/Makefile.am | 26 |
1 files changed, 26 insertions, 0 deletions
diff --git a/pwmanager/Makefile.am b/pwmanager/Makefile.am new file mode 100644 index 0000000..91202d2 --- a/dev/null +++ b/pwmanager/Makefile.am | |||
@@ -0,0 +1,26 @@ | |||
1 | SUBDIRS = pwmanager | ||
2 | |||
3 | AUTOMAKE_OPTIONS = dist-bzip2 | ||
4 | |||
5 | MAINTAINERCLEANFILES = subdirs configure.in acinclude.m4 configure.files | ||
6 | |||
7 | EXTRA_DIST = rpm debian file-format keycard-format COPYING.LGPL CodingStyle | ||
8 | |||
9 | # target to generate a .pot file manually (without scripty) | ||
10 | messages_manually: | ||
11 | extractrc `find . -name "*.rc" -o -name "*.ui"` > rc.cpp | ||
12 | LIST=`find . -name \*.h -o -name \*.hh -o -name \*.H -o -name \*.hxx -o -name \*.hpp -o -name \*.cpp -o -name \*.cc -o -name \*.cxx -o -name \*.ecpp -o -name \*.C`; \ | ||
13 | if test -n "$$LIST"; then \ | ||
14 | xgettext -ki18n -kI18N_NOOP -o ./pwmanager.pot $$LIST ; \ | ||
15 | fi | ||
16 | rm -f rc.cpp | ||
17 | |||
18 | # target for automatic .pot file merging by scripty. | ||
19 | # disable this target to disable automatic merging. | ||
20 | #messages: rc.cpp | ||
21 | #$(EXTRACTRC) `find . -name "*.rc" -o -name "*.ui"` > rc.cpp | ||
22 | #LIST=`find . -name \*.h -o -name \*.hh -o -name \*.H -o -name \*.hxx -o -name \*.hpp -o -name \*.cpp -o -name \*.cc -o -name \*.cxx -o -name \*.ecpp -o -name \*.C`; \ | ||
23 | #if test -n "$$LIST"; then \ | ||
24 | # $(XGETTEXT) $$LIST -o $(podir)/pwmanager.pot; \ | ||
25 | #fi | ||
26 | #rm -f rc.cpp | ||