summaryrefslogtreecommitdiff
path: root/libopie2
Unidiff
Diffstat (limited to 'libopie2') (more/less context) (ignore whitespace changes)
-rw-r--r--libopie2/opiepim/backend/otodoaccesssql.cpp11
1 files changed, 8 insertions, 3 deletions
diff --git a/libopie2/opiepim/backend/otodoaccesssql.cpp b/libopie2/opiepim/backend/otodoaccesssql.cpp
index 6f65c48..12a8bea 100644
--- a/libopie2/opiepim/backend/otodoaccesssql.cpp
+++ b/libopie2/opiepim/backend/otodoaccesssql.cpp
@@ -459,2 +459,4 @@ OPimTodo OPimTodoAccessBackendSQL::find(int uid ) const{
459} 459}
460
461// Remember: uid is already in the list of uids, called ints !
460OPimTodo OPimTodoAccessBackendSQL::find( int uid, const QArray<int>& ints, 462OPimTodo OPimTodoAccessBackendSQL::find( int uid, const QArray<int>& ints,
@@ -470,3 +472,3 @@ OPimTodo OPimTodoAccessBackendSQL::find( int uid, const QArray<int>& ints,
470 /* forward */ 472 /* forward */
471 case 0: // FIXME: Not a good style to use magic numbers here (eilers) 473 case Frontend::Forward:
472 for (uint i = cur; i < ints.count() && size < CACHE; i++ ) { 474 for (uint i = cur; i < ints.count() && size < CACHE; i++ ) {
@@ -478,3 +480,3 @@ OPimTodo OPimTodoAccessBackendSQL::find( int uid, const QArray<int>& ints,
478 /* reverse */ 480 /* reverse */
479 case 1: // FIXME: Not a good style to use magic numbers here (eilers) 481 case Frontend::Reverse:
480 for (uint i = cur; i != 0 && size < CACHE; i-- ) { 482 for (uint i = cur; i != 0 && size < CACHE; i-- ) {
@@ -485,2 +487,3 @@ OPimTodo OPimTodoAccessBackendSQL::find( int uid, const QArray<int>& ints,
485 } 487 }
488
486 search.resize( size ); 489 search.resize( size );
@@ -491,4 +494,6 @@ OPimTodo OPimTodoAccessBackendSQL::find( int uid, const QArray<int>& ints,
491 494
492 return todo( res ); 495 todo( res ); //FIXME: Don't like polymorphism here. It makes the code hard to read here..(eilers)
496 return cacheFind( uid );
493} 497}
498
494void OPimTodoAccessBackendSQL::clear() { 499void OPimTodoAccessBackendSQL::clear() {