summaryrefslogtreecommitdiff
path: root/noncore/games/kbill/Makefile.am
Unidiff
Diffstat (limited to 'noncore/games/kbill/Makefile.am') (more/less context) (ignore whitespace changes)
-rw-r--r--noncore/games/kbill/Makefile.am59
1 files changed, 59 insertions, 0 deletions
diff --git a/noncore/games/kbill/Makefile.am b/noncore/games/kbill/Makefile.am
new file mode 100644
index 0000000..a09ea13
--- a/dev/null
+++ b/noncore/games/kbill/Makefile.am
@@ -0,0 +1,59 @@
1####### kdevelop will overwrite this part!!! (begin)##########
2bin_PROGRAMS = kbill
3kbill_SOURCES = inputbox.cpp UI.cc Spark.cc Scorelist.cc Picture.cc Network.cc Monster.cc MCursor.cc Library.cc Horde.cc Game.cc Computer.cc Cable.cc Bucket.cc field.cpp kbill.cpp
4kbill_LDADD = $(LIB_KDEUI) $(LIB_KDECORE) $(LIB_QT) $(LIBSOCKET) $(LIB_KIO)
5
6
7SUBDIRS = docs bitmaps pixmaps
8
9EXTRA_DIST = kbill.cpp kbill.h kbill.kdelnk kbill.xpm mini-kbill.xpm field.cpp field.h Bucket.cc Bucket.h Cable.cc Cable.h Computer.cc Computer.h Game.cc Game.h Horde.cc Horde.h Library.cc Library.h MCursor.cc MCursor.h Monster.cc \ Monster.h Network.cc Network.h Picture.cc Picture.h Scorelist.cc Scorelist.h Spark.cc Spark.h \ Strings.h UI.cc objects.h inputbox.cpp inputbox.h
10
11install-data-local:
12 $(mkinstalldirs) $(kde_appsdir)/Games/
13 $(INSTALL_DATA) kbill.kdelnk $(kde_appsdir)/Games/kbill.kdelnk
14 $(mkinstalldirs) $(kde_icondir)/
15 $(INSTALL_DATA) kbill.xpm $(kde_icondir)/kbill.xpm
16 $(mkinstalldirs) $(kde_minidir)/
17 $(INSTALL_DATA) mini-kbill.xpm $(kde_minidir)/kbill.xpm
18 $(mkinstalldirs) $(kde_datadir)/kbill/
19 $(INSTALL_DATA) scores $(kde_datadir)/kbill/scores
20
21uninstall-local:
22 -rm -f $(kde_appsdir)/Games/kbill.kdelnk
23 -rm -f $(kde_icondir)/kbill.xpm
24 -rm -f $(kde_minidir)/kbill.xpm
25 -rm -f $(kde_datadir)/kbill/scores
26
27####### kdevelop will overwrite this part!!! (end)############
28# this 10 paths are KDE specific. Use them:
29# kde_htmldir Where your docs should go to. (contains lang subdirs)
30# kde_appsdir Where your application file (.kdelnk) should go to.
31# kde_icondir Where your icon should go to.
32# kde_minidir Where your mini icon should go to.
33# kde_datadir Where you install application data. (Use a subdir)
34# kde_locale Where translation files should go to.(contains lang subdirs)
35# kde_cgidir Where cgi-bin executables should go to.
36# kde_confdir Where config files should go to.
37# kde_mimedir Where mimetypes should go to.
38# kde_toolbardir Where general toolbar icons should go to.
39# kde_wallpaperdir Where general wallpapers should go to.
40
41# set the include path for X, qt and KDE
42INCLUDES= $(all_includes)
43# claim, which subdirectories you want to install
44# you can add here more. This one gets installed
45bin_PROGRAMS = kbill
46
47kbill_METASOURCES = USE_AUTOMOC
48
49# the library search path.
50kbill_LDFLAGS = $(all_libraries) $(KDE_RPATH)
51
52# them while "make clean", use CLEANFILES
53DISTCLEANFILES = $(kbill_METASOURCES)
54
55# make messages.po. Move this one to ../po/ and "make merge" in po
56# the -x is for skipping messages already translated in kdelibs
57messages:
58 $(XGETTEXT) -C -ki18n -x $(KDEDIR)/include/kde.pot `find . -name \*.h -o -name \*.cpp -o -name \*.cc` -o ../po/kbill.pot
59