Age | Commit message (Collapse) | Author | Files | Lines |
---|---|---|---|---|
2002-12-11 | Added save and load replays | andyq | 1 | -4/+97 |
2002-12-11 | - copyright notice fixlet | simon | 5 | -15/+76 |
2002-12-11 | - collect arguments passed to the skin loading into a structure | simon | 6 | -24/+24 |
2002-12-11 | - added a skin cache and a threaded skin loader. looks like the latter | simon | 3 | -4/+155 |
we have to disable though, because pure image loading with qt is anything but threadsafe :( | ||||
2002-12-11 | - expose information about the buttons | simon | 4 | -2/+28 |
2002-12-11 | Added dialogbox to notify that the vcard was unable to read | eilers | 1 | -0/+6 |
2002-12-11 | Added icons | benmeyer | 3 | -3/+3 |
2002-12-11 | Implemented dialog box for every received vcard to get user permission | eilers | 2 | -4/+30 |
2002-12-11 | Adjust for the move of the init script over | kergoth | 1 | -1/+1 |
2002-12-11 | Removed mimetype | andyq | 1 | -1/+0 |
2002-12-11 | - ah, forgot to remove this unused code | simon | 1 | -19/+0 |
2002-12-11 | When did this appear? | mickeyl | 1 | -0/+0 |
2002-12-11 | - include wellenreiter.desktop in .pro-file | mickeyl | 3 | -3/+3 |
- daemon now uses CARD_TYPE defined in header file (was: hardcoded CARD_TYPE_NG) (BTW. - we really need argument parsing and the config stuff ASAP) - default CARD_TYPE now is CARD_TYPE_HOSTAP | ||||
2002-12-11 | - roll back the threaded xine initialization, the mediaplayer initialization | simon | 11 | -241/+84 |
state and the PlayButton change set - instead load the audio-/video widget and the xine control on-demand. much faster and much simpler for startup | ||||
2002-12-11 | - Reduce g++ warnings. | mickeyl | 2 | -7/+7 |
- Depend on libpcap | ||||
2002-12-11 | - less code duplication. code from resizeEvent is now shared as well as | simon | 4 | -41/+42 |
the image composing method and the pixmap mask helper | ||||
2002-12-11 | - moved default skin name reading over to skin class | simon | 3 | -10/+26 |
2002-12-11 | fix for g++ complaining about different linking schemes: | mickeyl | 2 | -2/+10 |
/usr/include/net/bpf.h:408: previous declaration of `u_int bpf_filter(bpf_insn*, u_char*, unsigned int, unsigned int)' with C++ linkage /usr/include/pcap.h:201: conflicts with new declaration with C linkage /usr/include/net/bpf.h:407: previous declaration of `int bpf_validate(bpf_insn*, int)' with C++ linkage /usr/include/pcap.h:202: conflicts with new declaration with C linkage | ||||
2002-12-11 | - minor cleanup | simon | 2 | -7/+5 |
2002-12-11 | - oops, do the right cast in the gamma set method | simon | 1 | -1/+1 |
2002-12-11 | - slight simplification in the API | simon | 4 | -12/+11 |
2002-12-11 | - button mask composing moved to Skin class | simon | 4 | -27/+41 |
2002-12-11 | - starting with skin preloading | simon | 2 | -6/+37 |
2002-12-11 | - moved the remaining pieces of image/pixmap loading to the Skin class | simon | 4 | -16/+23 |
2002-12-11 | - more image loading functionality moved to the Skin class | simon | 3 | -2/+17 |
2002-12-11 | - starting to factor out the actual skin image loading into a separate | simon | 4 | -3/+48 |
class | ||||
2002-12-11 | changed to new pda icon | llornkcor | 1 | -1/+1 |
2002-12-11 | added | llornkcor | 1 | -0/+0 |
2002-12-11 | - less qimage<>qpixmap conversions | simon | 1 | -5/+6 |
2002-12-11 | - slight simplification of XineControl constructor | simon | 5 | -18/+37 |
- fixed a race between the video resizing and the xine initialization | ||||
2002-12-11 | - removed unused variable | simon | 1 | -1/+0 |
2002-12-11 | - step three to make it compile with gcc2 | simon | 1 | -0/+1 |
2002-12-11 | - gcc2 is not my friend, given that it can't deal with friend declarations | simon | 2 | -12/+11 |
properly :) (a.k.a: make it compile with gcc2, step 2) | ||||
2002-12-11 | - make it compile for gcc2: step1 | simon | 2 | -10/+9 |
2002-12-11 | max inactive minutes to 1 day - 1440 minutes | harlekin | 1 | -0/+1 |
2002-12-11 | - added bool Thread::isRunning() const | simon | 2 | -0/+8 |
2002-12-11 | - make more use of the Resource::* api for loading the data | simon | 1 | -2/+2 |
2002-12-11 | applied a patch from "Tais M. Hansen" <tais.hansen@osd.dk> to add danish | sandman | 6 | -4/+24 |
language support | ||||
2002-12-11 | - centralize more of the skin loading code, so it can be factored out later | simon | 4 | -22/+28 |
more easily | ||||
2002-12-11 | Added danish translations. | mellen | 1 | -0/+64 |
2002-12-11 | - moved the shared button up/down image variables into the base class | simon | 5 | -22/+16 |
- removed some unused variables | ||||
2002-12-11 | Added danish translations. | mellen | 1 | -0/+102 |
2002-12-11 | Added danish translation. | mellen | 1 | -0/+2 |
2002-12-11 | - initialized xine in a background thread. much time is still spend in | simon | 5 | -5/+42 |
skin loading though. | ||||
2002-12-11 | fix for a stupid bug .. op1 wants to strip the extension, but instead | sandman | 2 | -9/+23 |
stripps everything after the first '.'. So filenames like "02. foobar.mp3" become "02" | ||||
2002-12-11 | - added initialize states to MediaPlayerState | simon | 6 | -6/+68 |
- the play button is now of type PlayButton, inheritting from ToolButton and checking the media player initialization state in setEnabled | ||||
2002-12-10 | - added an m_initialized flag and a guard for it, along with an | simon | 2 | -1/+71 |
assertion method called from all methods that access variables depending on initialization (basically all :) | ||||
2002-12-10 | added a little debug output to the image loading routine to aid in finding | sandman | 1 | -0/+2 |
application startup time problems | ||||
2002-12-10 | - small code cleanup | sandman | 1 | -22/+21 |
- finally we get rid of the "no image/text codecs" message at startup !!! | ||||
2002-12-10 | not needed anymore | sandman | 1 | -15/+0 |