Age | Commit message (Expand) | Author | Files | Lines |
2002-12-09 | - migrating from a button vector to a button map | simon | 3 | -17/+18 |
2002-12-09 | - merged the two button setup loops | simon | 1 | -10/+8 |
2002-12-09 | - merged the separate mask and pixmap arrays into the Button structure | simon | 2 | -19/+15 |
2002-12-09 | - moving some variables to the base class | simon | 2 | -6/+7 |
2002-12-09 | small fixes. | mickeyl | 3 | -1/+3 |
2002-12-09 | Wellenreiter is now fully integrated into the Opie build environment. | mickeyl | 10 | -11/+51 |
2002-12-09 | - oops, buttonType is a bad name for a variable, given its redundancy | simon | 3 | -7/+7 |
2002-12-09 | - re-organizing a bit the button storage. more to come. | simon | 2 | -21/+28 |
2002-12-09 | - isToggle is now an enum ButtonType { NormalButton, ToggleButton }; | simon | 3 | -13/+10 |
2002-12-09 | - another hardcoded number removed :) | simon | 1 | -1/+1 |
2002-12-09 | - buttonPixUp/Down are now vectors, too | simon | 2 | -18/+10 |
2002-12-09 | - use a vector to store the masks | simon | 2 | -11/+12 |
2002-12-09 | - one global variable less | simon | 2 | -4/+4 |
2002-12-09 | switch (mouse) { | simon | 1 | -4/+4 |
2002-12-09 | - replaced currentFileListView method with a variable | simon | 2 | -17/+12 |
2002-12-09 | - use xine_set_param( ..., XINE_PARAM_SPEED, with XINE_SPEED_PAUSE and | simon | 3 | -8/+4 |
2002-12-09 | - Key_Space triggers togglePaused() | simon | 1 | -9/+1 |
2002-12-08 | Fixed saving of new checkbooks and incorrect setting of notes. | drw | 2 | -1/+7 |
2002-12-08 | - synchronizing the button indices a bit more with the audiowidget | simon | 2 | -6/+6 |
2002-12-08 | - switched from inlined logo to png | mickeyl | 3 | -1066/+23 |
2002-12-08 | removed some clumsy workarounds for old (unpatched) libqte's | sandman | 1 | -12/+3 |
2002-12-08 | - merged the two duplicated toggleButton methods into a shared one | simon | 6 | -17/+9 |
2002-12-08 | - oops, forgot to commit this one | simon | 1 | -0/+6 |
2002-12-08 | - some preparations for further code cleanups for paintButton calls | simon | 5 | -14/+17 |
2002-12-08 | - moved the duplicated code for checking whether the mouse is over a | simon | 4 | -12/+12 |
2002-12-08 | - merged xoff/yoff into a QPointe member variable, shared in the base class | simon | 5 | -17/+17 |
2002-12-08 | operator new is still completly useless in newer gcc 2.95 toolchains | sandman | 1 | -3/+0 |
2002-12-08 | - made XineControl independent from VideoWidget | simon | 3 | -12/+11 |
2002-12-08 | - share the imgButtonMask member variable in the base class | simon | 5 | -14/+14 |
2002-12-08 | - no need to include audio and videowidget.h here | simon | 1 | -2/+0 |
2002-12-08 | - share the buttons data in a buttons member variable in the base class | simon | 5 | -50/+48 |
2002-12-08 | - #include cleanup | simon | 1 | -7/+0 |
2002-12-08 | - I'm re-using code from the others, so add their copyright :) | simon | 2 | -0/+6 |
2002-12-08 | - unused variables removed | simon | 3 | -39/+1 |
2002-12-08 | the patch was reverse - fixed now | sandman | 1 | -4/+4 |
2002-12-08 | - made audioButtons a member variable here, too | simon | 2 | -4/+26 |
2002-12-08 | - made videoButtons a member variable instead of a global one | simon | 3 | -5/+29 |
2002-12-08 | This fixes the overlapping popupmenu problem. Qt/E chooses the lower | sandman | 1 | -0/+11 |
2002-12-08 | removed libpreload | sandman | 1 | -1/+0 |
2002-12-08 | added missing includes | sandman | 1 | -0/+4 |
2002-12-08 | - merged duplicated MediaButton definition into common MediaWidget::Button | simon | 3 | -9/+13 |
2002-12-08 | - minor cleanup | simon | 2 | -10/+15 |
2002-12-08 | - properly shut down xine in the destructor. fixes crashes when switching | simon | 1 | -0/+7 |
2002-12-08 | - when the file list view is visible only enable the play button if there | simon | 3 | -0/+40 |
2002-12-08 | started work on logwindow and hexwindow | mickeyl | 8 | -92/+176 |
2002-12-08 | - pro-file for future integration of the daemon | mickeyl | 2 | -4/+14 |
2002-12-08 | - new icons (based on Max's artwork) | mickeyl | 8 | -0/+9 |
2002-12-08 | - new networks finally show up in the GUI | mickeyl | 13 | -44/+1448 |
2002-12-08 | fix | tille | 1 | -1/+4 |
2002-12-08 | added combo for default email | tille | 3 | -25/+44 |