Age | Commit message (Collapse) | Author | Files | Lines |
---|---|---|---|---|
2002-12-11 | Add back in the main networksetup icon.. | kergoth | 3 | -3/+3 |
2002-12-11 | buttons centered again | harlekin | 1 | -29/+29 |
2002-12-11 | - skins are now pre-loaded in the background (step by step) | simon | 5 | -31/+148 |
2002-12-11 | Just compiled and tested the first version actually running on arm-linux. | mickeyl | 1 | -7/+56 |
This is pre-alpha work, but it is running - if you have an orinoco based card as interface wlan0. Ad-hoc mode is buggy yet, Config in progress... :) | ||||
2002-12-11 | Don't link libwellenreiter against Qt. | mickeyl | 1 | -5/+1 |
2002-12-11 | Add wlan stuff | benmeyer | 2 | -0/+10 |
2002-12-11 | Fixed ad-hco bug | benmeyer | 2 | -6/+12 |
2002-12-11 | Key accell | benmeyer | 4 | -22/+20 |
2002-12-11 | New cleaner layout | benmeyer | 6 | -230/+212 |
2002-12-11 | - make the cache work as expected | simon | 1 | -4/+35 |
2002-12-11 | Added PDF url | benmeyer | 2 | -0/+6 |
2002-12-11 | Now will display the channel and not the freqency | benmeyer | 8 | -8/+56 |
2002-12-11 | create opie startup script links in postinst, remove in prerm, instead of ↵ | kergoth | 4 | -3/+17 |
including the link in the ipk | ||||
2002-12-11 | Cleaned up ui files so tab is in correct order | benmeyer | 10 | -800/+140 |
2002-12-11 | - SkinCache now operates on SkinData instead of single images | simon | 2 | -21/+18 |
2002-12-11 | - disable cache temporarily | simon | 2 | -4/+11 |
2002-12-11 | No need for debug output anymore ... it works now | sandman | 1 | -6/+6 |
2002-12-11 | valgrind complained and here are some off-by-1 fixes | sandman | 1 | -3/+4 |
2002-12-11 | - moved the skin cache into the .cpp file | simon | 2 | -16/+16 |
2002-12-11 | QBusyBar::~QBusyBar ( ) | simon | 1 | -0/+1 |
{ + delete [] m_fadecols; | ||||
2002-12-11 | - set the correct status on the fullscreen toggle button when returning | simon | 1 | -0/+1 |
from fullscreen mode | ||||
2002-12-11 | Added check for no replay file on loading and fixed bugs where you could ↵ | andyq | 1 | -4/+13 |
screw up the replay by pressing stuff | ||||
2002-12-11 | Updated help | andyq | 1 | -0/+7 |
2002-12-11 | - restructing a bit the skin data storage, in preparation for cache | simon | 2 | -27/+41 |
improvements | ||||
2002-12-11 | Added new methods and members for replay loading and saving | andyq | 1 | -0/+3 |
2002-12-11 | Added save and load replays | andyq | 1 | -4/+97 |
2002-12-11 | - copyright notice fixlet | simon | 5 | -15/+76 |
2002-12-11 | - collect arguments passed to the skin loading into a structure | simon | 6 | -24/+24 |
2002-12-11 | - added a skin cache and a threaded skin loader. looks like the latter | simon | 3 | -4/+155 |
we have to disable though, because pure image loading with qt is anything but threadsafe :( | ||||
2002-12-11 | - expose information about the buttons | simon | 4 | -2/+28 |
2002-12-11 | Added dialogbox to notify that the vcard was unable to read | eilers | 1 | -0/+6 |
2002-12-11 | Added icons | benmeyer | 3 | -3/+3 |
2002-12-11 | Implemented dialog box for every received vcard to get user permission | eilers | 2 | -4/+30 |
2002-12-11 | Adjust for the move of the init script over | kergoth | 1 | -1/+1 |
2002-12-11 | Removed mimetype | andyq | 1 | -1/+0 |
2002-12-11 | - ah, forgot to remove this unused code | simon | 1 | -19/+0 |
2002-12-11 | When did this appear? | mickeyl | 1 | -0/+0 |
2002-12-11 | - include wellenreiter.desktop in .pro-file | mickeyl | 3 | -3/+3 |
- daemon now uses CARD_TYPE defined in header file (was: hardcoded CARD_TYPE_NG) (BTW. - we really need argument parsing and the config stuff ASAP) - default CARD_TYPE now is CARD_TYPE_HOSTAP | ||||
2002-12-11 | - roll back the threaded xine initialization, the mediaplayer initialization | simon | 11 | -241/+84 |
state and the PlayButton change set - instead load the audio-/video widget and the xine control on-demand. much faster and much simpler for startup | ||||
2002-12-11 | - Reduce g++ warnings. | mickeyl | 2 | -7/+7 |
- Depend on libpcap | ||||
2002-12-11 | - less code duplication. code from resizeEvent is now shared as well as | simon | 4 | -41/+42 |
the image composing method and the pixmap mask helper | ||||
2002-12-11 | - moved default skin name reading over to skin class | simon | 3 | -10/+26 |
2002-12-11 | fix for g++ complaining about different linking schemes: | mickeyl | 2 | -2/+10 |
/usr/include/net/bpf.h:408: previous declaration of `u_int bpf_filter(bpf_insn*, u_char*, unsigned int, unsigned int)' with C++ linkage /usr/include/pcap.h:201: conflicts with new declaration with C linkage /usr/include/net/bpf.h:407: previous declaration of `int bpf_validate(bpf_insn*, int)' with C++ linkage /usr/include/pcap.h:202: conflicts with new declaration with C linkage | ||||
2002-12-11 | - minor cleanup | simon | 2 | -7/+5 |
2002-12-11 | - oops, do the right cast in the gamma set method | simon | 1 | -1/+1 |
2002-12-11 | - slight simplification in the API | simon | 4 | -12/+11 |
2002-12-11 | - button mask composing moved to Skin class | simon | 4 | -27/+41 |
2002-12-11 | - starting with skin preloading | simon | 2 | -6/+37 |
2002-12-11 | - moved the remaining pieces of image/pixmap loading to the Skin class | simon | 4 | -16/+23 |
2002-12-11 | - more image loading functionality moved to the Skin class | simon | 3 | -2/+17 |