summaryrefslogtreecommitdiff
AgeCommit message (Collapse)AuthorFilesLines
2002-12-11No need for debug output anymore ... it works nowsandman1-6/+6
2002-12-11valgrind complained and here are some off-by-1 fixessandman1-3/+4
2002-12-11- moved the skin cache into the .cpp filesimon2-16/+16
2002-12-11 QBusyBar::~QBusyBar ( )simon1-0/+1
{ + delete [] m_fadecols;
2002-12-11- set the correct status on the fullscreen toggle button when returningsimon1-0/+1
from fullscreen mode
2002-12-11Added check for no replay file on loading and fixed bugs where you could ↵andyq1-4/+13
screw up the replay by pressing stuff
2002-12-11Updated helpandyq1-0/+7
2002-12-11- restructing a bit the skin data storage, in preparation for cachesimon2-27/+41
improvements
2002-12-11Added new methods and members for replay loading and savingandyq1-0/+3
2002-12-11Added save and load replaysandyq1-4/+97
2002-12-11- copyright notice fixletsimon5-15/+76
2002-12-11- collect arguments passed to the skin loading into a structuresimon6-24/+24
2002-12-11- added a skin cache and a threaded skin loader. looks like the lattersimon3-4/+155
we have to disable though, because pure image loading with qt is anything but threadsafe :(
2002-12-11- expose information about the buttonssimon4-2/+28
2002-12-11Added dialogbox to notify that the vcard was unable to readeilers1-0/+6
2002-12-11Added iconsbenmeyer3-3/+3
2002-12-11Implemented dialog box for every received vcard to get user permissioneilers2-4/+30
2002-12-11Adjust for the move of the init script overkergoth1-1/+1
2002-12-11Removed mimetypeandyq1-1/+0
2002-12-11- ah, forgot to remove this unused codesimon1-19/+0
2002-12-11When did this appear?mickeyl1-0/+0
2002-12-11- include wellenreiter.desktop in .pro-filemickeyl3-3/+3
- daemon now uses CARD_TYPE defined in header file (was: hardcoded CARD_TYPE_NG) (BTW. - we really need argument parsing and the config stuff ASAP) - default CARD_TYPE now is CARD_TYPE_HOSTAP
2002-12-11- roll back the threaded xine initialization, the mediaplayer initializationsimon11-241/+84
state and the PlayButton change set - instead load the audio-/video widget and the xine control on-demand. much faster and much simpler for startup
2002-12-11- Reduce g++ warnings.mickeyl2-7/+7
- Depend on libpcap
2002-12-11- less code duplication. code from resizeEvent is now shared as well assimon4-41/+42
the image composing method and the pixmap mask helper
2002-12-11- moved default skin name reading over to skin classsimon3-10/+26
2002-12-11fix for g++ complaining about different linking schemes:mickeyl2-2/+10
/usr/include/net/bpf.h:408: previous declaration of `u_int bpf_filter(bpf_insn*, u_char*, unsigned int, unsigned int)' with C++ linkage /usr/include/pcap.h:201: conflicts with new declaration with C linkage /usr/include/net/bpf.h:407: previous declaration of `int bpf_validate(bpf_insn*, int)' with C++ linkage /usr/include/pcap.h:202: conflicts with new declaration with C linkage
2002-12-11- minor cleanupsimon2-7/+5
2002-12-11- oops, do the right cast in the gamma set methodsimon1-1/+1
2002-12-11- slight simplification in the APIsimon4-12/+11
2002-12-11- button mask composing moved to Skin classsimon4-27/+41
2002-12-11- starting with skin preloadingsimon2-6/+37
2002-12-11- moved the remaining pieces of image/pixmap loading to the Skin classsimon4-16/+23
2002-12-11- more image loading functionality moved to the Skin classsimon3-2/+17
2002-12-11- starting to factor out the actual skin image loading into a separatesimon4-3/+48
class
2002-12-11changed to new pda iconllornkcor1-1/+1
2002-12-11addedllornkcor1-0/+0
2002-12-11- less qimage<>qpixmap conversionssimon1-5/+6
2002-12-11- slight simplification of XineControl constructorsimon5-18/+37
- fixed a race between the video resizing and the xine initialization
2002-12-11- removed unused variablesimon1-1/+0
2002-12-11- step three to make it compile with gcc2simon1-0/+1
2002-12-11- gcc2 is not my friend, given that it can't deal with friend declarationssimon2-12/+11
properly :) (a.k.a: make it compile with gcc2, step 2)
2002-12-11- make it compile for gcc2: step1simon2-10/+9
2002-12-11max inactive minutes to 1 day - 1440 minutesharlekin1-0/+1
2002-12-11- added bool Thread::isRunning() constsimon2-0/+8
2002-12-11- make more use of the Resource::* api for loading the datasimon1-2/+2
2002-12-11applied a patch from "Tais M. Hansen" <tais.hansen@osd.dk> to add danishsandman6-4/+24
language support
2002-12-11- centralize more of the skin loading code, so it can be factored out latersimon4-22/+28
more easily
2002-12-11Added danish translations.mellen1-0/+64
2002-12-11- moved the shared button up/down image variables into the base classsimon5-22/+16
- removed some unused variables