Age | Commit message (Collapse) | Author | Files | Lines |
---|---|---|---|---|
2002-12-10 | - factor out the expensive xine initialization code into a separate method, | simon | 2 | -5/+14 |
as preparation | ||||
2002-12-10 | no need for opieatd anymore | sandman | 3 | -43/+2 |
2002-12-10 | /etc/resumeat is now in /var/run/resumeat | sandman | 1 | -7/+8 |
2002-12-10 | don't use atd anymore - our atd is only simple shell script, so better get | sandman | 1 | -231/+288 |
rid of it. | ||||
2002-12-10 | slight bit of rearranging to ensure that the rtc time gets set if using -s ↵ | kergoth | 1 | -31/+42 |
regardless of whether resumeat contains a valid alarm | ||||
2002-12-10 | Add -lstdc++ to LIBS explicitly for apps that require it, as we no longer ↵ | kergoth | 3 | -3/+3 |
link with g++. | ||||
2002-12-10 | Todo depends on libopie | zecke | 1 | -1/+1 |
This should solve most of the todolist installation problems | ||||
2002-12-10 | Add OPimResolver | zecke | 1 | -0/+2 |
2002-12-10 | get in sync with HEAD again | zecke | 30 | -164/+1072 |
-OPimBase was added to be used as a default struct inside OPimResolver and to work with DSOs -TodoListXML backend now uses mmap and madvise to load data -OContact added/changed rtti -OTodo added changed rtti OPimAccess* added stuff necessary for the Resolver and a 'state'/'hint' on how to load data OPimResolver which resolves uid + services to Records, rtti to QCOPChannels loads arbitary Service backends ( will work with DSOs soon ) -OPimMainWindow added some setDocument scripting possibility and internal marshalling and demarshalling of Records -OPimRecord added loadDataFromm and saveDataTo for marshalling purposes much more :) | ||||
2002-12-10 | Shut up the compiler | zecke | 4 | -12/+5 |
2002-12-10 | Corrected dependencies | kergoth | 1 | -1/+1 |
2002-12-10 | enable. | mickeyl | 1 | -4/+4 |
2002-12-10 | moving to playlistview after adding to it is annoying some people and me ↵ | llornkcor | 1 | -2/+6 |
sometimes. try this for now | ||||
2002-12-10 | - added ThreadUtil::Thread class | simon | 2 | -0/+127 |
2002-12-10 | towards an alpha version | mickeyl | 13 | -12/+605 |
2002-12-09 | - ok, next try for that allocator. stupid gcc2 :( | simon | 1 | -1/+12 |
2002-12-09 | Add a var to pass in libs from teh environment easily.. needed so that the ↵ | kergoth | 59 | -59/+59 |
OZ buildroot can pass in -lsupc++ on the link when building with gcc3. | ||||
2002-12-09 | - work around gcc2's stupid STL that requires libstdc++ in the default | simon | 1 | -3/+7 |
allocator | ||||
2002-12-09 | - removed unused isHeld attribute | simon | 1 | -2/+1 |
2002-12-09 | - hah, the improved design pays off :) switching skins at run-time now | simon | 9 | -61/+87 |
only reloads the pixmaps and no more requires a restart or re-creation of the audio/video widgets and the xine control (which involved slow xine initialization) | ||||
2002-12-09 | - the skin loading code is now centralized. no more duplicated code :) | simon | 4 | -48/+50 |
2002-12-09 | ad-hoc fix | max | 1 | -1/+1 |
2002-12-09 | Added replay function and included own random method for replay functionality | andyq | 5 | -19/+274 |
2002-12-09 | - minor cleanup | simon | 4 | -15/+2 |
2002-12-09 | - reworked the mouse event handling to be much simpler | simon | 4 | -47/+51 |
- fixed missing return in Play case in handleCommand, which accidentially broke pausing - accept the key events we receive in the audioWidget - commented out suspicious connect to pauseCheck in mediaplayer, which broke pausing via space bar | ||||
2002-12-09 | improved display logic | mickeyl | 3 | -23/+65 |
2002-12-09 | - another small cleanup in the mouse handling | simon | 6 | -18/+13 |
2002-12-09 | - apparently gcc2 is too stupid to grok this :-( | simon | 1 | -1/+1 |
2002-12-09 | - another global variable removed | simon | 2 | -3/+3 |
2002-12-09 | - yay, mouseMoveEvent is no more duplicated code :) | simon | 6 | -91/+50 |
2002-12-09 | - removing duplicated code in VideoWidget | simon | 4 | -27/+9 |
2002-12-09 | - more cleanups in the mouse event handler | simon | 2 | -7/+4 |
2002-12-09 | - less indexing | simon | 1 | -4/+6 |
2002-12-09 | - transition to MediaWidget::Command completed | simon | 5 | -28/+30 |
2002-12-09 | - starting to migrate the videowidget to MediaWidget::Command and friends | simon | 2 | -21/+21 |
2002-12-09 | - less hardcoding of numbers | simon | 1 | -4/+5 |
2002-12-09 | - back to a vector :P | simon | 4 | -17/+19 |
2002-12-09 | - less indexing in the mouse event handler | simon | 2 | -23/+29 |
2002-12-09 | - toggleButton and setToggleButton now operate on a Button object instead | simon | 5 | -23/+17 |
of an index | ||||
2002-12-09 | - merged duplicated setToggleButton method | simon | 6 | -17/+12 |
- minor fixlet for paintAllButtons | ||||
2002-12-09 | Temorarely bug workaround ( #490 ) until trolltech publishing a bugfix ! | eilers | 1 | -0/+26 |
2002-12-09 | APs and adhoc stations are now grouped and displayed as belonging to a common | mickeyl | 4 | -15/+45 |
net. | ||||
2002-12-09 | - minor cleanup in paintEvent | simon | 2 | -5/+10 |
2002-12-09 | - minor cleanup | simon | 2 | -5/+8 |
2002-12-09 | - merged the duplicated (and identical) paintEvent methods into the | simon | 6 | -52/+30 |
base class | ||||
2002-12-09 | - pixBg is now backgroundPixmap and shared in the base class | simon | 5 | -15/+15 |
2002-12-09 | - paintButton is no more a duplicated method but centralized in the | simon | 6 | -28/+14 |
base class now :) | ||||
2002-12-09 | Added preview for default email and all email | eilers | 2 | -4/+12 |
2002-12-09 | - removed unused pixmaps array | simon | 1 | -1/+0 |
2002-12-09 | - getting rid of the buttonPixUp/Down arrays, reuse the Button structure | simon | 2 | -22/+12 |
instead |