summaryrefslogtreecommitdiff
AgeCommit message (Collapse)AuthorFilesLines
2002-12-04- move more view population logic into PlayListFileViewsimon4-28/+20
2002-12-04- merged popuplateAudioView and popuplateVideoView into onesimon4-74/+40
PlayListFileView::popuplateView method
2002-12-04- moving videoScan and audioScan into PlayListFileViewsimon4-12/+14
2002-12-04- merged scanForVideo and scanForAudio into a common scanFiles method insimon6-28/+37
the PlayListFileView. less duplicated code :)
2002-12-04Abstracted checkbook storage, added new main window display/configuration ↵drw13-243/+753
options.
2002-12-04Icon for checkbook config optiondrw1-0/+0
2002-12-03- a couple of public member variables made privatesimon1-6/+8
2002-12-03why didn't anybody notice this ? If you change the font, all currently opensandman1-1/+1
applications don't change their font -- that's not normal - that's a bug :) Fixed now
2002-12-03GUI used wrong comm port.mickeyl1-10/+14
2002-12-03- removing ten lines of duplicated codesimon2-20/+10
2002-12-03- starting to factor out the playlist file views into separate classessimon6-4/+65
2002-12-03Added danish translations.mellen1-0/+224
2002-12-03Toolbar got pushed down a line due to a too long translation in the menu ↵mellen1-1/+1
titles, so I changed it to a shorter word.
2002-12-03Two additional functions preloaded to make HancomWord happy ...sandman2-2/+45
1) the old pointSizes() problem in the FontDatabase (bic change from qt/e 2.3.3 -> 2.3.4) 2) the QPalette for the text widget has to be adjusted (hancom uses QPainter::eraseRect(), which doesn't work with background pixmaps, like e.g. in liquid)
2002-12-03Added danish translations.mellen1-0/+748
2002-12-03small fix regarding focus handling on combo-boxessandman1-1/+4
2002-12-02- I better be a good boy and delete what I allocate :)simon1-0/+2
2002-12-02- yay, last singleton gone. global playList variable is no more :)simon9-40/+36
2002-12-02- AudioWidget and VideoWidget are no more singletons via audioUI andsimon7-31/+56
videoUI. this allows switching skins at run-time (the appropriate connections are already made and it works quite nicely :)
2002-12-02- replaced QPixmap and QImage pointer usage with value usagesimon2-25/+23
2002-12-02- centralized closeEvent implementationsimon6-12/+7
2002-12-02- centralized the button command handling into MediaWidget (as it issimon4-48/+35
duplicated between AudioWidget and VideoWidget -- the latter still to come though)
2002-12-02- removed last traces of mediaPlayerState singleton. yay :)simon4-21/+21
2002-12-02- the audiowidget and the videowidget don't rely on the mediaplayerstatesimon7-86/+87
singleton anymore
2002-12-02- the playlist no more uses the mediaplayerstate as singletonsimon5-34/+35
2002-12-02- MediaPlayer no more uses the MediaPlayerState instance as singletonsimon3-30/+31
2002-12-02- less header inclusionssimon2-3/+0
2002-12-02- less code duplicationsimon6-11/+14
2002-12-02- inherit from MediaWidgetsimon4-13/+12
2002-12-02- new base class for AudioWidget and VideoWidgetsimon3-2/+79
2002-12-02Uncommenting destdirkergoth2-2/+2
2002-12-02- copyright fixletsimon2-2/+2
2002-12-02Dont refer to full path in Files:kergoth3-3/+3
2002-12-02- completed MediaPlayer::DisplayType transitionsimon5-35/+12
2002-12-02- another step to switch to from char view to DisplayTypesimon2-16/+29
2002-12-02- converted to MediaPlayerState::DisplayTypesimon2-10/+13
2002-12-02- oops, realized it's not MediaType but rather DisplayTypesimon4-15/+23
2002-12-02- adapted to the new MediaPlayerState::MediaTypesimon2-9/+10
2002-12-02- oops, fixed the signal signaturesimon1-1/+1
2002-12-02- introducing MediaType { Video, Audio } enum, to get rid of thesimon2-0/+10
char view ('a' and 'v') step by step
2002-12-02- added a missing constsimon2-34/+28
- QImage and QPixmap are value based classes, so use them like that for a couple of objects. simplifies the code and helps to avoid memory leaks
2002-12-02- don't enable the play button if switching to the playlist tab and thesimon2-1/+11
playlist is empty - don't crash when starting to play and no item is selected in the playlist. instead select the first item then.
2002-12-02- as MediaPlayerState::isUsingPlaylist() always returns true we can removesimon3-61/+35
it and simplify some code in the playlistwidget due to that
2002-12-02- removed the playlistToggled signal, as it is never emittedsimon3-15/+1
- resulted in some simplification in playlistwidget
2002-12-02- setUsingPlaylist and togglePlaylist is never called. removed.simon2-14/+0
2002-12-02- removed unused (and never initialized to something != 0)simon3-8/+1
PlayListWidgetPrivate::current
2002-12-02- save memory, use bitfieldssimon1-11/+11
2002-12-02- removed unused (and uninitialized) FileSelector *PlayListWidgetPrivate::filessimon2-5/+3
2002-12-02- disable 'play' in the play list tabsimon1-0/+4
2002-12-02- simplified MediaPlayer::setPlaying, moving more switch() like code intosimon4-25/+34
playlistwidget