summaryrefslogtreecommitdiff
AgeCommit message (Collapse)AuthorFilesLines
2002-12-09- minor cleanup in paintEventsimon2-5/+10
2002-12-09- minor cleanupsimon2-5/+8
2002-12-09- merged the duplicated (and identical) paintEvent methods into thesimon6-52/+30
base class
2002-12-09- pixBg is now backgroundPixmap and shared in the base classsimon5-15/+15
2002-12-09- paintButton is no more a duplicated method but centralized in thesimon6-28/+14
base class now :)
2002-12-09Added preview for default email and all emaileilers2-4/+12
2002-12-09- removed unused pixmaps arraysimon1-1/+0
2002-12-09- getting rid of the buttonPixUp/Down arrays, reuse the Button structuresimon2-22/+12
instead
2002-12-09- get rid of the masks array and re-use the Button structuresimon2-14/+10
2002-12-09- migrating from a button vector to a button mapsimon3-17/+18
2002-12-09- merged the two button setup loopssimon1-10/+8
2002-12-09- merged the separate mask and pixmap arrays into the Button structuresimon2-19/+15
and the buttons vector
2002-12-09- moving some variables to the base classsimon2-6/+7
2002-12-09small fixes.mickeyl3-1/+3
2002-12-09Wellenreiter is now fully integrated into the Opie build environment.mickeyl10-11/+51
If you want to play with what we have yet, be sure to add the following to the makefile: * noncore/net/wellenreiter/libwellenreiter * noncore/net/wellenreiter/daemon * noncore/net/wellenreiter/gui Don't add the toplevel noncore/net/wellenreiter, because the Makefile in there is handcrafted.
2002-12-09- oops, buttonType is a bad name for a variable, given its redundancysimon3-7/+7
2002-12-09- re-organizing a bit the button storage. more to come.simon2-21/+28
2002-12-09- isToggle is now an enum ButtonType { NormalButton, ToggleButton };simon3-13/+10
2002-12-09- another hardcoded number removed :)simon1-1/+1
2002-12-09- buttonPixUp/Down are now vectors, toosimon2-18/+10
- removed unused and uninitialized pixmaps array
2002-12-09- use a vector to store the maskssimon2-11/+12
2002-12-09- one global variable lesssimon2-4/+4
2002-12-09 switch (mouse) {simon1-4/+4
- case 1: + case LeftButton: break; - case 2: + case RightButton:
2002-12-09- replaced currentFileListView method with a variablesimon2-17/+12
2002-12-09- use xine_set_param( ..., XINE_PARAM_SPEED, with XINE_SPEED_PAUSE andsimon3-8/+4
XINE_SPEED_NORMAL to toggle between pause and playing state, instead of attempting to re-start the stream at the last position
2002-12-09- Key_Space triggers togglePaused()simon1-9/+1
2002-12-08Fixed saving of new checkbooks and incorrect setting of notes.drw2-1/+7
2002-12-08- synchronizing the button indices a bit more with the audiowidgetsimon2-6/+6
2002-12-08- switched from inlined logo to pngmickeyl3-1066/+23
- first work on config tab
2002-12-08removed some clumsy workarounds for old (unpatched) libqte'ssandman1-12/+3
2002-12-08- merged the two duplicated toggleButton methods into a shared onesimon6-17/+9
2002-12-08- oops, forgot to commit this onesimon1-0/+6
2002-12-08- some preparations for further code cleanups for paintButton callssimon5-14/+17
2002-12-08- moved the duplicated code for checking whether the mouse is over asimon4-12/+12
button into a shared isOverButton method
2002-12-08- merged xoff/yoff into a QPointe member variable, shared in the base classsimon5-17/+17
2002-12-08operator new is still completly useless in newer gcc 2.95 toolchainssandman1-3/+0
(~7 times slower than the malloc wrappers)
2002-12-08- made XineControl independent from VideoWidgetsimon3-12/+11
2002-12-08- share the imgButtonMask member variable in the base classsimon5-14/+14
2002-12-08- no need to include audio and videowidget.h heresimon1-2/+0
2002-12-08- share the buttons data in a buttons member variable in the base classsimon5-50/+48
2002-12-08- #include cleanupsimon1-7/+0
2002-12-08- I'm re-using code from the others, so add their copyright :)simon2-0/+6
2002-12-08- unused variables removedsimon3-39/+1
2002-12-08the patch was reverse - fixed nowsandman1-4/+4
2002-12-08- made audioButtons a member variable here, toosimon2-4/+26
2002-12-08- made videoButtons a member variable instead of a global onesimon3-5/+29
2002-12-08This fixes the overlapping popupmenu problem. Qt/E chooses the lowersandman1-0/+11
popupmenu (parent) for mouse move events, if two popupmenu overlap.
2002-12-08removed libpreloadsandman1-1/+0
2002-12-08added missing includessandman1-0/+4
added all hancom apps to the pointSizes fix
2002-12-08- merged duplicated MediaButton definition into common MediaWidget::Buttonsimon3-9/+13
structure