summaryrefslogtreecommitdiff
path: root/noncore
AgeCommit message (Collapse)AuthorFilesLines
2002-12-11- initialized xine in a background thread. much time is still spend insimon5-5/+42
skin loading though.
2002-12-11- added initialize states to MediaPlayerStatesimon6-6/+68
- the play button is now of type PlayButton, inheritting from ToolButton and checking the media player initialization state in setEnabled
2002-12-10- added an m_initialized flag and a guard for it, along with ansimon2-1/+71
assertion method called from all methods that access variables depending on initialization (basically all :)
2002-12-10- factor out the expensive xine initialization code into a separate method,simon2-5/+14
as preparation
2002-12-10Add -lstdc++ to LIBS explicitly for apps that require it, as we no longer ↵kergoth3-3/+3
link with g++.
2002-12-10Corrected dependencieskergoth1-1/+1
2002-12-10enable.mickeyl1-4/+4
2002-12-10moving to playlistview after adding to it is annoying some people and me ↵llornkcor1-2/+6
sometimes. try this for now
2002-12-10- added ThreadUtil::Thread classsimon2-0/+127
2002-12-10towards an alpha versionmickeyl13-12/+605
2002-12-09- ok, next try for that allocator. stupid gcc2 :(simon1-1/+12
2002-12-09- work around gcc2's stupid STL that requires libstdc++ in the defaultsimon1-3/+7
allocator
2002-12-09- removed unused isHeld attributesimon1-2/+1
2002-12-09- hah, the improved design pays off :) switching skins at run-time nowsimon9-61/+87
only reloads the pixmaps and no more requires a restart or re-creation of the audio/video widgets and the xine control (which involved slow xine initialization)
2002-12-09- the skin loading code is now centralized. no more duplicated code :)simon4-48/+50
2002-12-09ad-hoc fixmax1-1/+1
2002-12-09Added replay function and included own random method for replay functionalityandyq5-19/+274
2002-12-09- minor cleanupsimon4-15/+2
2002-12-09- reworked the mouse event handling to be much simplersimon4-47/+51
- fixed missing return in Play case in handleCommand, which accidentially broke pausing - accept the key events we receive in the audioWidget - commented out suspicious connect to pauseCheck in mediaplayer, which broke pausing via space bar
2002-12-09improved display logicmickeyl3-23/+65
2002-12-09- another small cleanup in the mouse handlingsimon6-18/+13
2002-12-09- apparently gcc2 is too stupid to grok this :-(simon1-1/+1
2002-12-09- another global variable removedsimon2-3/+3
2002-12-09- yay, mouseMoveEvent is no more duplicated code :)simon6-91/+50
2002-12-09- removing duplicated code in VideoWidgetsimon4-27/+9
2002-12-09- more cleanups in the mouse event handlersimon2-7/+4
2002-12-09- less indexingsimon1-4/+6
2002-12-09- transition to MediaWidget::Command completedsimon5-28/+30
2002-12-09- starting to migrate the videowidget to MediaWidget::Command and friendssimon2-21/+21
2002-12-09- less hardcoding of numberssimon1-4/+5
2002-12-09- back to a vector :Psimon4-17/+19
2002-12-09- less indexing in the mouse event handlersimon2-23/+29
2002-12-09- toggleButton and setToggleButton now operate on a Button object insteadsimon5-23/+17
of an index
2002-12-09- merged duplicated setToggleButton methodsimon6-17/+12
- minor fixlet for paintAllButtons
2002-12-09APs and adhoc stations are now grouped and displayed as belonging to a commonmickeyl4-15/+45
net.
2002-12-09- minor cleanup in paintEventsimon2-5/+10
2002-12-09- minor cleanupsimon2-5/+8
2002-12-09- merged the duplicated (and identical) paintEvent methods into thesimon6-52/+30
base class
2002-12-09- pixBg is now backgroundPixmap and shared in the base classsimon5-15/+15
2002-12-09- paintButton is no more a duplicated method but centralized in thesimon6-28/+14
base class now :)
2002-12-09- removed unused pixmaps arraysimon1-1/+0
2002-12-09- getting rid of the buttonPixUp/Down arrays, reuse the Button structuresimon2-22/+12
instead
2002-12-09- get rid of the masks array and re-use the Button structuresimon2-14/+10
2002-12-09- migrating from a button vector to a button mapsimon3-17/+18
2002-12-09- merged the two button setup loopssimon1-10/+8
2002-12-09- merged the separate mask and pixmap arrays into the Button structuresimon2-19/+15
and the buttons vector
2002-12-09- moving some variables to the base classsimon2-6/+7
2002-12-09small fixes.mickeyl3-1/+3
2002-12-09Wellenreiter is now fully integrated into the Opie build environment.mickeyl10-11/+51
If you want to play with what we have yet, be sure to add the following to the makefile: * noncore/net/wellenreiter/libwellenreiter * noncore/net/wellenreiter/daemon * noncore/net/wellenreiter/gui Don't add the toplevel noncore/net/wellenreiter, because the Makefile in there is handcrafted.
2002-12-09- oops, buttonType is a bad name for a variable, given its redundancysimon3-7/+7