-rw-r--r-- | Makefile.am | 37 |
1 files changed, 37 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am new file mode 100644 index 0000000..913b46a --- a/dev/null +++ b/Makefile.am | |||
@@ -0,0 +1,37 @@ | |||
1 | SUBDIRS = content locale | ||
2 | |||
3 | xpi_DATA = \ | ||
4 | install.rdf \ | ||
5 | AUTHORS COPYING NEWS | ||
6 | |||
7 | EXTRA_DIST = NEWS NEWS.xml NEWS.xsl chrome.manifest | ||
8 | |||
9 | XPI=${PACKAGE}-${VERSION}.xpi | ||
10 | |||
11 | xpi: ${XPI} | ||
12 | |||
13 | ${XPI}: install | ||
14 | cd ${xpichromedir} \ | ||
15 | && ${ZIP} -r -m ${PACKAGE}.jar */ | ||
16 | cd ${xpidir} \ | ||
17 | && ${ZIP} -r @abs_builddir@/$@ . | ||
18 | |||
19 | install-data-local: ${xpidir}/chrome.manifest | ||
20 | |||
21 | ${xpidir}/chrome.manifest: chrome.manifest Makefile | ||
22 | sed \ | ||
23 | -e 's,^content[[:space:]]\+\([^[:space:]]\+\)[[:space:]]\+\([^[:space:]]\+\)$$,content \1 jar:chrome/${PACKAGE}.jar!/\2,' \ | ||
24 | -e 's,^locale[[:space:]]\+\([^[:space:]]\+\)[[:space:]]\+\([^[:space:]]\+\)[[:space:]]\+\([^[:space:]]\+\)$$,locale \1 \2 jar:chrome/${PACKAGE}.jar!/\3,' \ | ||
25 | $< >$@ | ||
26 | |||
27 | clean-local: | ||
28 | rm -rf ${xpidir} ${XPI} | ||
29 | |||
30 | all-local: NEWS | ||
31 | |||
32 | NEWS: NEWS.xsl NEWS.xml | ||
33 | ${XSLTPROC} -o $@ NEWS.xsl NEWS.xml | ||
34 | |||
35 | mozextptr: ${MOZ_EXT_ID} | ||
36 | ${MOZ_EXT_ID}: | ||
37 | echo @abs_srcdir@ >$@ | ||