-rw-r--r-- | configure.ac | 71 |
1 files changed, 71 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac new file mode 100644 index 0000000..7b1db54 --- a/dev/null +++ b/configure.ac | |||
@@ -0,0 +1,71 @@ | |||
1 | AC_INIT([iii], [0.0], [iii-bugs@klever.net]) | ||
2 | AC_CONFIG_SRCDIR([configure.ac]) | ||
3 | AC_CONFIG_HEADERS([config.h]) | ||
4 | AM_INIT_AUTOMAKE([dist-bzip2]) | ||
5 | |||
6 | AC_PROG_INSTALL | ||
7 | AC_PROG_CXX | ||
8 | AC_PROG_CC | ||
9 | PKG_PROG_PKG_CONFIG | ||
10 | |||
11 | AC_HEADER_STDC | ||
12 | |||
13 | AC_PATH_PROG([XSLTPROC],[xsltproc],[true]) | ||
14 | |||
15 | PKG_CHECK_MODULES([MODULES],[gsoap++ openssl libconfuse],,[ | ||
16 | AC_MSG_ERROR([one of the build dependencies isn't satisfied]) | ||
17 | ]) | ||
18 | |||
19 | AC_PATH_PROG([SOAPCPP2],[soapcpp2],[false]) | ||
20 | test "$SOAPCPP2" = "false" && AC_MSG_ERROR([no soapcpp2 tool, part of gsoap package, found.]) | ||
21 | |||
22 | notfound=false | ||
23 | AC_CHECK_HEADERS([archive.h],[ | ||
24 | AC_CHECK_LIB([archive],[archive_read_new],,[notfound=true]) | ||
25 | ],[notfound=true]) | ||
26 | $notfound && AC_MSG_ERROR([no required libarchive library found. get one from http://people.freebsd.org/~kientzle/libarchive/]) | ||
27 | |||
28 | notfound=false | ||
29 | AC_LANG_PUSH([C++]) | ||
30 | AC_CHECK_HEADERS([autosprintf.h],[ | ||
31 | AC_CHECK_LIB([asprintf],[main],,[notfound=true]) | ||
32 | ],[notfound=true]) | ||
33 | $notfound && AC_MSG_ERROR([no autosprintf, part of gettext, found]) | ||
34 | AC_LANG_POP([C++]) | ||
35 | |||
36 | nitpick=false | ||
37 | AC_ARG_ENABLE([nitpicking], | ||
38 | AC_HELP_STRING([--enable-nitpicking],[make compiler somewhat overly fastidious about the code it deals with]), | ||
39 | [ test "$enableval" = "no" || nitpick=true ] | ||
40 | ) | ||
41 | if $nitpick ; then | ||
42 | CPP_NITPICK="-pedantic -Wall -Wextra -Wundef -Wshadow \ | ||
43 | -Wunsafe-loop-optimizations -Wconversion -Wmissing-format-attribute \ | ||
44 | -Wredundant-decls -ansi -Wlogical-op -Wmissing-noreturn" | ||
45 | C_NITPICK="$CPP_NITPICK" | ||
46 | CXX_NITPICK="$C_NITPICK" | ||
47 | |||
48 | CPPFLAGS="$CPPFLAGS $CPP_NITPICK" | ||
49 | CFLAGS="$CFLAGS $C_NITPICK" | ||
50 | CXXFLAGS="$CXXFLAGS $CXX_NITPICK" | ||
51 | fi | ||
52 | |||
53 | ndebug=true | ||
54 | AC_ARG_ENABLE([debug], | ||
55 | AC_HELP_STRING([--enable-debug],[enable debugginc code]), | ||
56 | [ test "$enableval" = "no" || ndebug=false ] | ||
57 | ) | ||
58 | if $ndebug ; then | ||
59 | CPPFLAGS_DEBUG="-DNDEBUG" | ||
60 | else | ||
61 | CPPFLAGS_DEBUG="-DDEBUG" | ||
62 | fi | ||
63 | AC_SUBST([CPPFLAGS_DEBUG]) | ||
64 | |||
65 | AC_CONFIG_FILES([ | ||
66 | Makefile | ||
67 | src/Makefile | ||
68 | doc/Makefile | ||
69 | doc/iiid.8 | ||
70 | ]) | ||
71 | AC_OUTPUT | ||