summaryrefslogtreecommitdiffabout
path: root/configure.ac
Unidiff
Diffstat (limited to 'configure.ac') (more/less context) (ignore whitespace changes)
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c814b53..1e0e42c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,75 +1,76 @@
1AC_INIT([iii], [0.3], [iii-bugs@klever.net]) 1AC_INIT([iii], [0.3], [iii-bugs@klever.net])
2AC_CONFIG_SRCDIR([src/iiid.cc]) 2AC_CONFIG_SRCDIR([src/iiid.cc])
3AC_CONFIG_AUX_DIR([aux.d])
3AC_CONFIG_HEADERS([config.h]) 4AC_CONFIG_HEADERS([config.h])
4AM_INIT_AUTOMAKE([dist-bzip2]) 5AM_INIT_AUTOMAKE([dist-bzip2])
5 6
6AC_PROG_INSTALL 7AC_PROG_INSTALL
7AC_PROG_CXX 8AC_PROG_CXX
8AC_PROG_CC 9AC_PROG_CC
9PKG_PROG_PKG_CONFIG 10PKG_PROG_PKG_CONFIG
10 11
11AC_HEADER_STDC 12AC_HEADER_STDC
12 13
13AC_PATH_PROG([XSLTPROC],[xsltproc],[true]) 14AC_PATH_PROG([XSLTPROC],[xsltproc],[true])
14 15
15PKG_CHECK_MODULES([MODULES],[gsoap++ libcrypto libconfuse]) 16PKG_CHECK_MODULES([MODULES],[gsoap++ libcrypto libconfuse])
16PKG_CHECK_MODULES([UUID],[uuid],[have_uuid=true],[have_uuid=false]) 17PKG_CHECK_MODULES([UUID],[uuid],[have_uuid=true],[have_uuid=false])
17AM_CONDITIONAL([HAVE_UUID],[$have_uuid]) 18AM_CONDITIONAL([HAVE_UUID],[$have_uuid])
18if $have_uuid ; then 19if $have_uuid ; then
19 AC_DEFINE([HAVE_LIBUUID],,[defined in presence of libuuid]) 20 AC_DEFINE([HAVE_LIBUUID],,[defined in presence of libuuid])
20 AC_SUBST([UUID_UUID],[uuid]) 21 AC_SUBST([UUID_UUID],[uuid])
21fi 22fi
22 23
23AC_PATH_PROG([SOAPCPP2],[soapcpp2],[false]) 24AC_PATH_PROG([SOAPCPP2],[soapcpp2],[false])
24test "$SOAPCPP2" = "false" && AC_MSG_ERROR([no soapcpp2 tool, part of gsoap package, found.]) 25test "$SOAPCPP2" = "false" && AC_MSG_ERROR([no soapcpp2 tool, part of gsoap package, found.])
25 26
26notfound=false 27notfound=false
27AC_CHECK_HEADERS([archive.h],[ 28AC_CHECK_HEADERS([archive.h],[
28 AC_CHECK_LIB([archive],[archive_read_new],,[notfound=true]) 29 AC_CHECK_LIB([archive],[archive_read_new],,[notfound=true])
29],[notfound=true]) 30],[notfound=true])
30$notfound && AC_MSG_ERROR([no required libarchive library found. get one from http://people.freebsd.org/~kientzle/libarchive/]) 31$notfound && AC_MSG_ERROR([no required libarchive library found. get one from http://people.freebsd.org/~kientzle/libarchive/])
31 32
32notfound=false 33notfound=false
33AC_LANG_PUSH([C++]) 34AC_LANG_PUSH([C++])
34AC_CHECK_HEADERS([autosprintf.h],[ 35AC_CHECK_HEADERS([autosprintf.h],[
35 AC_CHECK_LIB([asprintf],[main],,[notfound=true]) 36 AC_CHECK_LIB([asprintf],[main],,[notfound=true])
36],[notfound=true]) 37],[notfound=true])
37$notfound && AC_MSG_ERROR([no autosprintf, part of gettext, found]) 38$notfound && AC_MSG_ERROR([no autosprintf, part of gettext, found])
38AC_LANG_POP([C++]) 39AC_LANG_POP([C++])
39 40
40nitpick=false 41nitpick=false
41AC_ARG_ENABLE([nitpicking], 42AC_ARG_ENABLE([nitpicking],
42 AC_HELP_STRING([--enable-nitpicking],[make compiler somewhat overly fastidious about the code it deals with]), 43 AC_HELP_STRING([--enable-nitpicking],[make compiler somewhat overly fastidious about the code it deals with]),
43 [ test "$enableval" = "no" || nitpick=true ] 44 [ test "$enableval" = "no" || nitpick=true ]
44) 45)
45if $nitpick ; then 46if $nitpick ; then
46 CPP_NITPICK="-pedantic -Wall -Wextra -Wundef -Wshadow \ 47 CPP_NITPICK="-pedantic -Wall -Wextra -Wundef -Wshadow \
47 -Wunsafe-loop-optimizations -Wconversion -Wmissing-format-attribute \ 48 -Wunsafe-loop-optimizations -Wconversion -Wmissing-format-attribute \
48 -Wredundant-decls -ansi -Wlogical-op -Wmissing-noreturn" 49 -Wredundant-decls -ansi -Wlogical-op -Wmissing-noreturn"
49 C_NITPICK="$CPP_NITPICK" 50 C_NITPICK="$CPP_NITPICK"
50 CXX_NITPICK="$C_NITPICK" 51 CXX_NITPICK="$C_NITPICK"
51 52
52 CPPFLAGS="$CPPFLAGS $CPP_NITPICK" 53 CPPFLAGS="$CPPFLAGS $CPP_NITPICK"
53 CFLAGS="$CFLAGS $C_NITPICK" 54 CFLAGS="$CFLAGS $C_NITPICK"
54 CXXFLAGS="$CXXFLAGS $CXX_NITPICK" 55 CXXFLAGS="$CXXFLAGS $CXX_NITPICK"
55fi 56fi
56 57
57ndebug=true 58ndebug=true
58AC_ARG_ENABLE([debug], 59AC_ARG_ENABLE([debug],
59 AC_HELP_STRING([--enable-debug],[enable debugging code]), 60 AC_HELP_STRING([--enable-debug],[enable debugging code]),
60 [ test "$enableval" = "no" || ndebug=false ] 61 [ test "$enableval" = "no" || ndebug=false ]
61) 62)
62if $ndebug ; then 63if $ndebug ; then
63 CPPFLAGS_DEBUG="-DNDEBUG" 64 CPPFLAGS_DEBUG="-DNDEBUG"
64else 65else
65 CPPFLAGS_DEBUG="-DDEBUG" 66 CPPFLAGS_DEBUG="-DDEBUG"
66fi 67fi
67AC_SUBST([CPPFLAGS_DEBUG]) 68AC_SUBST([CPPFLAGS_DEBUG])
68 69
69AC_CONFIG_FILES([ 70AC_CONFIG_FILES([
70 Makefile 71 Makefile
71 src/Makefile 72 src/Makefile
72 doc/Makefile 73 doc/Makefile
73 doc/iiid.8 74 doc/iiid.8
74]) 75])
75AC_OUTPUT 76AC_OUTPUT