-rw-r--r-- | debian/compat | 2 | ||||
-rw-r--r-- | debian/control | 4 | ||||
-rwxr-xr-x | debian/iii.postinst | 2 | ||||
-rwxr-xr-x | debian/iii.postrm | 1 | ||||
-rw-r--r-- | debian/source/format | 1 |
5 files changed, 6 insertions, 4 deletions
diff --git a/debian/compat b/debian/compat index b8626c4..7ed6ff8 100644 --- a/debian/compat +++ b/debian/compat | |||
@@ -1 +1 @@ | |||
4 | 5 | ||
diff --git a/debian/control b/debian/control index 02a6138..aaa8c78 100644 --- a/debian/control +++ b/debian/control | |||
@@ -1,13 +1,13 @@ | |||
1 | Source: iii | 1 | Source: iii |
2 | Section: graphics | 2 | Section: graphics |
3 | Priority: optional | 3 | Priority: optional |
4 | Maintainer: Michael Krelin <hacker@klever.net> | 4 | Maintainer: Michael Krelin <hacker@klever.net> |
5 | Build-Depends: debhelper (>=7), gsoap, libssl-dev, libconfuse-dev, libarchive-dev, gettext | 5 | Build-Depends: debhelper (>=7), gsoap, libssl-dev, libconfuse-dev, libarchive-dev, gettext |
6 | Standards-Version: 3.8.0 | 6 | Standards-Version: 3.8.4 |
7 | 7 | ||
8 | Package: iii | 8 | Package: iii |
9 | Architecture: any | 9 | Architecture: any |
10 | Depends: adduser, ${shlibs:Depends} | 10 | Depends: adduser, ${shlibs:Depends}, ${misc:Depends} |
11 | Description: Eye-Fi Manager implementation | 11 | Description: Eye-Fi Manager implementation |
12 | Implementation of Eye-Fi manager service for Linux | 12 | Implementation of Eye-Fi manager service for Linux |
13 | 13 | ||
diff --git a/debian/iii.postinst b/debian/iii.postinst index 20463a1..f52bf84 100755 --- a/debian/iii.postinst +++ b/debian/iii.postinst | |||
@@ -1,18 +1,18 @@ | |||
1 | #!/bin/sh | 1 | #!/bin/sh |
2 | set -e | 2 | set -e |
3 | UG=eyefi | 3 | UG=eyefi |
4 | P=eyekindo | 4 | P=iii |
5 | H=/var/lib/$P | 5 | H=/var/lib/$P |
6 | 6 | ||
7 | if [ "$1" = configure ] ; then | 7 | if [ "$1" = configure ] ; then |
8 | getent group $UG >/dev/null 2>&1 || addgroup --system $UG | 8 | getent group $UG >/dev/null 2>&1 || addgroup --system $UG |
9 | getent passwd $UG >/dev/null 2>&1 || adduser --system --home $H \ | 9 | getent passwd $UG >/dev/null 2>&1 || adduser --system --home $H \ |
10 | --no-create-home --disabled-password --ingroup $UG $UG | 10 | --no-create-home --disabled-password --ingroup $UG $UG |
11 | if ! test -d $H ; then | 11 | if ! test -d $H ; then |
12 | mkdir -p $H | 12 | mkdir -p $H |
13 | chown $UG:$UG $H | 13 | chown $UG:$UG $H |
14 | chmod 2770 $H | 14 | chmod 2770 $H |
15 | fi | 15 | fi |
16 | fi | 16 | fi |
17 | 17 | ||
18 | #DEBHELPER# | 18 | #DEBHELPER# |
diff --git a/debian/iii.postrm b/debian/iii.postrm index a2c66fa..6060c4f 100755 --- a/debian/iii.postrm +++ b/debian/iii.postrm | |||
@@ -1,3 +1,4 @@ | |||
1 | #!/bin/sh | 1 | #!/bin/sh |
2 | set -e | ||
2 | 3 | ||
3 | #DEBHELPER# | 4 | #DEBHELPER# |
diff --git a/debian/source/format b/debian/source/format new file mode 100644 index 0000000..89ae9db --- a/dev/null +++ b/debian/source/format | |||
@@ -0,0 +1 @@ | |||
3.0 (native) | |||