-rw-r--r-- | src/Makefile.am | 32 |
1 files changed, 32 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am new file mode 100644 index 0000000..09f698e --- a/dev/null +++ b/src/Makefile.am | |||
@@ -0,0 +1,32 @@ | |||
1 | sbin_PROGRAMS=iiid | ||
2 | noinst_HEADERS = \ | ||
3 | eyefi.h \ | ||
4 | eyekinfig.h eyetil.h \ | ||
5 | eyefiworker.h | ||
6 | |||
7 | AM_CPPFLAGS = ${CPPFLAGS_DEBUG} \ | ||
8 | -DEYEKIN_CONF_DIR=\"${sysconfdir}/${PACKAGE}\" | ||
9 | DEFAULT_INCLUDES = -I${top_builddir} -I${builddir} -I${srcdir} | ||
10 | INCLUDES = ${MODULES_CFLAGS} | ||
11 | |||
12 | iiid_SOURCES = iiid.cc \ | ||
13 | eyekinfig.cc eyetil.cc \ | ||
14 | eyefiservice.cc eyefiworker.cc | ||
15 | nodist_iiid_SOURCES = \ | ||
16 | ${builddir}/soapC.cpp ${builddir}/soapeyefiService.cpp \ | ||
17 | COPYING.cc | ||
18 | iiid_LDADD = ${MODULES_LIBS} | ||
19 | |||
20 | COPYING.cc: ${top_srcdir}/COPYING | ||
21 | echo "const char * COPYING = " >$@ || (rm $@;exit 1) | ||
22 | sed -e 's/"/\\"/g' -e 's/^/\"/' -e 's/$$/\\n\"/' $< >>$@ || (rm $@;exit 1) | ||
23 | echo ';' >>$@ || (rm $@;exit 1) | ||
24 | |||
25 | ${srcdir}/eyefiservice.cc: ${builddir}/soapeyefiService.h | ||
26 | ${srcdir}/iiid.cc: ${builddir}/eyefi.nsmap | ||
27 | |||
28 | ${builddir}soapC.cpp ${builddir}/soapeyefiService.cpp ${builddir}/eyefi.nsmap ${builddir}/soapeyefiService.h: ${srcdir}/eyefi.h | ||
29 | ${SOAPCPP2} -d${builddir} -S -L -a -i -w -x $< | ||
30 | |||
31 | clean-local: | ||
32 | rm -f soap{{H,Stub,eyefiService}.h,{C,eyefiService}.cpp} eyefi.nsmap COPYING.cc | ||