-rw-r--r-- | Makefile.am | 22 |
1 files changed, 10 insertions, 12 deletions
diff --git a/Makefile.am b/Makefile.am index 9833732..3e9f0f1 100644 --- a/Makefile.am +++ b/Makefile.am | |||
@@ -1,27 +1,25 @@ | |||
1 | SUBDIRS=include src | 1 | SUBDIRS=include src |
2 | EXTRA_DIST= NEWS NEWS.xml NEWS.xsl | 2 | EXTRA_DIST= NEWS NEWS.xml NEWS.xsl |
3 | 3 | ||
4 | DISTCHECK_CONFIGURE_FLAGS=--with-pkgconfigdir=$${dc_install_base}/lib/pkgconfig | 4 | DISTCHECK_CONFIGURE_FLAGS=--with-pkgconfigdir=$${dc_install_base}/lib/pkgconfig |
5 | if HAVE_PKGCONFIG | 5 | if HAVE_PKGCONFIG |
6 | pkgconfigdir=@PKGCONFIG_DIR@ | 6 | pkgconfigdir=@PKGCONFIG_DIR@ |
7 | pkgconfig_DATA=kingate.pc kingate-fcgi.pc | 7 | pkgconfig_DATA=kingate.pc kingate-plaincgi.pc |
8 | if HAVE_FCGI | ||
9 | pkgconfig_DATA += kingate-fcgi.pc | ||
10 | endif | ||
8 | endif | 11 | endif |
9 | 12 | ||
10 | LOCAL_TARGETS= | 13 | all-local: NEWS |
11 | if HAVE_DOXYGEN | 14 | if HAVE_DOXYGEN |
12 | LOCAL_TARGETS+=doxygen | 15 | clean-local: |
16 | rm -rf doxydox | ||
13 | endif | 17 | endif |
14 | 18 | ||
15 | all-local: NEWS $(addprefix all-lota-,${LOCAL_TARGETS}) | ||
16 | clean-local: $(addprefix clean-lota-,${LOCAL_TARGETS}) | ||
17 | |||
18 | NEWS: NEWS.xsl NEWS.xml | 19 | NEWS: NEWS.xsl NEWS.xml |
19 | ${XSLTPROC} -o $@ NEWS.xsl NEWS.xml | 20 | ${XSLTPROC} -o $@ NEWS.xsl NEWS.xml |
20 | 21 | ||
21 | all-lota-doxygen: doxydox/built | 22 | if HAVE_DOXYGEN |
22 | doxydox/built: $(wildcard ${top_srcdir}/include/kingate/*.h) | 23 | dox: |
23 | ${DOXYGEN} | 24 | ${DOXYGEN} |
24 | touch $@ | 25 | endif |
25 | |||
26 | clean-lota-doxygen: | ||
27 | rm -rf doxydox | ||