summaryrefslogtreecommitdiffabout
path: root/configure.ac
Unidiff
Diffstat (limited to 'configure.ac') (more/less context) (ignore whitespace changes)
-rw-r--r--configure.ac25
1 files changed, 15 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 109eddf..5ae7b27 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1AC_INIT([kingate], [0.0], [kingate-bugs@klever.net]) 1AC_INIT([kingate], [0.0.1], [kingate-bugs@klever.net])
2AC_CONFIG_SRCDIR([include/kingate/cgi_gateway.h]) 2AC_CONFIG_SRCDIR([include/kingate/cgi_gateway.h])
3AC_CONFIG_HEADER([config.h]) 3AC_CONFIG_HEADER([config.h])
4AM_INIT_AUTOMAKE([dist-bzip2]) 4AM_INIT_AUTOMAKE([dist-bzip2])
@@ -12,17 +12,22 @@ AC_PROG_LIBTOOL
12AC_HEADER_STDC 12AC_HEADER_STDC
13AC_CHECK_HEADERS([sys/types.h sys/stat.h]) 13AC_CHECK_HEADERS([sys/types.h sys/stat.h])
14 14
15HAVE_FCGI=false
15AC_LANG_PUSH(C++) 16AC_LANG_PUSH(C++)
16AC_CHECK_HEADERS([fcgio.h],,[ 17AC_CHECK_HEADERS([fcgio.h],[
17 exit 1 18 AC_CHECK_LIB(fcgi,FCGX_Init,[
18]) 19 LIBS="-lfcgi ${LIBS}"
19AC_CHECK_LIB(fcgi,FCGX_Init,,[ 20 AC_CHECK_LIB([fcgi++],[main],[
20 exit 1 21 LIBS="-lfcgi++ ${LIBS}"
21]) 22 HAVE_FCGI=true
22AC_CHECK_LIB([fcgi++],[main],,[ 23 ])
23 exit 1 24 ])
24]) 25])
25AC_LANG_POP(C++) 26AC_LANG_POP(C++)
27if ! ${HAVE_FCGI} ; then
28 AC_MSG_NOTICE([no FastCGI development kit found. It is highly recommnded that you get one. Meanwhile we will proceed without FastCGI support])
29fi
30AM_CONDITIONAL([HAVE_FCGI],[${HAVE_FCGI}])
26 31
27AC_C_CONST 32AC_C_CONST
28 33
@@ -54,7 +59,7 @@ fi
54 59
55AC_CONFIG_FILES([ 60AC_CONFIG_FILES([
56 Makefile 61 Makefile
57 kingate.pc kingate-fcgi.pc 62 kingate.pc kingate-fcgi.pc kingate-plaincgi.pc
58 Doxyfile 63 Doxyfile
59 include/Makefile 64 include/Makefile
60 src/Makefile 65 src/Makefile