summaryrefslogtreecommitdiffabout
path: root/configure.ac
authorMichael Krelin <hacker@klever.net>2007-01-12 13:52:36 (UTC)
committer Michael Krelin <hacker@klever.net>2007-01-12 13:52:36 (UTC)
commitd6a92f4891cd730c1c3cdba90f474cf253534120 (patch) (side-by-side diff)
tree31848134d1192282b702b7bd99687bbe9043ee02 /configure.ac
parente79687a3d9a1631613de02d8e12bae36302b46ab (diff)
downloadlibopkele-d6a92f4891cd730c1c3cdba90f474cf253534120.zip
libopkele-d6a92f4891cd730c1c3cdba90f474cf253534120.tar.gz
libopkele-d6a92f4891cd730c1c3cdba90f474cf253534120.tar.bz2
version, date bump, NEWS summary
Diffstat (limited to 'configure.ac') (more/less context) (ignore whitespace changes)
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 2ce5f71..4729e92 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,78 +1,78 @@
-AC_INIT([libopkele], [0.0], [libopkele-bugs@klever.net])
+AC_INIT([libopkele], [0.1], [libopkele-bugs@klever.net])
AC_CONFIG_SRCDIR([include/opkele/opkele-config.h])
AC_CONFIG_HEADERS([config.h include/opkele/acconfig.h])
AM_INIT_AUTOMAKE([dist-bzip2])
AC_PROG_INSTALL
AC_PROG_CXX
AC_PROG_CC
AC_PROG_LIBTOOL
AC_HEADER_STDC
AC_PATH_PROG([XSLTPROC],[xsltproc],[true])
AC_WITH_PKGCONFIG
PKG_CHECK_MODULES([OPENSSL],[openssl],[
AC_MSG_RESULT([yes])
],[
AC_MSG_ERROR([no openssl library found. get one from http://www.openssl.org/])
]
)
WANT_KONFORKA="yes"
AC_ARG_ENABLE([konforka],
AC_HELP_STRING([--disable-konforka],[do not use konforka library (default: use if found)]),
[
test "${enableval}" = "no" && WANT_KONFORKA="no"
]
)
if test "${WANT_KONFORKA}" = "yes" ; then
PKG_CHECK_MODULES([KONFORKA],[konforka],[
AC_MSG_RESULT([yes])
AC_SUBST([KONFORKA_CFLAGS])
AC_SUBST([KONFORKA_LIBS])
AC_DEFINE([HAVE_KONFORKA],,[defined in presence of konforka library])
AC_DEFINE([OPKELE_HAVE_KONFORKA],,[defined in presence of konforka library])
AC_SUBST([KONFORKA_KONFORKA],[konforka])
],[
AC_MSG_RESULT([no])
]
)
fi
WANT_DOXYGEN="yes"
AC_ARG_ENABLE([doxygen],
AC_HELP_STRING([--disable-doxygen],[do not generate documentation]),
[
test "${enableval}" = "no" && WANT_DOXYGEN="no"
]
)
if test "${WANT_DOXYGEN}" = "yes" ; then
AC_WITH_DOXYGEN
AC_WITH_DOT
else
AM_CONDITIONAL([HAVE_DOXYGEN],[false])
AM_CONDITIONAL([HAVE_DOT],[false])
fi
LIBCURL_CHECK_CONFIG(,,,[
AC_MSG_ERROR([no required libcurl library. get one from http://curl.haxx.se/])
])
AC_WITH_PCRE([
AC_WITH_PCREPP(,[
AC_MSG_ERROR([no pcre++ library found. get one at http://www.daemon.de/PCRE])
])
],[
AC_MSG_ERROR([no pcre library found. get one at http://www.pcre.org/])
]
)
AC_CONFIG_FILES([
Makefile
libopkele.pc
Doxyfile
include/Makefile
lib/Makefile
])
AC_OUTPUT