author | Michael Krelin <hacker@klever.net> | 2008-04-06 09:31:10 (UTC) |
---|---|---|
committer | Michael Krelin <hacker@klever.net> | 2008-04-06 09:31:10 (UTC) |
commit | 752e484cd2fc239bc582a88fe7d62a225880ee3b (patch) (unidiff) | |
tree | ad53fd61add881c5262b9cbc66c5db41e179a993 /configure.ac | |
parent | c56867c814a70505e27501c8f02768a594d8e42d (diff) | |
parent | 1e3ed01c149aaeed5a64aacff218a5486128fc92 (diff) | |
download | libopkele-752e484cd2fc239bc582a88fe7d62a225880ee3b.zip libopkele-752e484cd2fc239bc582a88fe7d62a225880ee3b.tar.gz libopkele-752e484cd2fc239bc582a88fe7d62a225880ee3b.tar.bz2 |
Merge commit '1e3ed01c149aaeed5a64aacff218a5486128fc92' into devel/openid20
-rw-r--r-- | configure.ac | 4 |
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac index a49177f..0aa1272 100644 --- a/configure.ac +++ b/configure.ac | |||
@@ -165,32 +165,36 @@ AC_CHECK_HEADER([tidy.h],[ | |||
165 | if test -n "$PCRE_LIBS" -a -n "$PCRE_CFLAGS" ; then | 165 | if test -n "$PCRE_LIBS" -a -n "$PCRE_CFLAGS" ; then |
166 | AC_SUBST([PCRE_CFLAGS]) | 166 | AC_SUBST([PCRE_CFLAGS]) |
167 | AC_SUBST([PCRE_LIBS]) | 167 | AC_SUBST([PCRE_LIBS]) |
168 | : | 168 | : |
169 | else | 169 | else |
170 | PKG_CHECK_MODULES([PCRE],[libpcre],,[ | 170 | PKG_CHECK_MODULES([PCRE],[libpcre],,[ |
171 | AC_MSG_ERROR([no libpcre found, go get it at http://www.pcre.org/]) | 171 | AC_MSG_ERROR([no libpcre found, go get it at http://www.pcre.org/]) |
172 | ]) | 172 | ]) |
173 | fi | 173 | fi |
174 | 174 | ||
175 | PKG_CHECK_MODULES([SQLITE3],[sqlite3],[have_sqlite3=true],[have_sqlite3=false]) | 175 | PKG_CHECK_MODULES([SQLITE3],[sqlite3],[have_sqlite3=true],[have_sqlite3=false]) |
176 | AM_CONDITIONAL([HAVE_SQLITE3],[$have_sqlite3]) | 176 | AM_CONDITIONAL([HAVE_SQLITE3],[$have_sqlite3]) |
177 | PKG_CHECK_MODULES([KINGATE],[kingate-plaincgi],[have_kingate=true],[have_kingate=false]) | 177 | PKG_CHECK_MODULES([KINGATE],[kingate-plaincgi],[have_kingate=true],[have_kingate=false]) |
178 | AM_CONDITIONAL([HAVE_KINGATE],[$have_kingate]) | 178 | AM_CONDITIONAL([HAVE_KINGATE],[$have_kingate]) |
179 | PKG_CHECK_MODULES([UUID],[uuid],[have_uuid=true],[have_uuid=false]) | 179 | PKG_CHECK_MODULES([UUID],[uuid],[have_uuid=true],[have_uuid=false]) |
180 | AM_CONDITIONAL([HAVE_UUID],[$have_uuid]) | 180 | AM_CONDITIONAL([HAVE_UUID],[$have_uuid]) |
181 | if $have_uuid ; then | ||
182 | AC_DEFINE([HAVE_LIBUUID],,[defined in presence of libuuid]) | ||
183 | AC_SUBST([UUID_UUID],[uuid]) | ||
184 | fi | ||
181 | 185 | ||
182 | curl_ssl_verify_host="true" | 186 | curl_ssl_verify_host="true" |
183 | AC_ARG_ENABLE([ssl-verify-host], | 187 | AC_ARG_ENABLE([ssl-verify-host], |
184 | AC_HELP_STRING([--disable-ssl-verify-host],[disable cURL cert/host relationships verification]), | 188 | AC_HELP_STRING([--disable-ssl-verify-host],[disable cURL cert/host relationships verification]), |
185 | [ test "${enableval}" = "no" && curl_ssl_verify_host="false" ] | 189 | [ test "${enableval}" = "no" && curl_ssl_verify_host="false" ] |
186 | ) | 190 | ) |
187 | ${curl_ssl_verify_host} || AC_DEFINE([DISABLE_CURL_SSL_VERIFYHOST],,[defined if cURL is not to verify cert/host]) | 191 | ${curl_ssl_verify_host} || AC_DEFINE([DISABLE_CURL_SSL_VERIFYHOST],,[defined if cURL is not to verify cert/host]) |
188 | 192 | ||
189 | curl_ssl_verify_peer="true" | 193 | curl_ssl_verify_peer="true" |
190 | AC_ARG_ENABLE([ssl-verify-peer], | 194 | AC_ARG_ENABLE([ssl-verify-peer], |
191 | AC_HELP_STRING([--disable-ssl-verify-peer],[disable cURL cert validity verification]), | 195 | AC_HELP_STRING([--disable-ssl-verify-peer],[disable cURL cert validity verification]), |
192 | [ test "${enableval}" = "no" && curl_ssl_verify_peer="false" ] | 196 | [ test "${enableval}" = "no" && curl_ssl_verify_peer="false" ] |
193 | ) | 197 | ) |
194 | ${curl_ssl_verify_peer} || AC_DEFINE([DISABLE_CURL_SSL_VERIFYPEER],,[defined if cURL is not to verify cert validity]) | 198 | ${curl_ssl_verify_peer} || AC_DEFINE([DISABLE_CURL_SSL_VERIFYPEER],,[defined if cURL is not to verify cert validity]) |
195 | 199 | ||
196 | postels_law=true | 200 | postels_law=true |