summaryrefslogtreecommitdiffabout
path: root/configure.ac
authorMichael Krelin <hacker@klever.net>2009-12-22 22:37:28 (UTC)
committer Michael Krelin <hacker@klever.net>2009-12-22 22:37:28 (UTC)
commit3ad15ad20d08d45a2a077d8f8711ec5d915d2c40 (patch) (unidiff)
tree557e27277ce01a51a22461f836841fbf6ebd2b94 /configure.ac
parentd597166bcf3072e6e0dac58bd1edf2bdd79025b3 (diff)
downloadlibopkele-3ad15ad20d08d45a2a077d8f8711ec5d915d2c40.zip
libopkele-3ad15ad20d08d45a2a077d8f8711ec5d915d2c40.tar.gz
libopkele-3ad15ad20d08d45a2a077d8f8711ec5d915d2c40.tar.bz2
updated NEWS and bumped version2.0.4
Signed-off-by: Michael Krelin <hacker@klever.net>
Diffstat (limited to 'configure.ac') (more/less context) (ignore whitespace changes)
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 7fa2f85..e636253 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,251 +1,251 @@
1AC_INIT([libopkele], [2.0.3], [libopkele-bugs@klever.net]) 1AC_INIT([libopkele], [2.0.4], [libopkele-bugs@klever.net])
2AC_CONFIG_SRCDIR([include/opkele/opkele-config.h]) 2AC_CONFIG_SRCDIR([include/opkele/opkele-config.h])
3AC_CONFIG_HEADERS([config.h include/opkele/acconfig.h]) 3AC_CONFIG_HEADERS([config.h include/opkele/acconfig.h])
4AC_CONFIG_MACRO_DIR([aclocal.d]) 4AC_CONFIG_MACRO_DIR([aclocal.d])
5AC_CONFIG_AUX_DIR([aux.d]) 5AC_CONFIG_AUX_DIR([aux.d])
6AM_INIT_AUTOMAKE([dist-bzip2]) 6AM_INIT_AUTOMAKE([dist-bzip2])
7 7
8AC_PROG_INSTALL 8AC_PROG_INSTALL
9AC_PROG_CXX 9AC_PROG_CXX
10AC_PROG_CC 10AC_PROG_CC
11AC_PROG_LIBTOOL 11AC_PROG_LIBTOOL
12PKG_PROG_PKG_CONFIG 12PKG_PROG_PKG_CONFIG
13 13
14AC_HEADER_STDC 14AC_HEADER_STDC
15AC_CHECK_FUNCS([timegm]) 15AC_CHECK_FUNCS([timegm])
16 16
17AC_PATH_PROG([XSLTPROC],[xsltproc],[true]) 17AC_PATH_PROG([XSLTPROC],[xsltproc],[true])
18 18
19AC_MSG_CHECKING([for source tree version]) 19AC_MSG_CHECKING([for source tree version])
20if headrev=$(cd $srcdir && git rev-parse --verify HEAD 2>/dev/null) ; then 20if headrev=$(cd $srcdir && git rev-parse --verify HEAD 2>/dev/null) ; then
21 PACKAGE_SRC_VERSION="$(cd $srcdir && git describe --tags $headrev)" 21 PACKAGE_SRC_VERSION="$(cd $srcdir && git describe --tags $headrev)"
22 test "$PACKAGE_SRC_VERSION" = "$PACKAGE_VERSION" \ 22 test "$PACKAGE_SRC_VERSION" = "$PACKAGE_VERSION" \
23 -o "${PACKAGE_SRC_VERSION#${PACKAGE_VERSION}-}" != "$PACKAGE_SRC_VERSION" || PACKAGE_SRC_VERSION="${PACKAGE_VERSION}:${PACKAGE_SRC_VERSION}" 23 -o "${PACKAGE_SRC_VERSION#${PACKAGE_VERSION}-}" != "$PACKAGE_SRC_VERSION" || PACKAGE_SRC_VERSION="${PACKAGE_VERSION}:${PACKAGE_SRC_VERSION}"
24 ( cd $srcdir && git diff-index $headrev | read dirt ) && PACKAGE_SRC_VERSION="${PACKAGE_SRC_VERSION}-dirty" 24 ( cd $srcdir && git diff-index $headrev | read dirt ) && PACKAGE_SRC_VERSION="${PACKAGE_SRC_VERSION}-dirty"
25else 25else
26 PACKAGE_SRC_VERSION="$PACKAGE_VERSION" 26 PACKAGE_SRC_VERSION="$PACKAGE_VERSION"
27fi 27fi
28AC_MSG_RESULT([$PACKAGE_SRC_VERSION]) 28AC_MSG_RESULT([$PACKAGE_SRC_VERSION])
29AC_SUBST([PACKAGE_SRC_VERSION]) 29AC_SUBST([PACKAGE_SRC_VERSION])
30AC_DEFINE_UNQUOTED([PACKAGE_SRC_VERSION],["$PACKAGE_SRC_VERSION"],[more or less precise source tree version]) 30AC_DEFINE_UNQUOTED([PACKAGE_SRC_VERSION],["$PACKAGE_SRC_VERSION"],[more or less precise source tree version])
31 31
32tr1_mem_std="false" 32tr1_mem_std="false"
33tr1_mem_boost="false" 33tr1_mem_boost="false"
34AC_CHECK_SHAREDPTR(std::tr1,tr1/memory,[ tr1_mem_std=true ]) 34AC_CHECK_SHAREDPTR(std::tr1,tr1/memory,[ tr1_mem_std=true ])
35AC_CHECK_SHAREDPTR(boost,boost/shared_ptr.hpp,[ tr1_mem_boost=true ]) 35AC_CHECK_SHAREDPTR(boost,boost/shared_ptr.hpp,[ tr1_mem_boost=true ])
36tr1_mem="" 36tr1_mem=""
37AC_ARG_WITH([tr1-memory], 37AC_ARG_WITH([tr1-memory],
38 AC_HELP_STRING([--with-tr1-memory=<boost|std>],[select tr1/memory (shared_ptr<>) implementation to use]), 38 AC_HELP_STRING([--with-tr1-memory=<boost|std>],[select tr1/memory (shared_ptr<>) implementation to use]),
39 [ tr1_mem="$withval" ] 39 [ tr1_mem="$withval" ]
40) 40)
41AC_MSG_CHECKING([for tr1/memory implementation to use]) 41AC_MSG_CHECKING([for tr1/memory implementation to use])
42test -z "$tr1_mem" && $tr1_mem_std && tr1_mem=std 42test -z "$tr1_mem" && $tr1_mem_std && tr1_mem=std
43test -z "$tr1_mem" && $tr1_mem_boost && tr1_mem=boost 43test -z "$tr1_mem" && $tr1_mem_boost && tr1_mem=boost
44if test -z "$tr1_mem" ; then 44if test -z "$tr1_mem" ; then
45 AC_MSG_RESULT([none found]) 45 AC_MSG_RESULT([none found])
46else 46else
47 AC_MSG_RESULT([$tr1_mem]) 47 AC_MSG_RESULT([$tr1_mem])
48fi 48fi
49case "$tr1_mem" in 49case "$tr1_mem" in
50 std) 50 std)
51 $tr1_mem_std || AC_MSG_ERROR([std implementation requested, but not found]) 51 $tr1_mem_std || AC_MSG_ERROR([std implementation requested, but not found])
52 OPKELE_TR1_MEM_NS=std::tr1 52 OPKELE_TR1_MEM_NS=std::tr1
53 OPKELE_TR1_MEM_HEADER=tr1/memory 53 OPKELE_TR1_MEM_HEADER=tr1/memory
54 ;; 54 ;;
55 boost) 55 boost)
56 $tr1_mem_boost || AC_MSG_ERROR([boost implementation requested, but not found]) 56 $tr1_mem_boost || AC_MSG_ERROR([boost implementation requested, but not found])
57 OPKELE_TR1_MEM_NS=boost 57 OPKELE_TR1_MEM_NS=boost
58 OPKELE_TR1_MEM_HEADER=boost/shared_ptr.hpp 58 OPKELE_TR1_MEM_HEADER=boost/shared_ptr.hpp
59 ;; 59 ;;
60 *) 60 *)
61 AC_MSG_ERROR([no shared_ptr<> implementation found]) 61 AC_MSG_ERROR([no shared_ptr<> implementation found])
62 ;; 62 ;;
63esac 63esac
64AC_SUBST([OPKELE_TR1_MEM_NS]) 64AC_SUBST([OPKELE_TR1_MEM_NS])
65AC_SUBST([OPKELE_TR1_MEM_HEADER]) 65AC_SUBST([OPKELE_TR1_MEM_HEADER])
66 66
67AC_MSG_CHECKING([for deprecated attribute support]) 67AC_MSG_CHECKING([for deprecated attribute support])
68AC_COMPILE_IFELSE([ 68AC_COMPILE_IFELSE([
69 int __attribute__((deprecated)) deprecated_function(); 69 int __attribute__((deprecated)) deprecated_function();
70 ],[ 70 ],[
71 AC_MSG_RESULT([yes]) 71 AC_MSG_RESULT([yes])
72 AC_DEFINE([OPKELE_DEPRECATE],[__attribute__((deprecated))],[deprecated function attribute]) 72 AC_DEFINE([OPKELE_DEPRECATE],[__attribute__((deprecated))],[deprecated function attribute])
73 ],[ 73 ],[
74 AC_MSG_RESULT([no]) 74 AC_MSG_RESULT([no])
75 AC_DEFINE([OPKELE_DEPRECATE],,[deprecated function attribute]) 75 AC_DEFINE([OPKELE_DEPRECATE],,[deprecated function attribute])
76 ] 76 ]
77) 77)
78 78
79AC_LANG_PUSH([C++]) 79AC_LANG_PUSH([C++])
80AC_MSG_CHECKING([for abi::__cxa_demangle]) 80AC_MSG_CHECKING([for abi::__cxa_demangle])
81AC_COMPILE_IFELSE([ 81AC_COMPILE_IFELSE([
82 #include <typeinfo> 82 #include <typeinfo>
83 using namespace std; 83 using namespace std;
84 #include <cxxabi.h> 84 #include <cxxabi.h>
85 int main(int c,char **v) { 85 int main(int c,char **v) {
86 int dstat; 86 int dstat;
87 char *demangled = abi::__cxa_demangle(typeid(dstat).name(),0,0,&dstat); 87 char *demangled = abi::__cxa_demangle(typeid(dstat).name(),0,0,&dstat);
88 return 0; 88 return 0;
89 } 89 }
90 ],[ 90 ],[
91 AC_MSG_RESULT([yes]) 91 AC_MSG_RESULT([yes])
92 AC_DEFINE([HAVE_DEMANGLE],,[defined if abi::__cxa_demangle is available]) 92 AC_DEFINE([HAVE_DEMANGLE],,[defined if abi::__cxa_demangle is available])
93 ],[ 93 ],[
94 AC_MSG_RESULT([no]) 94 AC_MSG_RESULT([no])
95 ] 95 ]
96) 96)
97AC_LANG_POP([C++]) 97AC_LANG_POP([C++])
98 98
99 99
100 100
101 101
102PKG_CHECK_MODULES([OPENSSL],[openssl],,[ 102PKG_CHECK_MODULES([OPENSSL],[openssl],,[
103 AC_MSG_ERROR([no openssl library found. get one from http://www.openssl.org/]) 103 AC_MSG_ERROR([no openssl library found. get one from http://www.openssl.org/])
104]) 104])
105 105
106WANT_KONFORKA="yes" 106WANT_KONFORKA="yes"
107AC_ARG_ENABLE([konforka], 107AC_ARG_ENABLE([konforka],
108 AC_HELP_STRING([--disable-konforka],[do not use konforka library (default: use if found)]), 108 AC_HELP_STRING([--disable-konforka],[do not use konforka library (default: use if found)]),
109 [ 109 [
110 test "${enableval}" = "no" && WANT_KONFORKA="no" 110 test "${enableval}" = "no" && WANT_KONFORKA="no"
111 ] 111 ]
112) 112)
113if test "${WANT_KONFORKA}" = "yes" ; then 113if test "${WANT_KONFORKA}" = "yes" ; then
114 PKG_CHECK_MODULES([KONFORKA],[konforka],[ 114 PKG_CHECK_MODULES([KONFORKA],[konforka],[
115 AC_SUBST([KONFORKA_CFLAGS]) 115 AC_SUBST([KONFORKA_CFLAGS])
116 AC_SUBST([KONFORKA_LIBS]) 116 AC_SUBST([KONFORKA_LIBS])
117 AC_DEFINE([HAVE_KONFORKA],,[defined in presence of konforka library]) 117 AC_DEFINE([HAVE_KONFORKA],,[defined in presence of konforka library])
118 AC_DEFINE([OPKELE_HAVE_KONFORKA],,[defined in presence of konforka library]) 118 AC_DEFINE([OPKELE_HAVE_KONFORKA],,[defined in presence of konforka library])
119 AC_SUBST([KONFORKA_KONFORKA],[konforka]) 119 AC_SUBST([KONFORKA_KONFORKA],[konforka])
120 ],[true]) 120 ],[true])
121fi 121fi
122 122
123WANT_DOXYGEN="yes" 123WANT_DOXYGEN="yes"
124AC_ARG_ENABLE([doxygen], 124AC_ARG_ENABLE([doxygen],
125 AC_HELP_STRING([--disable-doxygen],[do not generate documentation]), 125 AC_HELP_STRING([--disable-doxygen],[do not generate documentation]),
126 [ 126 [
127 test "${enableval}" = "no" && WANT_DOXYGEN="no" 127 test "${enableval}" = "no" && WANT_DOXYGEN="no"
128 ] 128 ]
129) 129)
130if test "${WANT_DOXYGEN}" = "yes" ; then 130if test "${WANT_DOXYGEN}" = "yes" ; then
131 AC_WITH_DOXYGEN 131 AC_WITH_DOXYGEN
132 AC_WITH_DOT 132 AC_WITH_DOT
133else 133else
134 AM_CONDITIONAL([HAVE_DOXYGEN],[false]) 134 AM_CONDITIONAL([HAVE_DOXYGEN],[false])
135 AM_CONDITIONAL([HAVE_DOT],[false]) 135 AM_CONDITIONAL([HAVE_DOT],[false])
136fi 136fi
137 137
138LIBCURL_CHECK_CONFIG(,,,[ 138LIBCURL_CHECK_CONFIG(,,,[
139 AC_MSG_ERROR([no required libcurl library. get one from http://curl.haxx.se/]) 139 AC_MSG_ERROR([no required libcurl library. get one from http://curl.haxx.se/])
140]) 140])
141 141
142AC_CHECK_HEADER([expat.h],[ 142AC_CHECK_HEADER([expat.h],[
143 AC_CHECK_LIB([expat],[XML_ParserCreate],[ 143 AC_CHECK_LIB([expat],[XML_ParserCreate],[
144 EXPAT_LIBS=-lexpat 144 EXPAT_LIBS=-lexpat
145 EXPAT_CFLAGS= 145 EXPAT_CFLAGS=
146 AC_SUBST([EXPAT_LIBS]) 146 AC_SUBST([EXPAT_LIBS])
147 AC_SUBST([EXPAT_CFLAGS]) 147 AC_SUBST([EXPAT_CFLAGS])
148 ],[ 148 ],[
149 AC_MSG_ERROR([no required expat library. get one from http://expat.sourceforge.net/]) 149 AC_MSG_ERROR([no required expat library. get one from http://expat.sourceforge.net/])
150 ]) 150 ])
151],[ 151],[
152 AC_MSG_ERROR([no required expat library. get one from http://expat.sourceforge.net/]) 152 AC_MSG_ERROR([no required expat library. get one from http://expat.sourceforge.net/])
153]) 153])
154 154
155AC_CHECK_HEADERS([tidy.h tidy/tidy.h],[ 155AC_CHECK_HEADERS([tidy.h tidy/tidy.h],[
156 test -z "$TIDY_LIBS" && AC_CHECK_LIB([tidy],[tidyParseBuffer],[ 156 test -z "$TIDY_LIBS" && AC_CHECK_LIB([tidy],[tidyParseBuffer],[
157 TIDY_LIBS=-ltidy 157 TIDY_LIBS=-ltidy
158 TIDY_CFLAGS= 158 TIDY_CFLAGS=
159 AC_SUBST([TIDY_LIBS]) 159 AC_SUBST([TIDY_LIBS])
160 AC_SUBST([TIDY_CFLAGS]) 160 AC_SUBST([TIDY_CFLAGS])
161 ],[ 161 ],[
162 AC_MSG_ERROR([no required htmltidy library found. get one from http://tidy.sourceforge.net/]) 162 AC_MSG_ERROR([no required htmltidy library found. get one from http://tidy.sourceforge.net/])
163 ]) 163 ])
164],[ 164],[
165 test -z "$TIDY_LIBS" -a "$ac_header" = "tidy/tidy.h" \ 165 test -z "$TIDY_LIBS" -a "$ac_header" = "tidy/tidy.h" \
166 && AC_MSG_ERROR([no required htmltidy library found. get one from http://tidy.sourceforge.net/]) 166 && AC_MSG_ERROR([no required htmltidy library found. get one from http://tidy.sourceforge.net/])
167]) 167])
168 168
169PKG_CHECK_MODULES([SQLITE3],[sqlite3],[have_sqlite3=true],[have_sqlite3=false]) 169PKG_CHECK_MODULES([SQLITE3],[sqlite3],[have_sqlite3=true],[have_sqlite3=false])
170AM_CONDITIONAL([HAVE_SQLITE3],[$have_sqlite3]) 170AM_CONDITIONAL([HAVE_SQLITE3],[$have_sqlite3])
171PKG_CHECK_MODULES([KINGATE],[kingate-plaincgi],[have_kingate=true],[have_kingate=false]) 171PKG_CHECK_MODULES([KINGATE],[kingate-plaincgi],[have_kingate=true],[have_kingate=false])
172AM_CONDITIONAL([HAVE_KINGATE],[$have_kingate]) 172AM_CONDITIONAL([HAVE_KINGATE],[$have_kingate])
173PKG_CHECK_MODULES([UUID],[uuid],[have_uuid=true],[have_uuid=false]) 173PKG_CHECK_MODULES([UUID],[uuid],[have_uuid=true],[have_uuid=false])
174AM_CONDITIONAL([HAVE_UUID],[$have_uuid]) 174AM_CONDITIONAL([HAVE_UUID],[$have_uuid])
175if $have_uuid ; then 175if $have_uuid ; then
176 AC_DEFINE([HAVE_LIBUUID],,[defined in presence of libuuid]) 176 AC_DEFINE([HAVE_LIBUUID],,[defined in presence of libuuid])
177 AC_SUBST([UUID_UUID],[uuid]) 177 AC_SUBST([UUID_UUID],[uuid])
178fi 178fi
179 179
180curl_ssl_verify_host="true" 180curl_ssl_verify_host="true"
181AC_ARG_ENABLE([ssl-verify-host], 181AC_ARG_ENABLE([ssl-verify-host],
182 AC_HELP_STRING([--disable-ssl-verify-host],[disable cURL cert/host relationships verification]), 182 AC_HELP_STRING([--disable-ssl-verify-host],[disable cURL cert/host relationships verification]),
183 [ test "${enableval}" = "no" && curl_ssl_verify_host="false" ] 183 [ test "${enableval}" = "no" && curl_ssl_verify_host="false" ]
184) 184)
185${curl_ssl_verify_host} || AC_DEFINE([DISABLE_CURL_SSL_VERIFYHOST],,[defined if cURL is not to verify cert/host]) 185${curl_ssl_verify_host} || AC_DEFINE([DISABLE_CURL_SSL_VERIFYHOST],,[defined if cURL is not to verify cert/host])
186 186
187curl_ssl_verify_peer="true" 187curl_ssl_verify_peer="true"
188AC_ARG_ENABLE([ssl-verify-peer], 188AC_ARG_ENABLE([ssl-verify-peer],
189 AC_HELP_STRING([--disable-ssl-verify-peer],[disable cURL cert validity verification]), 189 AC_HELP_STRING([--disable-ssl-verify-peer],[disable cURL cert validity verification]),
190 [ test "${enableval}" = "no" && curl_ssl_verify_peer="false" ] 190 [ test "${enableval}" = "no" && curl_ssl_verify_peer="false" ]
191) 191)
192${curl_ssl_verify_peer} || AC_DEFINE([DISABLE_CURL_SSL_VERIFYPEER],,[defined if cURL is not to verify cert validity]) 192${curl_ssl_verify_peer} || AC_DEFINE([DISABLE_CURL_SSL_VERIFYPEER],,[defined if cURL is not to verify cert validity])
193 193
194postels_law=true 194postels_law=true
195AC_ARG_ENABLE([postels-law], 195AC_ARG_ENABLE([postels-law],
196 AC_HELP_STRING([--disable-postels-law],[Be strict, do not adhere to Postel's Law ("be conservative in what you do, be liberal in what you accept from others", RFC 793)]), 196 AC_HELP_STRING([--disable-postels-law],[Be strict, do not adhere to Postel's Law ("be conservative in what you do, be liberal in what you accept from others", RFC 793)]),
197 [ test "${enableval}" = "no" && postels_law=false ] 197 [ test "${enableval}" = "no" && postels_law=false ]
198) 198)
199$postels_law && AC_DEFINE([POSTELS_LAW],,[defined if we want to adhere to Postel's Law]) 199$postels_law && AC_DEFINE([POSTELS_LAW],,[defined if we want to adhere to Postel's Law])
200 200
201AC_DEFINE_UNQUOTED([OPKELE_SRC_DIR],["$PWD"],[source directory]) 201AC_DEFINE_UNQUOTED([OPKELE_SRC_DIR],["$PWD"],[source directory])
202 202
203nitpick=false 203nitpick=false
204AC_ARG_ENABLE([nitpicking], 204AC_ARG_ENABLE([nitpicking],
205 AC_HELP_STRING([--enable-nitpicking],[make compiler somewhat overly fastidious about the code it deals with]), 205 AC_HELP_STRING([--enable-nitpicking],[make compiler somewhat overly fastidious about the code it deals with]),
206 [ test "$enableval" = "no" || nitpick=true ] 206 [ test "$enableval" = "no" || nitpick=true ]
207) 207)
208if $nitpick ; then 208if $nitpick ; then
209 CPP_NITPICK="-pedantic -Wall -Wextra -Wundef -Wshadow \ 209 CPP_NITPICK="-pedantic -Wall -Wextra -Wundef -Wshadow \
210 -Wunsafe-loop-optimizations -Wconversion -Wmissing-format-attribute \ 210 -Wunsafe-loop-optimizations -Wconversion -Wmissing-format-attribute \
211 -Wredundant-decls -ansi" 211 -Wredundant-decls -ansi"
212 # -Wlogical-op -Wmissing-noreturn 212 # -Wlogical-op -Wmissing-noreturn
213 C_NITPICK="$CPP_NITPICK" 213 C_NITPICK="$CPP_NITPICK"
214 CXX_NITPICK="$C_NITPICK" 214 CXX_NITPICK="$C_NITPICK"
215 215
216 CPPFLAGS="$CPPFLAGS $CPP_NITPICK" 216 CPPFLAGS="$CPPFLAGS $CPP_NITPICK"
217 CFLAGS="$CFLAGS $C_NITPICK" 217 CFLAGS="$CFLAGS $C_NITPICK"
218 CXXFLAGS="$CXXFLAGS $CXX_NITPICK" 218 CXXFLAGS="$CXXFLAGS $CXX_NITPICK"
219fi 219fi
220 220
221ndebug=true 221ndebug=true
222AC_ARG_ENABLE([debug], 222AC_ARG_ENABLE([debug],
223 AC_HELP_STRING([--enable-debug],[enable debugging code]), 223 AC_HELP_STRING([--enable-debug],[enable debugging code]),
224 [ test "$enableval" = "no" || ndebug=false ] 224 [ test "$enableval" = "no" || ndebug=false ]
225) 225)
226if $ndebug ; then 226if $ndebug ; then
227 CPPFLAGS_DEBUG="-DNDEBUG" 227 CPPFLAGS_DEBUG="-DNDEBUG"
228else 228else
229 CPPFLAGS_DEBUG="" 229 CPPFLAGS_DEBUG=""
230fi 230fi
231AC_SUBST([CPPFLAGS_DEBUG]) 231AC_SUBST([CPPFLAGS_DEBUG])
232 232
233xri_proxy_url="https://xri.net/" 233xri_proxy_url="https://xri.net/"
234AC_MSG_CHECKING([for XRI resolver proxy]) 234AC_MSG_CHECKING([for XRI resolver proxy])
235AC_ARG_ENABLE([xri-proxy], 235AC_ARG_ENABLE([xri-proxy],
236 AC_HELP_STRING([--with-xri-proxy=url],[set xri proxy for use when resolving xri identities, default is https://xri.net/]), 236 AC_HELP_STRING([--with-xri-proxy=url],[set xri proxy for use when resolving xri identities, default is https://xri.net/]),
237 [ xri_proxy_url="$withval" ] 237 [ xri_proxy_url="$withval" ]
238) 238)
239AC_MSG_RESULT([$xri_proxy_url]) 239AC_MSG_RESULT([$xri_proxy_url])
240AC_DEFINE_UNQUOTED([XRI_PROXY_URL],["$xri_proxy_url"],[XRI proxy resolver URL]) 240AC_DEFINE_UNQUOTED([XRI_PROXY_URL],["$xri_proxy_url"],[XRI proxy resolver URL])
241 241
242AC_CONFIG_FILES([ 242AC_CONFIG_FILES([
243 Makefile 243 Makefile
244 libopkele.pc 244 libopkele.pc
245 Doxyfile 245 Doxyfile
246 include/Makefile 246 include/Makefile
247 include/opkele/tr1-mem.h 247 include/opkele/tr1-mem.h
248 lib/Makefile 248 lib/Makefile
249 test/Makefile 249 test/Makefile
250]) 250])
251AC_OUTPUT 251AC_OUTPUT