author | Michael Krelin <hacker@klever.net> | 2008-06-25 21:24:53 (UTC) |
---|---|---|
committer | Michael Krelin <hacker@klever.net> | 2008-06-25 21:24:53 (UTC) |
commit | 2744ea9808c3a6c50f8be78a9a71f6d3b2ba7e00 (patch) (unidiff) | |
tree | a9c124efee2b4edbeaeb646f1b94928bdc4e8c4c /configure.ac | |
parent | 04aac0e097992df01e17fbbb62a5a7d9682bcea9 (diff) | |
download | libopkele-2744ea9808c3a6c50f8be78a9a71f6d3b2ba7e00.zip libopkele-2744ea9808c3a6c50f8be78a9a71f6d3b2ba7e00.tar.gz libopkele-2744ea9808c3a6c50f8be78a9a71f6d3b2ba7e00.tar.bz2 |
improved detection of htmltidy for debian and co.
Signed-off-by: Michael Krelin <hacker@klever.net>
-rw-r--r-- | configure.ac | 5 |
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac index 0aa1272..a66e53d 100644 --- a/configure.ac +++ b/configure.ac | |||
@@ -120,75 +120,76 @@ fi | |||
120 | WANT_DOXYGEN="yes" | 120 | WANT_DOXYGEN="yes" |
121 | AC_ARG_ENABLE([doxygen], | 121 | AC_ARG_ENABLE([doxygen], |
122 | AC_HELP_STRING([--disable-doxygen],[do not generate documentation]), | 122 | AC_HELP_STRING([--disable-doxygen],[do not generate documentation]), |
123 | [ | 123 | [ |
124 | test "${enableval}" = "no" && WANT_DOXYGEN="no" | 124 | test "${enableval}" = "no" && WANT_DOXYGEN="no" |
125 | ] | 125 | ] |
126 | ) | 126 | ) |
127 | if test "${WANT_DOXYGEN}" = "yes" ; then | 127 | if test "${WANT_DOXYGEN}" = "yes" ; then |
128 | AC_WITH_DOXYGEN | 128 | AC_WITH_DOXYGEN |
129 | AC_WITH_DOT | 129 | AC_WITH_DOT |
130 | else | 130 | else |
131 | AM_CONDITIONAL([HAVE_DOXYGEN],[false]) | 131 | AM_CONDITIONAL([HAVE_DOXYGEN],[false]) |
132 | AM_CONDITIONAL([HAVE_DOT],[false]) | 132 | AM_CONDITIONAL([HAVE_DOT],[false]) |
133 | fi | 133 | fi |
134 | 134 | ||
135 | LIBCURL_CHECK_CONFIG(,,,[ | 135 | LIBCURL_CHECK_CONFIG(,,,[ |
136 | AC_MSG_ERROR([no required libcurl library. get one from http://curl.haxx.se/]) | 136 | AC_MSG_ERROR([no required libcurl library. get one from http://curl.haxx.se/]) |
137 | ]) | 137 | ]) |
138 | 138 | ||
139 | AC_CHECK_HEADER([expat.h],[ | 139 | AC_CHECK_HEADER([expat.h],[ |
140 | AC_CHECK_LIB([expat],[XML_ParserCreate],[ | 140 | AC_CHECK_LIB([expat],[XML_ParserCreate],[ |
141 | EXPAT_LIBS=-lexpat | 141 | EXPAT_LIBS=-lexpat |
142 | EXPAT_CFLAGS= | 142 | EXPAT_CFLAGS= |
143 | AC_SUBST([EXPAT_LIBS]) | 143 | AC_SUBST([EXPAT_LIBS]) |
144 | AC_SUBST([EXPAT_CFLAGS]) | 144 | AC_SUBST([EXPAT_CFLAGS]) |
145 | ],[ | 145 | ],[ |
146 | AC_MSG_ERROR([no required expat library. get one from http://expat.sourceforge.net/]) | 146 | AC_MSG_ERROR([no required expat library. get one from http://expat.sourceforge.net/]) |
147 | ]) | 147 | ]) |
148 | ],[ | 148 | ],[ |
149 | AC_MSG_ERROR([no required expat library. get one from http://expat.sourceforge.net/]) | 149 | AC_MSG_ERROR([no required expat library. get one from http://expat.sourceforge.net/]) |
150 | ]) | 150 | ]) |
151 | 151 | ||
152 | AC_CHECK_HEADER([tidy.h],[ | 152 | AC_CHECK_HEADERS([tidy.h tidy/tidy.h],[ |
153 | AC_CHECK_LIB([tidy],[tidyParseBuffer],[ | 153 | AC_CHECK_LIB([tidy],[tidyParseBuffer],[ |
154 | TIDY_LIBS=-ltidy | 154 | TIDY_LIBS=-ltidy |
155 | TIDY_CFLAGS= | 155 | TIDY_CFLAGS= |
156 | AC_SUBST([TIDY_LIBS]) | 156 | AC_SUBST([TIDY_LIBS]) |
157 | AC_SUBST([TIDY_CFLAGS]) | 157 | AC_SUBST([TIDY_CFLAGS]) |
158 | ],[ | 158 | ],[ |
159 | AC_MSG_ERROR([no required htmltidy library found. get one from http://tidy.sourceforge.net/]) | 159 | AC_MSG_ERROR([no required htmltidy library found. get one from http://tidy.sourceforge.net/]) |
160 | ]) | 160 | ]) |
161 | ],[ | 161 | ],[ |
162 | AC_MSG_ERROR([no required htmltidy library found. get one from http://tidy.sourceforge.net/]) | 162 | test "$ac_header" = "tidy/tidy.h" \ |
163 | && AC_MSG_ERROR([no required htmltidy library found. get one from http://tidy.sourceforge.net/]) | ||
163 | ]) | 164 | ]) |
164 | 165 | ||
165 | if test -n "$PCRE_LIBS" -a -n "$PCRE_CFLAGS" ; then | 166 | if test -n "$PCRE_LIBS" -a -n "$PCRE_CFLAGS" ; then |
166 | AC_SUBST([PCRE_CFLAGS]) | 167 | AC_SUBST([PCRE_CFLAGS]) |
167 | AC_SUBST([PCRE_LIBS]) | 168 | AC_SUBST([PCRE_LIBS]) |
168 | : | 169 | : |
169 | else | 170 | else |
170 | PKG_CHECK_MODULES([PCRE],[libpcre],,[ | 171 | PKG_CHECK_MODULES([PCRE],[libpcre],,[ |
171 | AC_MSG_ERROR([no libpcre found, go get it at http://www.pcre.org/]) | 172 | AC_MSG_ERROR([no libpcre found, go get it at http://www.pcre.org/]) |
172 | ]) | 173 | ]) |
173 | fi | 174 | fi |
174 | 175 | ||
175 | PKG_CHECK_MODULES([SQLITE3],[sqlite3],[have_sqlite3=true],[have_sqlite3=false]) | 176 | PKG_CHECK_MODULES([SQLITE3],[sqlite3],[have_sqlite3=true],[have_sqlite3=false]) |
176 | AM_CONDITIONAL([HAVE_SQLITE3],[$have_sqlite3]) | 177 | AM_CONDITIONAL([HAVE_SQLITE3],[$have_sqlite3]) |
177 | PKG_CHECK_MODULES([KINGATE],[kingate-plaincgi],[have_kingate=true],[have_kingate=false]) | 178 | PKG_CHECK_MODULES([KINGATE],[kingate-plaincgi],[have_kingate=true],[have_kingate=false]) |
178 | AM_CONDITIONAL([HAVE_KINGATE],[$have_kingate]) | 179 | AM_CONDITIONAL([HAVE_KINGATE],[$have_kingate]) |
179 | PKG_CHECK_MODULES([UUID],[uuid],[have_uuid=true],[have_uuid=false]) | 180 | PKG_CHECK_MODULES([UUID],[uuid],[have_uuid=true],[have_uuid=false]) |
180 | AM_CONDITIONAL([HAVE_UUID],[$have_uuid]) | 181 | AM_CONDITIONAL([HAVE_UUID],[$have_uuid]) |
181 | if $have_uuid ; then | 182 | if $have_uuid ; then |
182 | AC_DEFINE([HAVE_LIBUUID],,[defined in presence of libuuid]) | 183 | AC_DEFINE([HAVE_LIBUUID],,[defined in presence of libuuid]) |
183 | AC_SUBST([UUID_UUID],[uuid]) | 184 | AC_SUBST([UUID_UUID],[uuid]) |
184 | fi | 185 | fi |
185 | 186 | ||
186 | curl_ssl_verify_host="true" | 187 | curl_ssl_verify_host="true" |
187 | AC_ARG_ENABLE([ssl-verify-host], | 188 | AC_ARG_ENABLE([ssl-verify-host], |
188 | AC_HELP_STRING([--disable-ssl-verify-host],[disable cURL cert/host relationships verification]), | 189 | AC_HELP_STRING([--disable-ssl-verify-host],[disable cURL cert/host relationships verification]), |
189 | [ test "${enableval}" = "no" && curl_ssl_verify_host="false" ] | 190 | [ test "${enableval}" = "no" && curl_ssl_verify_host="false" ] |
190 | ) | 191 | ) |
191 | ${curl_ssl_verify_host} || AC_DEFINE([DISABLE_CURL_SSL_VERIFYHOST],,[defined if cURL is not to verify cert/host]) | 192 | ${curl_ssl_verify_host} || AC_DEFINE([DISABLE_CURL_SSL_VERIFYHOST],,[defined if cURL is not to verify cert/host]) |
192 | 193 | ||
193 | curl_ssl_verify_peer="true" | 194 | curl_ssl_verify_peer="true" |
194 | AC_ARG_ENABLE([ssl-verify-peer], | 195 | AC_ARG_ENABLE([ssl-verify-peer], |