summaryrefslogtreecommitdiffabout
path: root/configure.ac
authorMichael Krelin <hacker@klever.net>2009-04-11 16:44:46 (UTC)
committer Michael Krelin <hacker@klever.net>2009-04-11 16:44:46 (UTC)
commitd0509b2da90aa54ea923cf5731174e6b0a33d0eb (patch) (unidiff)
tree3dc38d594f11f1588f3a8ac830c1d72ef7a934a3 /configure.ac
parentf3308ce9dbe8d07a9b1f71d158b0e67c017044ce (diff)
downloadlibopkele-d0509b2da90aa54ea923cf5731174e6b0a33d0eb.zip
libopkele-d0509b2da90aa54ea923cf5731174e6b0a33d0eb.tar.gz
libopkele-d0509b2da90aa54ea923cf5731174e6b0a33d0eb.tar.bz2
add libtool macros to distributed tarball
Diffstat (limited to 'configure.ac') (more/less context) (ignore whitespace changes)
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a6de8c3..fd68b5b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,99 +1,100 @@
1AC_INIT([libopkele], [2.0.2], [libopkele-bugs@klever.net]) 1AC_INIT([libopkele], [2.0.2], [libopkele-bugs@klever.net])
2AC_CONFIG_SRCDIR([include/opkele/opkele-config.h]) 2AC_CONFIG_SRCDIR([include/opkele/opkele-config.h])
3AC_CONFIG_HEADERS([config.h include/opkele/acconfig.h]) 3AC_CONFIG_HEADERS([config.h include/opkele/acconfig.h])
4AC_CONFIG_MACRO_DIR([aclocal.d])
4AM_INIT_AUTOMAKE([dist-bzip2]) 5AM_INIT_AUTOMAKE([dist-bzip2])
5 6
6AC_PROG_INSTALL 7AC_PROG_INSTALL
7AC_PROG_CXX 8AC_PROG_CXX
8AC_PROG_CC 9AC_PROG_CC
9AC_PROG_LIBTOOL 10AC_PROG_LIBTOOL
10PKG_PROG_PKG_CONFIG 11PKG_PROG_PKG_CONFIG
11 12
12AC_HEADER_STDC 13AC_HEADER_STDC
13AC_CHECK_FUNCS([timegm]) 14AC_CHECK_FUNCS([timegm])
14 15
15AC_PATH_PROG([XSLTPROC],[xsltproc],[true]) 16AC_PATH_PROG([XSLTPROC],[xsltproc],[true])
16 17
17AC_MSG_CHECKING([for source tree version]) 18AC_MSG_CHECKING([for source tree version])
18if headrev=$(cd $srcdir && git rev-parse --verify HEAD 2>/dev/null) ; then 19if headrev=$(cd $srcdir && git rev-parse --verify HEAD 2>/dev/null) ; then
19 PACKAGE_SRC_VERSION="$(cd $srcdir && git describe --tags $headrev)" 20 PACKAGE_SRC_VERSION="$(cd $srcdir && git describe --tags $headrev)"
20 test "$PACKAGE_SRC_VERSION" = "$PACKAGE_VERSION" \ 21 test "$PACKAGE_SRC_VERSION" = "$PACKAGE_VERSION" \
21 -o "${PACKAGE_SRC_VERSION#${PACKAGE_VERSION}-}" != "$PACKAGE_SRC_VERSION" || PACKAGE_SRC_VERSION="${PACKAGE_VERSION}:${PACKAGE_SRC_VERSION}" 22 -o "${PACKAGE_SRC_VERSION#${PACKAGE_VERSION}-}" != "$PACKAGE_SRC_VERSION" || PACKAGE_SRC_VERSION="${PACKAGE_VERSION}:${PACKAGE_SRC_VERSION}"
22 ( cd $srcdir && git diff-index $headrev | read dirt ) && PACKAGE_SRC_VERSION="${PACKAGE_SRC_VERSION}-dirty" 23 ( cd $srcdir && git diff-index $headrev | read dirt ) && PACKAGE_SRC_VERSION="${PACKAGE_SRC_VERSION}-dirty"
23else 24else
24 PACKAGE_SRC_VERSION="$PACKAGE_VERSION" 25 PACKAGE_SRC_VERSION="$PACKAGE_VERSION"
25fi 26fi
26AC_MSG_RESULT([$PACKAGE_SRC_VERSION]) 27AC_MSG_RESULT([$PACKAGE_SRC_VERSION])
27AC_SUBST([PACKAGE_SRC_VERSION]) 28AC_SUBST([PACKAGE_SRC_VERSION])
28AC_DEFINE_UNQUOTED([PACKAGE_SRC_VERSION],["$PACKAGE_SRC_VERSION"],[more or less precise source tree version]) 29AC_DEFINE_UNQUOTED([PACKAGE_SRC_VERSION],["$PACKAGE_SRC_VERSION"],[more or less precise source tree version])
29 30
30tr1_mem_std="false" 31tr1_mem_std="false"
31tr1_mem_boost="false" 32tr1_mem_boost="false"
32AC_CHECK_SHAREDPTR(std::tr1,tr1/memory,[ tr1_mem_std=true ]) 33AC_CHECK_SHAREDPTR(std::tr1,tr1/memory,[ tr1_mem_std=true ])
33AC_CHECK_SHAREDPTR(boost,boost/shared_ptr.hpp,[ tr1_mem_boost=true ]) 34AC_CHECK_SHAREDPTR(boost,boost/shared_ptr.hpp,[ tr1_mem_boost=true ])
34tr1_mem="" 35tr1_mem=""
35AC_ARG_WITH([tr1-memory], 36AC_ARG_WITH([tr1-memory],
36 AC_HELP_STRING([--with-tr1-memory=<boost|std>],[select tr1/memory (shared_ptr<>) implementation to use]), 37 AC_HELP_STRING([--with-tr1-memory=<boost|std>],[select tr1/memory (shared_ptr<>) implementation to use]),
37 [ tr1_mem="$withval" ] 38 [ tr1_mem="$withval" ]
38) 39)
39AC_MSG_CHECKING([for tr1/memory implementation to use]) 40AC_MSG_CHECKING([for tr1/memory implementation to use])
40test -z "$tr1_mem" && $tr1_mem_std && tr1_mem=std 41test -z "$tr1_mem" && $tr1_mem_std && tr1_mem=std
41test -z "$tr1_mem" && $tr1_mem_boost && tr1_mem=boost 42test -z "$tr1_mem" && $tr1_mem_boost && tr1_mem=boost
42if test -z "$tr1_mem" ; then 43if test -z "$tr1_mem" ; then
43 AC_MSG_RESULT([none found]) 44 AC_MSG_RESULT([none found])
44else 45else
45 AC_MSG_RESULT([$tr1_mem]) 46 AC_MSG_RESULT([$tr1_mem])
46fi 47fi
47case "$tr1_mem" in 48case "$tr1_mem" in
48 std) 49 std)
49 $tr1_mem_std || AC_MSG_ERROR([std implementation requested, but not found]) 50 $tr1_mem_std || AC_MSG_ERROR([std implementation requested, but not found])
50 OPKELE_TR1_MEM_NS=std::tr1 51 OPKELE_TR1_MEM_NS=std::tr1
51 OPKELE_TR1_MEM_HEADER=tr1/memory 52 OPKELE_TR1_MEM_HEADER=tr1/memory
52 ;; 53 ;;
53 boost) 54 boost)
54 $tr1_mem_boost || AC_MSG_ERROR([boost implementation requested, but not found]) 55 $tr1_mem_boost || AC_MSG_ERROR([boost implementation requested, but not found])
55 OPKELE_TR1_MEM_NS=boost 56 OPKELE_TR1_MEM_NS=boost
56 OPKELE_TR1_MEM_HEADER=boost/shared_ptr.hpp 57 OPKELE_TR1_MEM_HEADER=boost/shared_ptr.hpp
57 ;; 58 ;;
58 *) 59 *)
59 AC_MSG_ERROR([no shared_ptr<> implementation found]) 60 AC_MSG_ERROR([no shared_ptr<> implementation found])
60 ;; 61 ;;
61esac 62esac
62AC_SUBST([OPKELE_TR1_MEM_NS]) 63AC_SUBST([OPKELE_TR1_MEM_NS])
63AC_SUBST([OPKELE_TR1_MEM_HEADER]) 64AC_SUBST([OPKELE_TR1_MEM_HEADER])
64 65
65AC_MSG_CHECKING([for deprecated attribute support]) 66AC_MSG_CHECKING([for deprecated attribute support])
66AC_COMPILE_IFELSE([ 67AC_COMPILE_IFELSE([
67 int __attribute__((deprecated)) deprecated_function(); 68 int __attribute__((deprecated)) deprecated_function();
68 ],[ 69 ],[
69 AC_MSG_RESULT([yes]) 70 AC_MSG_RESULT([yes])
70 AC_DEFINE([OPKELE_DEPRECATE],[__attribute__((deprecated))],[deprecated function attribute]) 71 AC_DEFINE([OPKELE_DEPRECATE],[__attribute__((deprecated))],[deprecated function attribute])
71 ],[ 72 ],[
72 AC_MSG_RESULT([no]) 73 AC_MSG_RESULT([no])
73 AC_DEFINE([OPKELE_DEPRECATE],,[deprecated function attribute]) 74 AC_DEFINE([OPKELE_DEPRECATE],,[deprecated function attribute])
74 ] 75 ]
75) 76)
76 77
77AC_LANG_PUSH([C++]) 78AC_LANG_PUSH([C++])
78AC_MSG_CHECKING([for abi::__cxa_demangle]) 79AC_MSG_CHECKING([for abi::__cxa_demangle])
79AC_COMPILE_IFELSE([ 80AC_COMPILE_IFELSE([
80 #include <typeinfo> 81 #include <typeinfo>
81 using namespace std; 82 using namespace std;
82 #include <cxxabi.h> 83 #include <cxxabi.h>
83 int main(int c,char **v) { 84 int main(int c,char **v) {
84 int dstat; 85 int dstat;
85 char *demangled = abi::__cxa_demangle(typeid(dstat).name(),0,0,&dstat); 86 char *demangled = abi::__cxa_demangle(typeid(dstat).name(),0,0,&dstat);
86 return 0; 87 return 0;
87 } 88 }
88 ],[ 89 ],[
89 AC_MSG_RESULT([yes]) 90 AC_MSG_RESULT([yes])
90 AC_DEFINE([HAVE_DEMANGLE],,[defined if abi::__cxa_demangle is available]) 91 AC_DEFINE([HAVE_DEMANGLE],,[defined if abi::__cxa_demangle is available])
91 ],[ 92 ],[
92 AC_MSG_RESULT([no]) 93 AC_MSG_RESULT([no])
93 ] 94 ]
94) 95)
95AC_LANG_POP([C++]) 96AC_LANG_POP([C++])
96 97
97 98
98 99
99 100