summaryrefslogtreecommitdiffabout
path: root/configure.ac
authorMichael Krelin <hacker@klever.net>2005-07-19 13:08:32 (UTC)
committer Michael Krelin <hacker@klever.net>2005-07-19 13:08:32 (UTC)
commit4c82851dd5d5644a89d4f269079bf901f763ee33 (patch) (unidiff)
treeb64c8b3c9a1be88e2a9c3f762272e0b4509ba7d9 /configure.ac
parent907343b0c973eb295bec8795902a6d49744e9174 (diff)
downloadlibopkele-4c82851dd5d5644a89d4f269079bf901f763ee33.zip
libopkele-4c82851dd5d5644a89d4f269079bf901f763ee33.tar.gz
libopkele-4c82851dd5d5644a89d4f269079bf901f763ee33.tar.bz2
initial commit of libopkele - OpenID support library
Diffstat (limited to 'configure.ac') (more/less context) (ignore whitespace changes)
-rw-r--r--configure.ac87
1 files changed, 87 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..a31f5b1
--- a/dev/null
+++ b/configure.ac
@@ -0,0 +1,87 @@
1AC_INIT([libopkele], [0.0], [libopkele-bugs@klever.net])
2AC_CONFIG_SRCDIR([include/opkele/opkele-config.h])
3AC_CONFIG_HEADERS([config.h include/opkele/acconfig.h])
4AM_INIT_AUTOMAKE([dist-bzip2])
5
6AC_PROG_INSTALL
7AC_PROG_CXX
8AC_PROG_CC
9AC_PROG_LIBTOOL
10
11AC_HEADER_STDC
12
13AC_PATH_PROG([XSLTPROC],[xsltproc],[true])
14AC_WITH_PKGCONFIG
15
16PKG_CHECK_MODULES([OPENSSL],[openssl],[
17 AC_MSG_RESULT([yes])
18 ],[
19 AC_MSG_ERROR([no openssl library found. get one from http://www.openssl.org/])
20 ]
21)
22
23WANT_KONFORKA="yes"
24AC_ARG_ENABLE([konforka],
25 AC_HELP_STRING([--disable-konforka],[do not use konforka library (default: use if found)]),
26 [
27 test "${enableval}" = "no" && WANT_KONFORKA="no"
28 ]
29)
30if test "${WANT_KONFORKA}" = "yes" ; then
31 PKG_CHECK_MODULES([KONFORKA],[konforka],[
32 AC_MSG_RESULT([yes])
33 AC_SUBST([KONFORKA_CFLAGS])
34 AC_SUBST([KONFORKA_LIBS])
35 AC_DEFINE([HAVE_KONFORKA],,[defined in presence of konforka library])
36 AC_DEFINE([OPKELE_HAVE_KONFORKA],,[defined in presence of konforka library])
37 AC_SUBST([KONFORKA_KONFORKA],[konforka])
38 ]
39 )
40fi
41
42AC_LANG_PUSH([C++])
43 AC_CHECK_LIB([mimetic],[main],[
44 MIMETIC_LIBS=-lmimetic
45 AC_SUBST([MIMETIC_CFLAGS])
46 AC_SUBST([MIMETIC_LIBS])
47 ],[
48 AC_MSG_ERROR([no mimetic library found. get one from http://codesink.org/mimetic_mime_library.html])
49 ]
50 )
51AC_LANG_POP([C++])
52
53WANT_DOXYGEN="yes"
54AC_ARG_ENABLE([doxygen],
55 AC_HELP_STRING([--disable-doxygen],[do not generate documentation]),
56 [
57 test "${enableval}" = "no" && WANT_DOXYGEN="no"
58 ]
59)
60if test "${WANT_DOXYGEN}" = "yes" ; then
61 AC_WITH_DOXYGEN
62 AC_WITH_DOT
63else
64 AM_CONDITIONAL([HAVE_DOXYGEN],[false])
65 AM_CONDITIONAL([HAVE_DOT],[false])
66fi
67
68LIBCURL_CHECK_CONFIG(,,,[
69 AC_MSG_ERROR([no required libcurl library. get one from http://curl.haxx.se/])
70])
71AC_WITH_PCRE([
72 AC_WITH_PCREPP(,[
73 AC_MSG_ERROR([no pcre++ library found. get one at http://www.daemon.de/PCRE])
74 ])
75 ],[
76 AC_MSG_ERROR([no pcre library found. get one at http://www.pcre.org/])
77 ]
78)
79
80AC_CONFIG_FILES([
81 Makefile
82 libopkele.pc
83 Doxyfile
84 include/Makefile
85 lib/Makefile
86])
87AC_OUTPUT