summaryrefslogtreecommitdiffabout
path: root/configure.ac
authorMichael Krelin <hacker@klever.net>2007-09-22 20:56:57 (UTC)
committer Michael Krelin <hacker@klever.net>2007-09-22 20:56:57 (UTC)
commit5cb71518360f865cd4448a083b5d481e6f356a3e (patch) (unidiff)
tree4faeab2b1a1a14c589745be714be18471879e781 /configure.ac
parent5cfe3f2743c2b2eb2689090516a4e667fd8ca29a (diff)
downloadlibopkele-5cb71518360f865cd4448a083b5d481e6f356a3e.zip
libopkele-5cb71518360f865cd4448a083b5d481e6f356a3e.tar.gz
libopkele-5cb71518360f865cd4448a083b5d481e6f356a3e.tar.bz2
got rid of all pcre wrappers altogether
although all claims against pcre++ make absolutely no sense. But for now I'll live with no wrappers at all. I may reconsider it when implementing more sophisticated discovery mechanisms for upcoming extensions. Signed-off-by: Michael Krelin <hacker@klever.net>
Diffstat (limited to 'configure.ac') (more/less context) (ignore whitespace changes)
-rw-r--r--configure.ac47
1 files changed, 3 insertions, 44 deletions
diff --git a/configure.ac b/configure.ac
index 00c6bc4..53e22ba 100644
--- a/configure.ac
+++ b/configure.ac
@@ -53,50 +53,9 @@ LIBCURL_CHECK_CONFIG(,,,[
53 AC_MSG_ERROR([no required libcurl library. get one from http://curl.haxx.se/]) 53 AC_MSG_ERROR([no required libcurl library. get one from http://curl.haxx.se/])
54]) 54])
55 55
56want_pcre_impl="" 56PKG_CHECK_MODULES([PCRE],[libpcre],,[
57AC_ARG_WITH([pcre-bindings], 57 AC_MSG_ERROR([no libpcre found, go get it at http://www.pcre.org/])
58 AC_HELP_STRING([--with-pcre-bindings=(pcrepp|none|libpcrecpp)],[Specify which pcre c++ bindings to use. 'pcrepp' stands for quite sensible library, found at http://www.daemon.de/PCRE/, 'libcrecpp' makes use of crappy bindings by google and 'none' disables internal implementation of OP discovery]), 58])
59 [
60 case "$withval" in
61 pcrepp) want_pcre_impl="pcrepp" ;;
62 libpcrecpp) want_pcre_impl="libpcrecpp" ;;
63 none) want_pcre_impl="none";;
64 *) AC_MSG_ERROR([I'm not sure I understand what do you want for a pcre c++ bindings]) ;;
65 esac
66 ]
67)
68
69found_pcre_impl=""
70
71if test -z "$want_pcre_impl" -o "$want_pcre_impl" = "pcrepp" ; then
72 AC_WITH_PCRE([
73 AC_WITH_PCREPP([
74 found_pcre_impl=pcrepp
75 ])
76 ],[
77 AC_MSG_ERROR([no pcre library found. get one at http://www.pcre.org/])
78 ]
79 )
80 test "$want_pcre_impl,$found_pcre_impl" = "pcrepp," && AC_MSG_ERROR([no pcre++ library found. get one at http://www.daemon.de/PCRE])
81fi
82
83if test "$found_pcre_impl,$want_pcre_impl" = "," -o "$want_pcre_impl" = "libpcrecpp" ; then
84 test -z "$want_pcre_impl" || AC_MSG_NOTICE([You want to use crappy libpcre c++ bindings])
85 PKG_CHECK_MODULES([LIBPCRECPP],[libpcrecpp],[
86 found_pcre_impl=libpcrecpp
87 CXXFLAGS="$CXXFLAGS $LIBPCRECPP_CFLAGS"
88 LIBS="$LIBS $LIBPCRECPP_LIBS"
89 ],[
90 test -z "$want_pcre_impl" || AC_MSG_ERROR([no libpcre c++ bindings found. why would you want it if you don't have it installed?])
91 ]
92 )
93fi
94test "$want_pcre_impl,$found_pcre_impl" = "," && AC_MSG_ERROR([no pcre c++ bindings found, use --with-pcre-bindings=none to disable code that makes use of it])
95
96case "$found_pcre_impl" in
97 pcrepp) AC_DEFINE([USE_PCREPP],,[defined if pcre++ is to be used]) ;;
98 libpcrecpp) AC_DEFINE([USE_LIBPCRECPP],,[defined if crappy google bindings are to be used]) ;;
99esac
100 59
101curl_ssl_verify_host="true" 60curl_ssl_verify_host="true"
102AC_ARG_ENABLE([ssl-verify-host], 61AC_ARG_ENABLE([ssl-verify-host],