summaryrefslogtreecommitdiffabout
path: root/configure.ac
authorMichael Krelin <hacker@klever.net>2007-11-21 18:24:02 (UTC)
committer Michael Krelin <hacker@klever.net>2007-11-21 18:24:02 (UTC)
commita9b6c1f0b1a771dcd9afc76f05d1ad2ff0af937e (patch) (unidiff)
tree7e6a6f6b4b0e294d0522743d6dbb227322ce3490 /configure.ac
parentd9772d76607ad5b293e385df26cce4c87b8f6e54 (diff)
downloadlibopkele-a9b6c1f0b1a771dcd9afc76f05d1ad2ff0af937e.zip
libopkele-a9b6c1f0b1a771dcd9afc76f05d1ad2ff0af937e.tar.gz
libopkele-a9b6c1f0b1a771dcd9afc76f05d1ad2ff0af937e.tar.bz2
add a configure option for agressive error detection
Signed-off-by: Michael Krelin <hacker@klever.net>
Diffstat (limited to 'configure.ac') (more/less context) (ignore whitespace changes)
-rw-r--r--configure.ac18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 626b263..c5759b0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -99,6 +99,24 @@ $postels_law && AC_DEFINE([POSTELS_LAW],,[defined if we want to adhere to Postel
99 99
100AC_DEFINE_UNQUOTED([OPKELE_SRC_DIR],["$PWD"],[source directory]) 100AC_DEFINE_UNQUOTED([OPKELE_SRC_DIR],["$PWD"],[source directory])
101 101
102nitpick=false
103AC_ARG_ENABLE([nitpicking],
104 AC_HELP_STRING([--enable-nitpicking],[make compiler somewhat overly fastidious about the code it deals with]),
105 [ test "$enableval" = "no" || nitpick=true ]
106)
107if $nitpick ; then
108 CPP_NITPICK="-pedantic -Wall -Wextra -Wundef -Wshadow \
109 -Wunsafe-loop-optimizations -Wconversion -Wmissing-declarations \
110 -Wmissing-format-attribute -Wredundant-decls"
111 # -Wlogical-op -Wmissing-noreturn
112 C_NITPICK="$CPP_NITPICK"
113 CXX_NITPICK="$C_NITPICK"
114
115 CPPFLAGS="$CPPFLAGS $CPP_NITPICK"
116 CFLAGS="$CFLAGS $C_NITPICK"
117 CXXFLAGS="$CXXFLAGS $CXX_NITPICK"
118fi
119
102AC_CONFIG_FILES([ 120AC_CONFIG_FILES([
103 Makefile 121 Makefile
104 libopkele.pc 122 libopkele.pc