summaryrefslogtreecommitdiffabout
path: root/configure.ac
authorMichael Krelin <hacker@klever.net>2007-12-27 00:08:36 (UTC)
committer Michael Krelin <hacker@klever.net>2008-01-04 18:17:46 (UTC)
commited6883769a03b36402c2c78b1dcee0c7efeb70bc (patch) (unidiff)
treeec96f9c7feeb02d2822ec9872b937b54ab82fb8a /configure.ac
parente63de16a9885641b5070ec834225cb562bc2042f (diff)
downloadlibopkele-ed6883769a03b36402c2c78b1dcee0c7efeb70bc.zip
libopkele-ed6883769a03b36402c2c78b1dcee0c7efeb70bc.tar.gz
libopkele-ed6883769a03b36402c2c78b1dcee0c7efeb70bc.tar.bz2
changed auto_ptr to shared_ptr
Signed-off-by: Michael Krelin <hacker@klever.net>
Diffstat (limited to 'configure.ac') (more/less context) (ignore whitespace changes)
-rw-r--r--configure.ac32
1 files changed, 32 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1bd1873..c4e9a74 100644
--- a/configure.ac
+++ b/configure.ac
@@ -26,6 +26,37 @@ AC_MSG_RESULT([$PACKAGE_SRC_VERSION])
26AC_SUBST([PACKAGE_SRC_VERSION]) 26AC_SUBST([PACKAGE_SRC_VERSION])
27AC_DEFINE_UNQUOTED([PACKAGE_SRC_VERSION],["$PACKAGE_SRC_VERSION"],[more or less precise source tree version]) 27AC_DEFINE_UNQUOTED([PACKAGE_SRC_VERSION],["$PACKAGE_SRC_VERSION"],[more or less precise source tree version])
28 28
29tr1_mem_std="false"
30tr1_mem_boost="false"
31AC_CHECK_SHAREDPTR(std::tr1,tr1/memory,[ tr1_mem_std=true ])
32AC_CHECK_SHAREDPTR(boost,boost/shared_ptr.hpp,[ tr1_mem_boost=true ])
33tr1_mem=""
34AC_ARG_WITH([tr1-memory],
35 AC_HELP_STRING([--with-tr1-memory=<boost|std>],[select tr1/memory (shared_ptr<>) implementation to use]),
36 [ tr1_mem="$withval" ]
37)
38AC_MSG_CHECKING([for tr1/memory implementation to use])
39test -z "$tr1_mem" && $tr1_mem_std && tr1_mem=std
40test -z "$tr1_mem" && $tr1_mem_boost && tr1_mem=boost
41test -z "$tr1_mem" && AC_MSG_RESULT([none found]) || AC_MSG_RESULT([$tr1_mem])
42case "$tr1_mem" in
43 std)
44 $tr1_mem_std || AC_MSG_ERROR([std implementation requested, but not found])
45 OPKELE_TR1_MEM_NS=std::tr1
46 OPKELE_TR1_MEM_HEADER=tr1/memory
47 ;;
48 boost)
49 $tr1_mem_boost || AC_MSG_ERROR([boost implementation requested, but not found])
50 OPKELE_TR1_MEM_NS=boost
51 OPKELE_TR1_MEM_HEADER=boost/shared_ptr.hpp
52 ;;
53 *)
54 AC_MSG_ERROR([no shared_ptr<> implementation found])
55 ;;
56esac
57AC_SUBST([OPKELE_TR1_MEM_NS])
58AC_SUBST([OPKELE_TR1_MEM_HEADER])
59
29PKG_CHECK_MODULES([OPENSSL],[openssl],,[ 60PKG_CHECK_MODULES([OPENSSL],[openssl],,[
30 AC_MSG_ERROR([no openssl library found. get one from http://www.openssl.org/]) 61 AC_MSG_ERROR([no openssl library found. get one from http://www.openssl.org/])
31]) 62])
@@ -144,6 +175,7 @@ AC_CONFIG_FILES([
144 libopkele.pc 175 libopkele.pc
145 Doxyfile 176 Doxyfile
146 include/Makefile 177 include/Makefile
178 include/opkele/tr1-mem.h
147 lib/Makefile 179 lib/Makefile
148 test/Makefile 180 test/Makefile
149]) 181])