summaryrefslogtreecommitdiffabout
path: root/configure.ac
Unidiff
Diffstat (limited to 'configure.ac') (more/less context) (ignore whitespace changes)
-rw-r--r--configure.ac83
1 files changed, 83 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 48a5efb..c28141c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -28,2 +28,37 @@ AC_DEFINE_UNQUOTED([PACKAGE_SRC_VERSION],["$PACKAGE_SRC_VERSION"],[more or less
28 28
29tr1_mem_std="false"
30tr1_mem_boost="false"
31AC_CHECK_SHAREDPTR(std::tr1,tr1/memory,[ tr1_mem_std=true ])
32AC_CHECK_SHAREDPTR(boost,boost/shared_ptr.hpp,[ tr1_mem_boost=true ])
33tr1_mem=""
34AC_ARG_WITH([tr1-memory],
35 AC_HELP_STRING([--with-tr1-memory=<boost|std>],[select tr1/memory (shared_ptr<>) implementation to use]),
36 [ tr1_mem="$withval" ]
37)
38AC_MSG_CHECKING([for tr1/memory implementation to use])
39test -z "$tr1_mem" && $tr1_mem_std && tr1_mem=std
40test -z "$tr1_mem" && $tr1_mem_boost && tr1_mem=boost
41if test -z "$tr1_mem" ; then
42 AC_MSG_RESULT([none found])
43else
44 AC_MSG_RESULT([$tr1_mem])
45fi
46case "$tr1_mem" in
47 std)
48 $tr1_mem_std || AC_MSG_ERROR([std implementation requested, but not found])
49 OPKELE_TR1_MEM_NS=std::tr1
50 OPKELE_TR1_MEM_HEADER=tr1/memory
51 ;;
52 boost)
53 $tr1_mem_boost || AC_MSG_ERROR([boost implementation requested, but not found])
54 OPKELE_TR1_MEM_NS=boost
55 OPKELE_TR1_MEM_HEADER=boost/shared_ptr.hpp
56 ;;
57 *)
58 AC_MSG_ERROR([no shared_ptr<> implementation found])
59 ;;
60esac
61AC_SUBST([OPKELE_TR1_MEM_NS])
62AC_SUBST([OPKELE_TR1_MEM_HEADER])
63
29PKG_CHECK_MODULES([OPENSSL],[openssl],,[ 64PKG_CHECK_MODULES([OPENSSL],[openssl],,[
@@ -68,2 +103,28 @@ LIBCURL_CHECK_CONFIG(,,,[
68 103
104AC_CHECK_HEADER([expat.h],[
105 AC_CHECK_LIB([expat],[XML_ParserCreate],[
106 EXPAT_LIBS=-lexpat
107 EXPAT_CFLAGS=
108 AC_SUBST([EXPAT_LIBS])
109 AC_SUBST([EXPAT_CFLAGS])
110 ],[
111 AC_MSG_ERROR([no required expat library. get one from http://expat.sourceforge.net/])
112 ])
113],[
114 AC_MSG_ERROR([no required expat library. get one from http://expat.sourceforge.net/])
115])
116
117AC_CHECK_HEADER([tidy.h],[
118 AC_CHECK_LIB([tidy],[tidyParseBuffer],[
119 TIDY_LIBS=-ltidy
120 TIDY_CFLAGS=
121 AC_SUBST([TIDY_LIBS])
122 AC_SUBST([TIDY_CFLAGS])
123 ],[
124 AC_MSG_ERROR([no required htmltidy library found. get one from http://tidy.sourceforge.net/])
125 ])
126],[
127 AC_MSG_ERROR([no required htmltidy library found. get one from http://tidy.sourceforge.net/])
128])
129
69if test -n "$PCRE_LIBS" -a -n "$PCRE_CFLAGS" ; then 130if test -n "$PCRE_LIBS" -a -n "$PCRE_CFLAGS" ; then
@@ -119,2 +180,23 @@ fi
119 180
181ndebug=true
182AC_ARG_ENABLE([debug],
183 AC_HELP_STRING([--enable-debug],[enable debugging code]),
184 [ test "$enableval" = "no" || ndebug=false ]
185)
186if $ndebug ; then
187 CPPFLAGS_DEBUG="-DNDEBUG"
188else
189 CPPFLAGS_DEBUG=""
190fi
191AC_SUBST([CPPFLAGS_DEBUG])
192
193xri_proxy_url="http://beta.xri.net/"
194AC_MSG_CHECKING([for XRI resolver proxy])
195AC_ARG_ENABLE([xri-proxy],
196 AC_HELP_STRING([--with-xri-proxy=url],[set xri proxy for use when resolving xri identities, default is http://xr_proxy_url]),
197 [ xri_proxy_url="$withval" ]
198)
199AC_MSG_RESULT([$xri_proxy_url])
200AC_DEFINE_UNQUOTED([XRI_PROXY_URL],["$xri_proxy_url"],[XRI proxy resolver URL])
201
120AC_CONFIG_FILES([ 202AC_CONFIG_FILES([
@@ -124,2 +206,3 @@ AC_CONFIG_FILES([
124 include/Makefile 206 include/Makefile
207 include/opkele/tr1-mem.h
125 lib/Makefile 208 lib/Makefile