-rw-r--r-- | configure.ac | 3 |
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac index eb3f4d6..2094273 100644 --- a/configure.ac +++ b/configure.ac | |||
@@ -1,92 +1,95 @@ | |||
1 | AC_INIT([libopkele], [0.3], [libopkele-bugs@klever.net]) | 1 | AC_INIT([libopkele], [0.3], [libopkele-bugs@klever.net]) |
2 | AC_CONFIG_SRCDIR([include/opkele/opkele-config.h]) | 2 | AC_CONFIG_SRCDIR([include/opkele/opkele-config.h]) |
3 | AC_CONFIG_HEADERS([config.h include/opkele/acconfig.h]) | 3 | AC_CONFIG_HEADERS([config.h include/opkele/acconfig.h]) |
4 | AM_INIT_AUTOMAKE([dist-bzip2]) | 4 | AM_INIT_AUTOMAKE([dist-bzip2]) |
5 | 5 | ||
6 | AC_PROG_INSTALL | 6 | AC_PROG_INSTALL |
7 | AC_PROG_CXX | 7 | AC_PROG_CXX |
8 | AC_PROG_CC | 8 | AC_PROG_CC |
9 | AC_PROG_LIBTOOL | 9 | AC_PROG_LIBTOOL |
10 | 10 | ||
11 | AC_HEADER_STDC | 11 | AC_HEADER_STDC |
12 | 12 | ||
13 | AC_PATH_PROG([XSLTPROC],[xsltproc],[true]) | 13 | AC_PATH_PROG([XSLTPROC],[xsltproc],[true]) |
14 | AC_WITH_PKGCONFIG | 14 | AC_WITH_PKGCONFIG |
15 | 15 | ||
16 | PKG_CHECK_MODULES([OPENSSL],[openssl],,[ | 16 | PKG_CHECK_MODULES([OPENSSL],[openssl],,[ |
17 | AC_MSG_ERROR([no openssl library found. get one from http://www.openssl.org/]) | 17 | AC_MSG_ERROR([no openssl library found. get one from http://www.openssl.org/]) |
18 | ]) | 18 | ]) |
19 | 19 | ||
20 | WANT_KONFORKA="yes" | 20 | WANT_KONFORKA="yes" |
21 | AC_ARG_ENABLE([konforka], | 21 | AC_ARG_ENABLE([konforka], |
22 | AC_HELP_STRING([--disable-konforka],[do not use konforka library (default: use if found)]), | 22 | AC_HELP_STRING([--disable-konforka],[do not use konforka library (default: use if found)]), |
23 | [ | 23 | [ |
24 | test "${enableval}" = "no" && WANT_KONFORKA="no" | 24 | test "${enableval}" = "no" && WANT_KONFORKA="no" |
25 | ] | 25 | ] |
26 | ) | 26 | ) |
27 | if test "${WANT_KONFORKA}" = "yes" ; then | 27 | if test "${WANT_KONFORKA}" = "yes" ; then |
28 | PKG_CHECK_MODULES([KONFORKA],[konforka],[ | 28 | PKG_CHECK_MODULES([KONFORKA],[konforka],[ |
29 | AC_SUBST([KONFORKA_CFLAGS]) | 29 | AC_SUBST([KONFORKA_CFLAGS]) |
30 | AC_SUBST([KONFORKA_LIBS]) | 30 | AC_SUBST([KONFORKA_LIBS]) |
31 | AC_DEFINE([HAVE_KONFORKA],,[defined in presence of konforka library]) | 31 | AC_DEFINE([HAVE_KONFORKA],,[defined in presence of konforka library]) |
32 | AC_DEFINE([OPKELE_HAVE_KONFORKA],,[defined in presence of konforka library]) | 32 | AC_DEFINE([OPKELE_HAVE_KONFORKA],,[defined in presence of konforka library]) |
33 | AC_SUBST([KONFORKA_KONFORKA],[konforka]) | 33 | AC_SUBST([KONFORKA_KONFORKA],[konforka]) |
34 | ],[true]) | 34 | ],[true]) |
35 | fi | 35 | fi |
36 | 36 | ||
37 | WANT_DOXYGEN="yes" | 37 | WANT_DOXYGEN="yes" |
38 | AC_ARG_ENABLE([doxygen], | 38 | AC_ARG_ENABLE([doxygen], |
39 | AC_HELP_STRING([--disable-doxygen],[do not generate documentation]), | 39 | AC_HELP_STRING([--disable-doxygen],[do not generate documentation]), |
40 | [ | 40 | [ |
41 | test "${enableval}" = "no" && WANT_DOXYGEN="no" | 41 | test "${enableval}" = "no" && WANT_DOXYGEN="no" |
42 | ] | 42 | ] |
43 | ) | 43 | ) |
44 | if test "${WANT_DOXYGEN}" = "yes" ; then | 44 | if test "${WANT_DOXYGEN}" = "yes" ; then |
45 | AC_WITH_DOXYGEN | 45 | AC_WITH_DOXYGEN |
46 | AC_WITH_DOT | 46 | AC_WITH_DOT |
47 | else | 47 | else |
48 | AM_CONDITIONAL([HAVE_DOXYGEN],[false]) | 48 | AM_CONDITIONAL([HAVE_DOXYGEN],[false]) |
49 | AM_CONDITIONAL([HAVE_DOT],[false]) | 49 | AM_CONDITIONAL([HAVE_DOT],[false]) |
50 | fi | 50 | fi |
51 | 51 | ||
52 | LIBCURL_CHECK_CONFIG(,,,[ | 52 | LIBCURL_CHECK_CONFIG(,,,[ |
53 | AC_MSG_ERROR([no required libcurl library. get one from http://curl.haxx.se/]) | 53 | AC_MSG_ERROR([no required libcurl library. get one from http://curl.haxx.se/]) |
54 | ]) | 54 | ]) |
55 | AC_WITH_PCRE([ | 55 | AC_WITH_PCRE([ |
56 | AC_WITH_PCREPP(,[ | 56 | AC_WITH_PCREPP(,[ |
57 | AC_MSG_ERROR([no pcre++ library found. get one at http://www.daemon.de/PCRE]) | 57 | AC_MSG_ERROR([no pcre++ library found. get one at http://www.daemon.de/PCRE]) |
58 | ]) | 58 | ]) |
59 | ],[ | 59 | ],[ |
60 | AC_MSG_ERROR([no pcre library found. get one at http://www.pcre.org/]) | 60 | AC_MSG_ERROR([no pcre library found. get one at http://www.pcre.org/]) |
61 | ] | 61 | ] |
62 | ) | 62 | ) |
63 | 63 | ||
64 | curl_ssl_verify_host="true" | 64 | curl_ssl_verify_host="true" |
65 | AC_ARG_ENABLE([ssl-verify-host], | 65 | AC_ARG_ENABLE([ssl-verify-host], |
66 | AC_HELP_STRING([--disable-ssl-verify-host],[disable cURL cert/host relationships verification]), | 66 | AC_HELP_STRING([--disable-ssl-verify-host],[disable cURL cert/host relationships verification]), |
67 | [ test "${enableval}" = "no" && curl_ssl_verify_host="false" ] | 67 | [ test "${enableval}" = "no" && curl_ssl_verify_host="false" ] |
68 | ) | 68 | ) |
69 | ${curl_ssl_verify_host} || AC_DEFINE([DISABLE_CURL_SSL_VERIFYHOST],,[defined if cURL is not to verify cert/host]) | 69 | ${curl_ssl_verify_host} || AC_DEFINE([DISABLE_CURL_SSL_VERIFYHOST],,[defined if cURL is not to verify cert/host]) |
70 | 70 | ||
71 | curl_ssl_verify_peer="true" | 71 | curl_ssl_verify_peer="true" |
72 | AC_ARG_ENABLE([ssl-verify-peer], | 72 | AC_ARG_ENABLE([ssl-verify-peer], |
73 | AC_HELP_STRING([--disable-ssl-verify-peer],[disable cURL cert validity verification]), | 73 | AC_HELP_STRING([--disable-ssl-verify-peer],[disable cURL cert validity verification]), |
74 | [ test "${enableval}" = "no" && curl_ssl_verify_peer="false" ] | 74 | [ test "${enableval}" = "no" && curl_ssl_verify_peer="false" ] |
75 | ) | 75 | ) |
76 | ${curl_ssl_verify_peer} || AC_DEFINE([DISABLE_CURL_SSL_VERIFYPEER],,[defined if cURL is not to verify cert validity]) | 76 | ${curl_ssl_verify_peer} || AC_DEFINE([DISABLE_CURL_SSL_VERIFYPEER],,[defined if cURL is not to verify cert validity]) |
77 | 77 | ||
78 | postels_law=true | 78 | postels_law=true |
79 | AC_ARG_ENABLE([postels-law], | 79 | AC_ARG_ENABLE([postels-law], |
80 | AC_HELP_STRING([--disable-postels-law],[Be strict, do not adhere to Postel's Law ("be conservative in what you do, be liberal in what you accept from others", RFC 793)]), | 80 | AC_HELP_STRING([--disable-postels-law],[Be strict, do not adhere to Postel's Law ("be conservative in what you do, be liberal in what you accept from others", RFC 793)]), |
81 | [ test "${enableval}" = "no" && postels_law=false ] | 81 | [ test "${enableval}" = "no" && postels_law=false ] |
82 | ) | 82 | ) |
83 | $postels_law && AC_DEFINE([POSTELS_LAW],,[defined if we want to adhere to Postel's Law]) | 83 | $postels_law && AC_DEFINE([POSTELS_LAW],,[defined if we want to adhere to Postel's Law]) |
84 | 84 | ||
85 | AC_DEFINE_UNQUOTED([OPKELE_SRC_DIR],["$PWD"],[source directory]) | ||
86 | |||
85 | AC_CONFIG_FILES([ | 87 | AC_CONFIG_FILES([ |
86 | Makefile | 88 | Makefile |
87 | libopkele.pc | 89 | libopkele.pc |
88 | Doxyfile | 90 | Doxyfile |
89 | include/Makefile | 91 | include/Makefile |
90 | lib/Makefile | 92 | lib/Makefile |
93 | test/Makefile | ||
91 | ]) | 94 | ]) |
92 | AC_OUTPUT | 95 | AC_OUTPUT |