summaryrefslogtreecommitdiffabout
path: root/configure.ac
Unidiff
Diffstat (limited to 'configure.ac') (more/less context) (ignore whitespace changes)
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2b94b41..1bd1873 100644
--- a/configure.ac
+++ b/configure.ac
@@ -121,21 +121,30 @@ if $nitpick ; then
121 CPP_NITPICK="-pedantic -Wall -Wextra -Wundef -Wshadow \ 121 CPP_NITPICK="-pedantic -Wall -Wextra -Wundef -Wshadow \
122 -Wunsafe-loop-optimizations -Wconversion -Wmissing-format-attribute \ 122 -Wunsafe-loop-optimizations -Wconversion -Wmissing-format-attribute \
123 -Wredundant-decls -ansi" 123 -Wredundant-decls -ansi"
124 # -Wlogical-op -Wmissing-noreturn 124 # -Wlogical-op -Wmissing-noreturn
125 C_NITPICK="$CPP_NITPICK" 125 C_NITPICK="$CPP_NITPICK"
126 CXX_NITPICK="$C_NITPICK" 126 CXX_NITPICK="$C_NITPICK"
127 127
128 CPPFLAGS="$CPPFLAGS $CPP_NITPICK" 128 CPPFLAGS="$CPPFLAGS $CPP_NITPICK"
129 CFLAGS="$CFLAGS $C_NITPICK" 129 CFLAGS="$CFLAGS $C_NITPICK"
130 CXXFLAGS="$CXXFLAGS $CXX_NITPICK" 130 CXXFLAGS="$CXXFLAGS $CXX_NITPICK"
131fi 131fi
132 132
133xri_proxy_url="http://beta.xri.net/"
134AC_MSG_CHECKING([for XRI resolver proxy])
135AC_ARG_ENABLE([xri-proxy],
136 AC_HELP_STRING([--with-xri-proxy=url],[set xri proxy for use when resolving xri identities, default is http://xr_proxy_url]),
137 [ xri_proxy_url="$withval" ]
138)
139AC_MSG_RESULT([$xri_proxy_url])
140AC_DEFINE_UNQUOTED([XRI_PROXY_URL],["$xri_proxy_url"],[XRI proxy resolver URL])
141
133AC_CONFIG_FILES([ 142AC_CONFIG_FILES([
134 Makefile 143 Makefile
135 libopkele.pc 144 libopkele.pc
136 Doxyfile 145 Doxyfile
137 include/Makefile 146 include/Makefile
138 lib/Makefile 147 lib/Makefile
139 test/Makefile 148 test/Makefile
140]) 149])
141AC_OUTPUT 150AC_OUTPUT