summaryrefslogtreecommitdiffabout
path: root/configure.ac
Unidiff
Diffstat (limited to 'configure.ac') (more/less context) (ignore whitespace changes)
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3194718..3484146 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,140 +1,141 @@
1AC_INIT([libopkele], [2.0], [libopkele-bugs@klever.net]) 1AC_INIT([libopkele], [2.0], [libopkele-bugs@klever.net])
2AC_CONFIG_SRCDIR([include/opkele/opkele-config.h]) 2AC_CONFIG_SRCDIR([include/opkele/opkele-config.h])
3AC_CONFIG_HEADERS([config.h include/opkele/acconfig.h]) 3AC_CONFIG_HEADERS([config.h include/opkele/acconfig.h])
4AM_INIT_AUTOMAKE([dist-bzip2]) 4AM_INIT_AUTOMAKE([dist-bzip2])
5 5
6AC_PROG_INSTALL 6AC_PROG_INSTALL
7AC_PROG_CXX 7AC_PROG_CXX
8AC_PROG_CC 8AC_PROG_CC
9AC_PROG_LIBTOOL 9AC_PROG_LIBTOOL
10PKG_PROG_PKG_CONFIG 10PKG_PROG_PKG_CONFIG
11 11
12AC_HEADER_STDC 12AC_HEADER_STDC
13AC_CHECK_FUNCS([timegm])
13 14
14AC_PATH_PROG([XSLTPROC],[xsltproc],[true]) 15AC_PATH_PROG([XSLTPROC],[xsltproc],[true])
15 16
16AC_MSG_CHECKING([for source tree version]) 17AC_MSG_CHECKING([for source tree version])
17if headrev=$(cd $srcdir && git rev-parse --verify HEAD 2>/dev/null) ; then 18if headrev=$(cd $srcdir && git rev-parse --verify HEAD 2>/dev/null) ; then
18 PACKAGE_SRC_VERSION="$(cd $srcdir && git describe --tags $headrev)" 19 PACKAGE_SRC_VERSION="$(cd $srcdir && git describe --tags $headrev)"
19 test "$PACKAGE_SRC_VERSION" = "$PACKAGE_VERSION" \ 20 test "$PACKAGE_SRC_VERSION" = "$PACKAGE_VERSION" \
20 -o "${PACKAGE_SRC_VERSION#${PACKAGE_VERSION}-}" != "$PACKAGE_SRC_VERSION" || PACKAGE_SRC_VERSION="${PACKAGE_VERSION}:${PACKAGE_SRC_VERSION}" 21 -o "${PACKAGE_SRC_VERSION#${PACKAGE_VERSION}-}" != "$PACKAGE_SRC_VERSION" || PACKAGE_SRC_VERSION="${PACKAGE_VERSION}:${PACKAGE_SRC_VERSION}"
21 ( cd $srcdir && git diff-index $headrev | read dirt ) && PACKAGE_SRC_VERSION="${PACKAGE_SRC_VERSION}-dirty" 22 ( cd $srcdir && git diff-index $headrev | read dirt ) && PACKAGE_SRC_VERSION="${PACKAGE_SRC_VERSION}-dirty"
22else 23else
23 PACKAGE_SRC_VERSION="$PACKAGE_VERSION" 24 PACKAGE_SRC_VERSION="$PACKAGE_VERSION"
24fi 25fi
25AC_MSG_RESULT([$PACKAGE_SRC_VERSION]) 26AC_MSG_RESULT([$PACKAGE_SRC_VERSION])
26AC_SUBST([PACKAGE_SRC_VERSION]) 27AC_SUBST([PACKAGE_SRC_VERSION])
27AC_DEFINE_UNQUOTED([PACKAGE_SRC_VERSION],["$PACKAGE_SRC_VERSION"],[more or less precise source tree version]) 28AC_DEFINE_UNQUOTED([PACKAGE_SRC_VERSION],["$PACKAGE_SRC_VERSION"],[more or less precise source tree version])
28 29
29tr1_mem_std="false" 30tr1_mem_std="false"
30tr1_mem_boost="false" 31tr1_mem_boost="false"
31AC_CHECK_SHAREDPTR(std::tr1,tr1/memory,[ tr1_mem_std=true ]) 32AC_CHECK_SHAREDPTR(std::tr1,tr1/memory,[ tr1_mem_std=true ])
32AC_CHECK_SHAREDPTR(boost,boost/shared_ptr.hpp,[ tr1_mem_boost=true ]) 33AC_CHECK_SHAREDPTR(boost,boost/shared_ptr.hpp,[ tr1_mem_boost=true ])
33tr1_mem="" 34tr1_mem=""
34AC_ARG_WITH([tr1-memory], 35AC_ARG_WITH([tr1-memory],
35 AC_HELP_STRING([--with-tr1-memory=<boost|std>],[select tr1/memory (shared_ptr<>) implementation to use]), 36 AC_HELP_STRING([--with-tr1-memory=<boost|std>],[select tr1/memory (shared_ptr<>) implementation to use]),
36 [ tr1_mem="$withval" ] 37 [ tr1_mem="$withval" ]
37) 38)
38AC_MSG_CHECKING([for tr1/memory implementation to use]) 39AC_MSG_CHECKING([for tr1/memory implementation to use])
39test -z "$tr1_mem" && $tr1_mem_std && tr1_mem=std 40test -z "$tr1_mem" && $tr1_mem_std && tr1_mem=std
40test -z "$tr1_mem" && $tr1_mem_boost && tr1_mem=boost 41test -z "$tr1_mem" && $tr1_mem_boost && tr1_mem=boost
41if test -z "$tr1_mem" ; then 42if test -z "$tr1_mem" ; then
42 AC_MSG_RESULT([none found]) 43 AC_MSG_RESULT([none found])
43else 44else
44 AC_MSG_RESULT([$tr1_mem]) 45 AC_MSG_RESULT([$tr1_mem])
45fi 46fi
46case "$tr1_mem" in 47case "$tr1_mem" in
47 std) 48 std)
48 $tr1_mem_std || AC_MSG_ERROR([std implementation requested, but not found]) 49 $tr1_mem_std || AC_MSG_ERROR([std implementation requested, but not found])
49 OPKELE_TR1_MEM_NS=std::tr1 50 OPKELE_TR1_MEM_NS=std::tr1
50 OPKELE_TR1_MEM_HEADER=tr1/memory 51 OPKELE_TR1_MEM_HEADER=tr1/memory
51 ;; 52 ;;
52 boost) 53 boost)
53 $tr1_mem_boost || AC_MSG_ERROR([boost implementation requested, but not found]) 54 $tr1_mem_boost || AC_MSG_ERROR([boost implementation requested, but not found])
54 OPKELE_TR1_MEM_NS=boost 55 OPKELE_TR1_MEM_NS=boost
55 OPKELE_TR1_MEM_HEADER=boost/shared_ptr.hpp 56 OPKELE_TR1_MEM_HEADER=boost/shared_ptr.hpp
56 ;; 57 ;;
57 *) 58 *)
58 AC_MSG_ERROR([no shared_ptr<> implementation found]) 59 AC_MSG_ERROR([no shared_ptr<> implementation found])
59 ;; 60 ;;
60esac 61esac
61AC_SUBST([OPKELE_TR1_MEM_NS]) 62AC_SUBST([OPKELE_TR1_MEM_NS])
62AC_SUBST([OPKELE_TR1_MEM_HEADER]) 63AC_SUBST([OPKELE_TR1_MEM_HEADER])
63 64
64AC_MSG_CHECKING([for deprecated attribute support]) 65AC_MSG_CHECKING([for deprecated attribute support])
65AC_COMPILE_IFELSE([ 66AC_COMPILE_IFELSE([
66 int __attribute__((deprecated)) deprecated_function(); 67 int __attribute__((deprecated)) deprecated_function();
67 ],[ 68 ],[
68 AC_MSG_RESULT([yes]) 69 AC_MSG_RESULT([yes])
69 AC_DEFINE([OPKELE_DEPRECATE],[__attribute__((deprecated))],[deprecated function attribute]) 70 AC_DEFINE([OPKELE_DEPRECATE],[__attribute__((deprecated))],[deprecated function attribute])
70 ],[ 71 ],[
71 AC_MSG_RESULT([no]) 72 AC_MSG_RESULT([no])
72 AC_DEFINE([OPKELE_DEPRECATE],,[deprecated function attribute]) 73 AC_DEFINE([OPKELE_DEPRECATE],,[deprecated function attribute])
73 ] 74 ]
74) 75)
75 76
76AC_LANG_PUSH([C++]) 77AC_LANG_PUSH([C++])
77AC_MSG_CHECKING([for abi::__cxa_demangle]) 78AC_MSG_CHECKING([for abi::__cxa_demangle])
78AC_COMPILE_IFELSE([ 79AC_COMPILE_IFELSE([
79 #include <typeinfo> 80 #include <typeinfo>
80 using namespace std; 81 using namespace std;
81 #include <cxxabi.h> 82 #include <cxxabi.h>
82 int main(int c,char **v) { 83 int main(int c,char **v) {
83 int dstat; 84 int dstat;
84 char *demangled = abi::__cxa_demangle(typeid(dstat).name(),0,0,&dstat); 85 char *demangled = abi::__cxa_demangle(typeid(dstat).name(),0,0,&dstat);
85 return 0; 86 return 0;
86 } 87 }
87 ],[ 88 ],[
88 AC_MSG_RESULT([yes]) 89 AC_MSG_RESULT([yes])
89 AC_DEFINE([HAVE_DEMANGLE],,[defined if abi::__cxa_demangle is available]) 90 AC_DEFINE([HAVE_DEMANGLE],,[defined if abi::__cxa_demangle is available])
90 ],[ 91 ],[
91 AC_MSG_RESULT([no]) 92 AC_MSG_RESULT([no])
92 ] 93 ]
93) 94)
94AC_LANG_POP([C++]) 95AC_LANG_POP([C++])
95 96
96 97
97 98
98 99
99PKG_CHECK_MODULES([OPENSSL],[openssl],,[ 100PKG_CHECK_MODULES([OPENSSL],[openssl],,[
100 AC_MSG_ERROR([no openssl library found. get one from http://www.openssl.org/]) 101 AC_MSG_ERROR([no openssl library found. get one from http://www.openssl.org/])
101]) 102])
102 103
103WANT_KONFORKA="yes" 104WANT_KONFORKA="yes"
104AC_ARG_ENABLE([konforka], 105AC_ARG_ENABLE([konforka],
105 AC_HELP_STRING([--disable-konforka],[do not use konforka library (default: use if found)]), 106 AC_HELP_STRING([--disable-konforka],[do not use konforka library (default: use if found)]),
106 [ 107 [
107 test "${enableval}" = "no" && WANT_KONFORKA="no" 108 test "${enableval}" = "no" && WANT_KONFORKA="no"
108 ] 109 ]
109) 110)
110if test "${WANT_KONFORKA}" = "yes" ; then 111if test "${WANT_KONFORKA}" = "yes" ; then
111 PKG_CHECK_MODULES([KONFORKA],[konforka],[ 112 PKG_CHECK_MODULES([KONFORKA],[konforka],[
112 AC_SUBST([KONFORKA_CFLAGS]) 113 AC_SUBST([KONFORKA_CFLAGS])
113 AC_SUBST([KONFORKA_LIBS]) 114 AC_SUBST([KONFORKA_LIBS])
114 AC_DEFINE([HAVE_KONFORKA],,[defined in presence of konforka library]) 115 AC_DEFINE([HAVE_KONFORKA],,[defined in presence of konforka library])
115 AC_DEFINE([OPKELE_HAVE_KONFORKA],,[defined in presence of konforka library]) 116 AC_DEFINE([OPKELE_HAVE_KONFORKA],,[defined in presence of konforka library])
116 AC_SUBST([KONFORKA_KONFORKA],[konforka]) 117 AC_SUBST([KONFORKA_KONFORKA],[konforka])
117 ],[true]) 118 ],[true])
118fi 119fi
119 120
120WANT_DOXYGEN="yes" 121WANT_DOXYGEN="yes"
121AC_ARG_ENABLE([doxygen], 122AC_ARG_ENABLE([doxygen],
122 AC_HELP_STRING([--disable-doxygen],[do not generate documentation]), 123 AC_HELP_STRING([--disable-doxygen],[do not generate documentation]),
123 [ 124 [
124 test "${enableval}" = "no" && WANT_DOXYGEN="no" 125 test "${enableval}" = "no" && WANT_DOXYGEN="no"
125 ] 126 ]
126) 127)
127if test "${WANT_DOXYGEN}" = "yes" ; then 128if test "${WANT_DOXYGEN}" = "yes" ; then
128 AC_WITH_DOXYGEN 129 AC_WITH_DOXYGEN
129 AC_WITH_DOT 130 AC_WITH_DOT
130else 131else
131 AM_CONDITIONAL([HAVE_DOXYGEN],[false]) 132 AM_CONDITIONAL([HAVE_DOXYGEN],[false])
132 AM_CONDITIONAL([HAVE_DOT],[false]) 133 AM_CONDITIONAL([HAVE_DOT],[false])
133fi 134fi
134 135
135LIBCURL_CHECK_CONFIG(,,,[ 136LIBCURL_CHECK_CONFIG(,,,[
136 AC_MSG_ERROR([no required libcurl library. get one from http://curl.haxx.se/]) 137 AC_MSG_ERROR([no required libcurl library. get one from http://curl.haxx.se/])
137]) 138])
138 139
139AC_CHECK_HEADER([expat.h],[ 140AC_CHECK_HEADER([expat.h],[
140 AC_CHECK_LIB([expat],[XML_ParserCreate],[ 141 AC_CHECK_LIB([expat],[XML_ParserCreate],[