summaryrefslogtreecommitdiffabout
path: root/configure.ac
Unidiff
Diffstat (limited to 'configure.ac') (more/less context) (ignore whitespace changes)
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 3484146..a7b56ff 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,193 +1,193 @@
1AC_INIT([libopkele], [2.0], [libopkele-bugs@klever.net]) 1AC_INIT([libopkele], [2.0.1], [libopkele-bugs@klever.net])
2AC_CONFIG_SRCDIR([include/opkele/opkele-config.h]) 2AC_CONFIG_SRCDIR([include/opkele/opkele-config.h])
3AC_CONFIG_HEADERS([config.h include/opkele/acconfig.h]) 3AC_CONFIG_HEADERS([config.h include/opkele/acconfig.h])
4AM_INIT_AUTOMAKE([dist-bzip2]) 4AM_INIT_AUTOMAKE([dist-bzip2])
5 5
6AC_PROG_INSTALL 6AC_PROG_INSTALL
7AC_PROG_CXX 7AC_PROG_CXX
8AC_PROG_CC 8AC_PROG_CC
9AC_PROG_LIBTOOL 9AC_PROG_LIBTOOL
10PKG_PROG_PKG_CONFIG 10PKG_PROG_PKG_CONFIG
11 11
12AC_HEADER_STDC 12AC_HEADER_STDC
13AC_CHECK_FUNCS([timegm]) 13AC_CHECK_FUNCS([timegm])
14 14
15AC_PATH_PROG([XSLTPROC],[xsltproc],[true]) 15AC_PATH_PROG([XSLTPROC],[xsltproc],[true])
16 16
17AC_MSG_CHECKING([for source tree version]) 17AC_MSG_CHECKING([for source tree version])
18if headrev=$(cd $srcdir && git rev-parse --verify HEAD 2>/dev/null) ; then 18if headrev=$(cd $srcdir && git rev-parse --verify HEAD 2>/dev/null) ; then
19 PACKAGE_SRC_VERSION="$(cd $srcdir && git describe --tags $headrev)" 19 PACKAGE_SRC_VERSION="$(cd $srcdir && git describe --tags $headrev)"
20 test "$PACKAGE_SRC_VERSION" = "$PACKAGE_VERSION" \ 20 test "$PACKAGE_SRC_VERSION" = "$PACKAGE_VERSION" \
21 -o "${PACKAGE_SRC_VERSION#${PACKAGE_VERSION}-}" != "$PACKAGE_SRC_VERSION" || PACKAGE_SRC_VERSION="${PACKAGE_VERSION}:${PACKAGE_SRC_VERSION}" 21 -o "${PACKAGE_SRC_VERSION#${PACKAGE_VERSION}-}" != "$PACKAGE_SRC_VERSION" || PACKAGE_SRC_VERSION="${PACKAGE_VERSION}:${PACKAGE_SRC_VERSION}"
22 ( cd $srcdir && git diff-index $headrev | read dirt ) && PACKAGE_SRC_VERSION="${PACKAGE_SRC_VERSION}-dirty" 22 ( cd $srcdir && git diff-index $headrev | read dirt ) && PACKAGE_SRC_VERSION="${PACKAGE_SRC_VERSION}-dirty"
23else 23else
24 PACKAGE_SRC_VERSION="$PACKAGE_VERSION" 24 PACKAGE_SRC_VERSION="$PACKAGE_VERSION"
25fi 25fi
26AC_MSG_RESULT([$PACKAGE_SRC_VERSION]) 26AC_MSG_RESULT([$PACKAGE_SRC_VERSION])
27AC_SUBST([PACKAGE_SRC_VERSION]) 27AC_SUBST([PACKAGE_SRC_VERSION])
28AC_DEFINE_UNQUOTED([PACKAGE_SRC_VERSION],["$PACKAGE_SRC_VERSION"],[more or less precise source tree version]) 28AC_DEFINE_UNQUOTED([PACKAGE_SRC_VERSION],["$PACKAGE_SRC_VERSION"],[more or less precise source tree version])
29 29
30tr1_mem_std="false" 30tr1_mem_std="false"
31tr1_mem_boost="false" 31tr1_mem_boost="false"
32AC_CHECK_SHAREDPTR(std::tr1,tr1/memory,[ tr1_mem_std=true ]) 32AC_CHECK_SHAREDPTR(std::tr1,tr1/memory,[ tr1_mem_std=true ])
33AC_CHECK_SHAREDPTR(boost,boost/shared_ptr.hpp,[ tr1_mem_boost=true ]) 33AC_CHECK_SHAREDPTR(boost,boost/shared_ptr.hpp,[ tr1_mem_boost=true ])
34tr1_mem="" 34tr1_mem=""
35AC_ARG_WITH([tr1-memory], 35AC_ARG_WITH([tr1-memory],
36 AC_HELP_STRING([--with-tr1-memory=<boost|std>],[select tr1/memory (shared_ptr<>) implementation to use]), 36 AC_HELP_STRING([--with-tr1-memory=<boost|std>],[select tr1/memory (shared_ptr<>) implementation to use]),
37 [ tr1_mem="$withval" ] 37 [ tr1_mem="$withval" ]
38) 38)
39AC_MSG_CHECKING([for tr1/memory implementation to use]) 39AC_MSG_CHECKING([for tr1/memory implementation to use])
40test -z "$tr1_mem" && $tr1_mem_std && tr1_mem=std 40test -z "$tr1_mem" && $tr1_mem_std && tr1_mem=std
41test -z "$tr1_mem" && $tr1_mem_boost && tr1_mem=boost 41test -z "$tr1_mem" && $tr1_mem_boost && tr1_mem=boost
42if test -z "$tr1_mem" ; then 42if test -z "$tr1_mem" ; then
43 AC_MSG_RESULT([none found]) 43 AC_MSG_RESULT([none found])
44else 44else
45 AC_MSG_RESULT([$tr1_mem]) 45 AC_MSG_RESULT([$tr1_mem])
46fi 46fi
47case "$tr1_mem" in 47case "$tr1_mem" in
48 std) 48 std)
49 $tr1_mem_std || AC_MSG_ERROR([std implementation requested, but not found]) 49 $tr1_mem_std || AC_MSG_ERROR([std implementation requested, but not found])
50 OPKELE_TR1_MEM_NS=std::tr1 50 OPKELE_TR1_MEM_NS=std::tr1
51 OPKELE_TR1_MEM_HEADER=tr1/memory 51 OPKELE_TR1_MEM_HEADER=tr1/memory
52 ;; 52 ;;
53 boost) 53 boost)
54 $tr1_mem_boost || AC_MSG_ERROR([boost implementation requested, but not found]) 54 $tr1_mem_boost || AC_MSG_ERROR([boost implementation requested, but not found])
55 OPKELE_TR1_MEM_NS=boost 55 OPKELE_TR1_MEM_NS=boost
56 OPKELE_TR1_MEM_HEADER=boost/shared_ptr.hpp 56 OPKELE_TR1_MEM_HEADER=boost/shared_ptr.hpp
57 ;; 57 ;;
58 *) 58 *)
59 AC_MSG_ERROR([no shared_ptr<> implementation found]) 59 AC_MSG_ERROR([no shared_ptr<> implementation found])
60 ;; 60 ;;
61esac 61esac
62AC_SUBST([OPKELE_TR1_MEM_NS]) 62AC_SUBST([OPKELE_TR1_MEM_NS])
63AC_SUBST([OPKELE_TR1_MEM_HEADER]) 63AC_SUBST([OPKELE_TR1_MEM_HEADER])
64 64
65AC_MSG_CHECKING([for deprecated attribute support]) 65AC_MSG_CHECKING([for deprecated attribute support])
66AC_COMPILE_IFELSE([ 66AC_COMPILE_IFELSE([
67 int __attribute__((deprecated)) deprecated_function(); 67 int __attribute__((deprecated)) deprecated_function();
68 ],[ 68 ],[
69 AC_MSG_RESULT([yes]) 69 AC_MSG_RESULT([yes])
70 AC_DEFINE([OPKELE_DEPRECATE],[__attribute__((deprecated))],[deprecated function attribute]) 70 AC_DEFINE([OPKELE_DEPRECATE],[__attribute__((deprecated))],[deprecated function attribute])
71 ],[ 71 ],[
72 AC_MSG_RESULT([no]) 72 AC_MSG_RESULT([no])
73 AC_DEFINE([OPKELE_DEPRECATE],,[deprecated function attribute]) 73 AC_DEFINE([OPKELE_DEPRECATE],,[deprecated function attribute])
74 ] 74 ]
75) 75)
76 76
77AC_LANG_PUSH([C++]) 77AC_LANG_PUSH([C++])
78AC_MSG_CHECKING([for abi::__cxa_demangle]) 78AC_MSG_CHECKING([for abi::__cxa_demangle])
79AC_COMPILE_IFELSE([ 79AC_COMPILE_IFELSE([
80 #include <typeinfo> 80 #include <typeinfo>
81 using namespace std; 81 using namespace std;
82 #include <cxxabi.h> 82 #include <cxxabi.h>
83 int main(int c,char **v) { 83 int main(int c,char **v) {
84 int dstat; 84 int dstat;
85 char *demangled = abi::__cxa_demangle(typeid(dstat).name(),0,0,&dstat); 85 char *demangled = abi::__cxa_demangle(typeid(dstat).name(),0,0,&dstat);
86 return 0; 86 return 0;
87 } 87 }
88 ],[ 88 ],[
89 AC_MSG_RESULT([yes]) 89 AC_MSG_RESULT([yes])
90 AC_DEFINE([HAVE_DEMANGLE],,[defined if abi::__cxa_demangle is available]) 90 AC_DEFINE([HAVE_DEMANGLE],,[defined if abi::__cxa_demangle is available])
91 ],[ 91 ],[
92 AC_MSG_RESULT([no]) 92 AC_MSG_RESULT([no])
93 ] 93 ]
94) 94)
95AC_LANG_POP([C++]) 95AC_LANG_POP([C++])
96 96
97 97
98 98
99 99
100PKG_CHECK_MODULES([OPENSSL],[openssl],,[ 100PKG_CHECK_MODULES([OPENSSL],[openssl],,[
101 AC_MSG_ERROR([no openssl library found. get one from http://www.openssl.org/]) 101 AC_MSG_ERROR([no openssl library found. get one from http://www.openssl.org/])
102]) 102])
103 103
104WANT_KONFORKA="yes" 104WANT_KONFORKA="yes"
105AC_ARG_ENABLE([konforka], 105AC_ARG_ENABLE([konforka],
106 AC_HELP_STRING([--disable-konforka],[do not use konforka library (default: use if found)]), 106 AC_HELP_STRING([--disable-konforka],[do not use konforka library (default: use if found)]),
107 [ 107 [
108 test "${enableval}" = "no" && WANT_KONFORKA="no" 108 test "${enableval}" = "no" && WANT_KONFORKA="no"
109 ] 109 ]
110) 110)
111if test "${WANT_KONFORKA}" = "yes" ; then 111if test "${WANT_KONFORKA}" = "yes" ; then
112 PKG_CHECK_MODULES([KONFORKA],[konforka],[ 112 PKG_CHECK_MODULES([KONFORKA],[konforka],[
113 AC_SUBST([KONFORKA_CFLAGS]) 113 AC_SUBST([KONFORKA_CFLAGS])
114 AC_SUBST([KONFORKA_LIBS]) 114 AC_SUBST([KONFORKA_LIBS])
115 AC_DEFINE([HAVE_KONFORKA],,[defined in presence of konforka library]) 115 AC_DEFINE([HAVE_KONFORKA],,[defined in presence of konforka library])
116 AC_DEFINE([OPKELE_HAVE_KONFORKA],,[defined in presence of konforka library]) 116 AC_DEFINE([OPKELE_HAVE_KONFORKA],,[defined in presence of konforka library])
117 AC_SUBST([KONFORKA_KONFORKA],[konforka]) 117 AC_SUBST([KONFORKA_KONFORKA],[konforka])
118 ],[true]) 118 ],[true])
119fi 119fi
120 120
121WANT_DOXYGEN="yes" 121WANT_DOXYGEN="yes"
122AC_ARG_ENABLE([doxygen], 122AC_ARG_ENABLE([doxygen],
123 AC_HELP_STRING([--disable-doxygen],[do not generate documentation]), 123 AC_HELP_STRING([--disable-doxygen],[do not generate documentation]),
124 [ 124 [
125 test "${enableval}" = "no" && WANT_DOXYGEN="no" 125 test "${enableval}" = "no" && WANT_DOXYGEN="no"
126 ] 126 ]
127) 127)
128if test "${WANT_DOXYGEN}" = "yes" ; then 128if test "${WANT_DOXYGEN}" = "yes" ; then
129 AC_WITH_DOXYGEN 129 AC_WITH_DOXYGEN
130 AC_WITH_DOT 130 AC_WITH_DOT
131else 131else
132 AM_CONDITIONAL([HAVE_DOXYGEN],[false]) 132 AM_CONDITIONAL([HAVE_DOXYGEN],[false])
133 AM_CONDITIONAL([HAVE_DOT],[false]) 133 AM_CONDITIONAL([HAVE_DOT],[false])
134fi 134fi
135 135
136LIBCURL_CHECK_CONFIG(,,,[ 136LIBCURL_CHECK_CONFIG(,,,[
137 AC_MSG_ERROR([no required libcurl library. get one from http://curl.haxx.se/]) 137 AC_MSG_ERROR([no required libcurl library. get one from http://curl.haxx.se/])
138]) 138])
139 139
140AC_CHECK_HEADER([expat.h],[ 140AC_CHECK_HEADER([expat.h],[
141 AC_CHECK_LIB([expat],[XML_ParserCreate],[ 141 AC_CHECK_LIB([expat],[XML_ParserCreate],[
142 EXPAT_LIBS=-lexpat 142 EXPAT_LIBS=-lexpat
143 EXPAT_CFLAGS= 143 EXPAT_CFLAGS=
144 AC_SUBST([EXPAT_LIBS]) 144 AC_SUBST([EXPAT_LIBS])
145 AC_SUBST([EXPAT_CFLAGS]) 145 AC_SUBST([EXPAT_CFLAGS])
146 ],[ 146 ],[
147 AC_MSG_ERROR([no required expat library. get one from http://expat.sourceforge.net/]) 147 AC_MSG_ERROR([no required expat library. get one from http://expat.sourceforge.net/])
148 ]) 148 ])
149],[ 149],[
150 AC_MSG_ERROR([no required expat library. get one from http://expat.sourceforge.net/]) 150 AC_MSG_ERROR([no required expat library. get one from http://expat.sourceforge.net/])
151]) 151])
152 152
153AC_CHECK_HEADERS([tidy.h tidy/tidy.h],[ 153AC_CHECK_HEADERS([tidy.h tidy/tidy.h],[
154 AC_CHECK_LIB([tidy],[tidyParseBuffer],[ 154 AC_CHECK_LIB([tidy],[tidyParseBuffer],[
155 TIDY_LIBS=-ltidy 155 TIDY_LIBS=-ltidy
156 TIDY_CFLAGS= 156 TIDY_CFLAGS=
157 AC_SUBST([TIDY_LIBS]) 157 AC_SUBST([TIDY_LIBS])
158 AC_SUBST([TIDY_CFLAGS]) 158 AC_SUBST([TIDY_CFLAGS])
159 ],[ 159 ],[
160 AC_MSG_ERROR([no required htmltidy library found. get one from http://tidy.sourceforge.net/]) 160 AC_MSG_ERROR([no required htmltidy library found. get one from http://tidy.sourceforge.net/])
161 ]) 161 ])
162],[ 162],[
163 test "$ac_header" = "tidy/tidy.h" \ 163 test "$ac_header" = "tidy/tidy.h" \
164 && AC_MSG_ERROR([no required htmltidy library found. get one from http://tidy.sourceforge.net/]) 164 && AC_MSG_ERROR([no required htmltidy library found. get one from http://tidy.sourceforge.net/])
165]) 165])
166 166
167if test -n "$PCRE_LIBS" -a -n "$PCRE_CFLAGS" ; then 167if test -n "$PCRE_LIBS" -a -n "$PCRE_CFLAGS" ; then
168 AC_SUBST([PCRE_CFLAGS]) 168 AC_SUBST([PCRE_CFLAGS])
169 AC_SUBST([PCRE_LIBS]) 169 AC_SUBST([PCRE_LIBS])
170 : 170 :
171else 171else
172 PKG_CHECK_MODULES([PCRE],[libpcre],,[ 172 PKG_CHECK_MODULES([PCRE],[libpcre],,[
173 AC_MSG_ERROR([no libpcre found, go get it at http://www.pcre.org/]) 173 AC_MSG_ERROR([no libpcre found, go get it at http://www.pcre.org/])
174 ]) 174 ])
175fi 175fi
176 176
177PKG_CHECK_MODULES([SQLITE3],[sqlite3],[have_sqlite3=true],[have_sqlite3=false]) 177PKG_CHECK_MODULES([SQLITE3],[sqlite3],[have_sqlite3=true],[have_sqlite3=false])
178AM_CONDITIONAL([HAVE_SQLITE3],[$have_sqlite3]) 178AM_CONDITIONAL([HAVE_SQLITE3],[$have_sqlite3])
179PKG_CHECK_MODULES([KINGATE],[kingate-plaincgi],[have_kingate=true],[have_kingate=false]) 179PKG_CHECK_MODULES([KINGATE],[kingate-plaincgi],[have_kingate=true],[have_kingate=false])
180AM_CONDITIONAL([HAVE_KINGATE],[$have_kingate]) 180AM_CONDITIONAL([HAVE_KINGATE],[$have_kingate])
181PKG_CHECK_MODULES([UUID],[uuid],[have_uuid=true],[have_uuid=false]) 181PKG_CHECK_MODULES([UUID],[uuid],[have_uuid=true],[have_uuid=false])
182AM_CONDITIONAL([HAVE_UUID],[$have_uuid]) 182AM_CONDITIONAL([HAVE_UUID],[$have_uuid])
183if $have_uuid ; then 183if $have_uuid ; then
184 AC_DEFINE([HAVE_LIBUUID],,[defined in presence of libuuid]) 184 AC_DEFINE([HAVE_LIBUUID],,[defined in presence of libuuid])
185 AC_SUBST([UUID_UUID],[uuid]) 185 AC_SUBST([UUID_UUID],[uuid])
186fi 186fi
187 187
188curl_ssl_verify_host="true" 188curl_ssl_verify_host="true"
189AC_ARG_ENABLE([ssl-verify-host], 189AC_ARG_ENABLE([ssl-verify-host],
190 AC_HELP_STRING([--disable-ssl-verify-host],[disable cURL cert/host relationships verification]), 190 AC_HELP_STRING([--disable-ssl-verify-host],[disable cURL cert/host relationships verification]),
191 [ test "${enableval}" = "no" && curl_ssl_verify_host="false" ] 191 [ test "${enableval}" = "no" && curl_ssl_verify_host="false" ]
192) 192)
193${curl_ssl_verify_host} || AC_DEFINE([DISABLE_CURL_SSL_VERIFYHOST],,[defined if cURL is not to verify cert/host]) 193${curl_ssl_verify_host} || AC_DEFINE([DISABLE_CURL_SSL_VERIFYHOST],,[defined if cURL is not to verify cert/host])