-rw-r--r-- | configure.ac | 11 |
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac index 50dd8d4..23e40da 100644 --- a/configure.ac +++ b/configure.ac | |||
@@ -1,97 +1,108 @@ | |||
1 | AC_INIT([libopkele], [0.3], [libopkele-bugs@klever.net]) | 1 | AC_INIT([libopkele], [0.3], [libopkele-bugs@klever.net]) |
2 | AC_CONFIG_SRCDIR([include/opkele/opkele-config.h]) | 2 | AC_CONFIG_SRCDIR([include/opkele/opkele-config.h]) |
3 | AC_CONFIG_HEADERS([config.h include/opkele/acconfig.h]) | 3 | AC_CONFIG_HEADERS([config.h include/opkele/acconfig.h]) |
4 | AM_INIT_AUTOMAKE([dist-bzip2]) | 4 | AM_INIT_AUTOMAKE([dist-bzip2]) |
5 | 5 | ||
6 | AC_PROG_INSTALL | 6 | AC_PROG_INSTALL |
7 | AC_PROG_CXX | 7 | AC_PROG_CXX |
8 | AC_PROG_CC | 8 | AC_PROG_CC |
9 | AC_PROG_LIBTOOL | 9 | AC_PROG_LIBTOOL |
10 | PKG_PROG_PKG_CONFIG | 10 | PKG_PROG_PKG_CONFIG |
11 | 11 | ||
12 | AC_HEADER_STDC | 12 | AC_HEADER_STDC |
13 | 13 | ||
14 | AC_PATH_PROG([XSLTPROC],[xsltproc],[true]) | 14 | AC_PATH_PROG([XSLTPROC],[xsltproc],[true]) |
15 | 15 | ||
16 | AC_MSG_CHECKING([for source tree version]) | ||
17 | if headrev=$(cd $srcdir && git rev-parse --verify HEAD 2>/dev/null) ; then | ||
18 | PACKAGE_SRC_VERSION="${PACKAGE_VERSION}:$(cd $srcdir && git describe --tags $headrev)" | ||
19 | ( cd $srcdir && git diff-index $headrev | read dirt ) && PACKAGE_SRC_VERSION="${PACKAGE_SRC_VERSION}-dirty" | ||
20 | else | ||
21 | PACKAGE_SRC_VERSION="$PACKAGE_VERSION" | ||
22 | fi | ||
23 | AC_MSG_RESULT([$PACKAGE_SRC_VERSION]) | ||
24 | AC_SUBST([PACKAGE_SRC_VERSION]) | ||
25 | AC_DEFINE_UNQUOTED([PACKAGE_SRC_VERSION],["$PACKAGE_SRC_VERSION"],[more or less precise source tree version]) | ||
26 | |||
16 | PKG_CHECK_MODULES([OPENSSL],[openssl],,[ | 27 | PKG_CHECK_MODULES([OPENSSL],[openssl],,[ |
17 | AC_MSG_ERROR([no openssl library found. get one from http://www.openssl.org/]) | 28 | AC_MSG_ERROR([no openssl library found. get one from http://www.openssl.org/]) |
18 | ]) | 29 | ]) |
19 | 30 | ||
20 | WANT_KONFORKA="yes" | 31 | WANT_KONFORKA="yes" |
21 | AC_ARG_ENABLE([konforka], | 32 | AC_ARG_ENABLE([konforka], |
22 | AC_HELP_STRING([--disable-konforka],[do not use konforka library (default: use if found)]), | 33 | AC_HELP_STRING([--disable-konforka],[do not use konforka library (default: use if found)]), |
23 | [ | 34 | [ |
24 | test "${enableval}" = "no" && WANT_KONFORKA="no" | 35 | test "${enableval}" = "no" && WANT_KONFORKA="no" |
25 | ] | 36 | ] |
26 | ) | 37 | ) |
27 | if test "${WANT_KONFORKA}" = "yes" ; then | 38 | if test "${WANT_KONFORKA}" = "yes" ; then |
28 | PKG_CHECK_MODULES([KONFORKA],[konforka],[ | 39 | PKG_CHECK_MODULES([KONFORKA],[konforka],[ |
29 | AC_SUBST([KONFORKA_CFLAGS]) | 40 | AC_SUBST([KONFORKA_CFLAGS]) |
30 | AC_SUBST([KONFORKA_LIBS]) | 41 | AC_SUBST([KONFORKA_LIBS]) |
31 | AC_DEFINE([HAVE_KONFORKA],,[defined in presence of konforka library]) | 42 | AC_DEFINE([HAVE_KONFORKA],,[defined in presence of konforka library]) |
32 | AC_DEFINE([OPKELE_HAVE_KONFORKA],,[defined in presence of konforka library]) | 43 | AC_DEFINE([OPKELE_HAVE_KONFORKA],,[defined in presence of konforka library]) |
33 | AC_SUBST([KONFORKA_KONFORKA],[konforka]) | 44 | AC_SUBST([KONFORKA_KONFORKA],[konforka]) |
34 | ],[true]) | 45 | ],[true]) |
35 | fi | 46 | fi |
36 | 47 | ||
37 | WANT_DOXYGEN="yes" | 48 | WANT_DOXYGEN="yes" |
38 | AC_ARG_ENABLE([doxygen], | 49 | AC_ARG_ENABLE([doxygen], |
39 | AC_HELP_STRING([--disable-doxygen],[do not generate documentation]), | 50 | AC_HELP_STRING([--disable-doxygen],[do not generate documentation]), |
40 | [ | 51 | [ |
41 | test "${enableval}" = "no" && WANT_DOXYGEN="no" | 52 | test "${enableval}" = "no" && WANT_DOXYGEN="no" |
42 | ] | 53 | ] |
43 | ) | 54 | ) |
44 | if test "${WANT_DOXYGEN}" = "yes" ; then | 55 | if test "${WANT_DOXYGEN}" = "yes" ; then |
45 | AC_WITH_DOXYGEN | 56 | AC_WITH_DOXYGEN |
46 | AC_WITH_DOT | 57 | AC_WITH_DOT |
47 | else | 58 | else |
48 | AM_CONDITIONAL([HAVE_DOXYGEN],[false]) | 59 | AM_CONDITIONAL([HAVE_DOXYGEN],[false]) |
49 | AM_CONDITIONAL([HAVE_DOT],[false]) | 60 | AM_CONDITIONAL([HAVE_DOT],[false]) |
50 | fi | 61 | fi |
51 | 62 | ||
52 | LIBCURL_CHECK_CONFIG(,,,[ | 63 | LIBCURL_CHECK_CONFIG(,,,[ |
53 | AC_MSG_ERROR([no required libcurl library. get one from http://curl.haxx.se/]) | 64 | AC_MSG_ERROR([no required libcurl library. get one from http://curl.haxx.se/]) |
54 | ]) | 65 | ]) |
55 | 66 | ||
56 | if test -n "$PCRE_LIBS" -a -n "$PCRE_CFLAGS" ; then | 67 | if test -n "$PCRE_LIBS" -a -n "$PCRE_CFLAGS" ; then |
57 | AC_SUBST([PCRE_CFLAGS]) | 68 | AC_SUBST([PCRE_CFLAGS]) |
58 | AC_SUBST([PCRE_LIBS]) | 69 | AC_SUBST([PCRE_LIBS]) |
59 | : | 70 | : |
60 | else | 71 | else |
61 | PKG_CHECK_MODULES([PCRE],[libpcre],,[ | 72 | PKG_CHECK_MODULES([PCRE],[libpcre],,[ |
62 | AC_MSG_ERROR([no libpcre found, go get it at http://www.pcre.org/]) | 73 | AC_MSG_ERROR([no libpcre found, go get it at http://www.pcre.org/]) |
63 | ]) | 74 | ]) |
64 | fi | 75 | fi |
65 | 76 | ||
66 | curl_ssl_verify_host="true" | 77 | curl_ssl_verify_host="true" |
67 | AC_ARG_ENABLE([ssl-verify-host], | 78 | AC_ARG_ENABLE([ssl-verify-host], |
68 | AC_HELP_STRING([--disable-ssl-verify-host],[disable cURL cert/host relationships verification]), | 79 | AC_HELP_STRING([--disable-ssl-verify-host],[disable cURL cert/host relationships verification]), |
69 | [ test "${enableval}" = "no" && curl_ssl_verify_host="false" ] | 80 | [ test "${enableval}" = "no" && curl_ssl_verify_host="false" ] |
70 | ) | 81 | ) |
71 | ${curl_ssl_verify_host} || AC_DEFINE([DISABLE_CURL_SSL_VERIFYHOST],,[defined if cURL is not to verify cert/host]) | 82 | ${curl_ssl_verify_host} || AC_DEFINE([DISABLE_CURL_SSL_VERIFYHOST],,[defined if cURL is not to verify cert/host]) |
72 | 83 | ||
73 | curl_ssl_verify_peer="true" | 84 | curl_ssl_verify_peer="true" |
74 | AC_ARG_ENABLE([ssl-verify-peer], | 85 | AC_ARG_ENABLE([ssl-verify-peer], |
75 | AC_HELP_STRING([--disable-ssl-verify-peer],[disable cURL cert validity verification]), | 86 | AC_HELP_STRING([--disable-ssl-verify-peer],[disable cURL cert validity verification]), |
76 | [ test "${enableval}" = "no" && curl_ssl_verify_peer="false" ] | 87 | [ test "${enableval}" = "no" && curl_ssl_verify_peer="false" ] |
77 | ) | 88 | ) |
78 | ${curl_ssl_verify_peer} || AC_DEFINE([DISABLE_CURL_SSL_VERIFYPEER],,[defined if cURL is not to verify cert validity]) | 89 | ${curl_ssl_verify_peer} || AC_DEFINE([DISABLE_CURL_SSL_VERIFYPEER],,[defined if cURL is not to verify cert validity]) |
79 | 90 | ||
80 | postels_law=true | 91 | postels_law=true |
81 | AC_ARG_ENABLE([postels-law], | 92 | AC_ARG_ENABLE([postels-law], |
82 | AC_HELP_STRING([--disable-postels-law],[Be strict, do not adhere to Postel's Law ("be conservative in what you do, be liberal in what you accept from others", RFC 793)]), | 93 | AC_HELP_STRING([--disable-postels-law],[Be strict, do not adhere to Postel's Law ("be conservative in what you do, be liberal in what you accept from others", RFC 793)]), |
83 | [ test "${enableval}" = "no" && postels_law=false ] | 94 | [ test "${enableval}" = "no" && postels_law=false ] |
84 | ) | 95 | ) |
85 | $postels_law && AC_DEFINE([POSTELS_LAW],,[defined if we want to adhere to Postel's Law]) | 96 | $postels_law && AC_DEFINE([POSTELS_LAW],,[defined if we want to adhere to Postel's Law]) |
86 | 97 | ||
87 | AC_DEFINE_UNQUOTED([OPKELE_SRC_DIR],["$PWD"],[source directory]) | 98 | AC_DEFINE_UNQUOTED([OPKELE_SRC_DIR],["$PWD"],[source directory]) |
88 | 99 | ||
89 | AC_CONFIG_FILES([ | 100 | AC_CONFIG_FILES([ |
90 | Makefile | 101 | Makefile |
91 | libopkele.pc | 102 | libopkele.pc |
92 | Doxyfile | 103 | Doxyfile |
93 | include/Makefile | 104 | include/Makefile |
94 | lib/Makefile | 105 | lib/Makefile |
95 | test/Makefile | 106 | test/Makefile |
96 | ]) | 107 | ]) |
97 | AC_OUTPUT | 108 | AC_OUTPUT |