summaryrefslogtreecommitdiffabout
path: root/configure.ac
Side-by-side diff
Diffstat (limited to 'configure.ac') (more/less context) (show whitespace changes)
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 0aa1272..a66e53d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -150,5 +150,5 @@ AC_CHECK_HEADER([expat.h],[
])
-AC_CHECK_HEADER([tidy.h],[
+AC_CHECK_HEADERS([tidy.h tidy/tidy.h],[
AC_CHECK_LIB([tidy],[tidyParseBuffer],[
TIDY_LIBS=-ltidy
@@ -160,5 +160,6 @@ AC_CHECK_HEADER([tidy.h],[
])
],[
- AC_MSG_ERROR([no required htmltidy library found. get one from http://tidy.sourceforge.net/])
+ test "$ac_header" = "tidy/tidy.h" \
+ && AC_MSG_ERROR([no required htmltidy library found. get one from http://tidy.sourceforge.net/])
])