-rw-r--r-- | configure.ac | 3 |
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac index eb3f4d6..2094273 100644 --- a/configure.ac +++ b/configure.ac | |||
@@ -53,40 +53,43 @@ LIBCURL_CHECK_CONFIG(,,,[ | |||
53 | AC_MSG_ERROR([no required libcurl library. get one from http://curl.haxx.se/]) | 53 | AC_MSG_ERROR([no required libcurl library. get one from http://curl.haxx.se/]) |
54 | ]) | 54 | ]) |
55 | AC_WITH_PCRE([ | 55 | AC_WITH_PCRE([ |
56 | AC_WITH_PCREPP(,[ | 56 | AC_WITH_PCREPP(,[ |
57 | AC_MSG_ERROR([no pcre++ library found. get one at http://www.daemon.de/PCRE]) | 57 | AC_MSG_ERROR([no pcre++ library found. get one at http://www.daemon.de/PCRE]) |
58 | ]) | 58 | ]) |
59 | ],[ | 59 | ],[ |
60 | AC_MSG_ERROR([no pcre library found. get one at http://www.pcre.org/]) | 60 | AC_MSG_ERROR([no pcre library found. get one at http://www.pcre.org/]) |
61 | ] | 61 | ] |
62 | ) | 62 | ) |
63 | 63 | ||
64 | curl_ssl_verify_host="true" | 64 | curl_ssl_verify_host="true" |
65 | AC_ARG_ENABLE([ssl-verify-host], | 65 | AC_ARG_ENABLE([ssl-verify-host], |
66 | AC_HELP_STRING([--disable-ssl-verify-host],[disable cURL cert/host relationships verification]), | 66 | AC_HELP_STRING([--disable-ssl-verify-host],[disable cURL cert/host relationships verification]), |
67 | [ test "${enableval}" = "no" && curl_ssl_verify_host="false" ] | 67 | [ test "${enableval}" = "no" && curl_ssl_verify_host="false" ] |
68 | ) | 68 | ) |
69 | ${curl_ssl_verify_host} || AC_DEFINE([DISABLE_CURL_SSL_VERIFYHOST],,[defined if cURL is not to verify cert/host]) | 69 | ${curl_ssl_verify_host} || AC_DEFINE([DISABLE_CURL_SSL_VERIFYHOST],,[defined if cURL is not to verify cert/host]) |
70 | 70 | ||
71 | curl_ssl_verify_peer="true" | 71 | curl_ssl_verify_peer="true" |
72 | AC_ARG_ENABLE([ssl-verify-peer], | 72 | AC_ARG_ENABLE([ssl-verify-peer], |
73 | AC_HELP_STRING([--disable-ssl-verify-peer],[disable cURL cert validity verification]), | 73 | AC_HELP_STRING([--disable-ssl-verify-peer],[disable cURL cert validity verification]), |
74 | [ test "${enableval}" = "no" && curl_ssl_verify_peer="false" ] | 74 | [ test "${enableval}" = "no" && curl_ssl_verify_peer="false" ] |
75 | ) | 75 | ) |
76 | ${curl_ssl_verify_peer} || AC_DEFINE([DISABLE_CURL_SSL_VERIFYPEER],,[defined if cURL is not to verify cert validity]) | 76 | ${curl_ssl_verify_peer} || AC_DEFINE([DISABLE_CURL_SSL_VERIFYPEER],,[defined if cURL is not to verify cert validity]) |
77 | 77 | ||
78 | postels_law=true | 78 | postels_law=true |
79 | AC_ARG_ENABLE([postels-law], | 79 | AC_ARG_ENABLE([postels-law], |
80 | AC_HELP_STRING([--disable-postels-law],[Be strict, do not adhere to Postel's Law ("be conservative in what you do, be liberal in what you accept from others", RFC 793)]), | 80 | AC_HELP_STRING([--disable-postels-law],[Be strict, do not adhere to Postel's Law ("be conservative in what you do, be liberal in what you accept from others", RFC 793)]), |
81 | [ test "${enableval}" = "no" && postels_law=false ] | 81 | [ test "${enableval}" = "no" && postels_law=false ] |
82 | ) | 82 | ) |
83 | $postels_law && AC_DEFINE([POSTELS_LAW],,[defined if we want to adhere to Postel's Law]) | 83 | $postels_law && AC_DEFINE([POSTELS_LAW],,[defined if we want to adhere to Postel's Law]) |
84 | 84 | ||
85 | AC_DEFINE_UNQUOTED([OPKELE_SRC_DIR],["$PWD"],[source directory]) | ||
86 | |||
85 | AC_CONFIG_FILES([ | 87 | AC_CONFIG_FILES([ |
86 | Makefile | 88 | Makefile |
87 | libopkele.pc | 89 | libopkele.pc |
88 | Doxyfile | 90 | Doxyfile |
89 | include/Makefile | 91 | include/Makefile |
90 | lib/Makefile | 92 | lib/Makefile |
93 | test/Makefile | ||
91 | ]) | 94 | ]) |
92 | AC_OUTPUT | 95 | AC_OUTPUT |