summaryrefslogtreecommitdiffabout
path: root/configure.ac
Unidiff
Diffstat (limited to 'configure.ac') (more/less context) (show whitespace changes)
-rw-r--r--configure.ac10
1 files changed, 0 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 5fb6bec..7fa2f85 100644
--- a/configure.ac
+++ b/configure.ac
@@ -121,106 +121,96 @@ if test "${WANT_KONFORKA}" = "yes" ; then
121fi 121fi
122 122
123WANT_DOXYGEN="yes" 123WANT_DOXYGEN="yes"
124AC_ARG_ENABLE([doxygen], 124AC_ARG_ENABLE([doxygen],
125 AC_HELP_STRING([--disable-doxygen],[do not generate documentation]), 125 AC_HELP_STRING([--disable-doxygen],[do not generate documentation]),
126 [ 126 [
127 test "${enableval}" = "no" && WANT_DOXYGEN="no" 127 test "${enableval}" = "no" && WANT_DOXYGEN="no"
128 ] 128 ]
129) 129)
130if test "${WANT_DOXYGEN}" = "yes" ; then 130if test "${WANT_DOXYGEN}" = "yes" ; then
131 AC_WITH_DOXYGEN 131 AC_WITH_DOXYGEN
132 AC_WITH_DOT 132 AC_WITH_DOT
133else 133else
134 AM_CONDITIONAL([HAVE_DOXYGEN],[false]) 134 AM_CONDITIONAL([HAVE_DOXYGEN],[false])
135 AM_CONDITIONAL([HAVE_DOT],[false]) 135 AM_CONDITIONAL([HAVE_DOT],[false])
136fi 136fi
137 137
138LIBCURL_CHECK_CONFIG(,,,[ 138LIBCURL_CHECK_CONFIG(,,,[
139 AC_MSG_ERROR([no required libcurl library. get one from http://curl.haxx.se/]) 139 AC_MSG_ERROR([no required libcurl library. get one from http://curl.haxx.se/])
140]) 140])
141 141
142AC_CHECK_HEADER([expat.h],[ 142AC_CHECK_HEADER([expat.h],[
143 AC_CHECK_LIB([expat],[XML_ParserCreate],[ 143 AC_CHECK_LIB([expat],[XML_ParserCreate],[
144 EXPAT_LIBS=-lexpat 144 EXPAT_LIBS=-lexpat
145 EXPAT_CFLAGS= 145 EXPAT_CFLAGS=
146 AC_SUBST([EXPAT_LIBS]) 146 AC_SUBST([EXPAT_LIBS])
147 AC_SUBST([EXPAT_CFLAGS]) 147 AC_SUBST([EXPAT_CFLAGS])
148 ],[ 148 ],[
149 AC_MSG_ERROR([no required expat library. get one from http://expat.sourceforge.net/]) 149 AC_MSG_ERROR([no required expat library. get one from http://expat.sourceforge.net/])
150 ]) 150 ])
151],[ 151],[
152 AC_MSG_ERROR([no required expat library. get one from http://expat.sourceforge.net/]) 152 AC_MSG_ERROR([no required expat library. get one from http://expat.sourceforge.net/])
153]) 153])
154 154
155AC_CHECK_HEADERS([tidy.h tidy/tidy.h],[ 155AC_CHECK_HEADERS([tidy.h tidy/tidy.h],[
156 test -z "$TIDY_LIBS" && AC_CHECK_LIB([tidy],[tidyParseBuffer],[ 156 test -z "$TIDY_LIBS" && AC_CHECK_LIB([tidy],[tidyParseBuffer],[
157 TIDY_LIBS=-ltidy 157 TIDY_LIBS=-ltidy
158 TIDY_CFLAGS= 158 TIDY_CFLAGS=
159 AC_SUBST([TIDY_LIBS]) 159 AC_SUBST([TIDY_LIBS])
160 AC_SUBST([TIDY_CFLAGS]) 160 AC_SUBST([TIDY_CFLAGS])
161 ],[ 161 ],[
162 AC_MSG_ERROR([no required htmltidy library found. get one from http://tidy.sourceforge.net/]) 162 AC_MSG_ERROR([no required htmltidy library found. get one from http://tidy.sourceforge.net/])
163 ]) 163 ])
164],[ 164],[
165 test -z "$TIDY_LIBS" -a "$ac_header" = "tidy/tidy.h" \ 165 test -z "$TIDY_LIBS" -a "$ac_header" = "tidy/tidy.h" \
166 && AC_MSG_ERROR([no required htmltidy library found. get one from http://tidy.sourceforge.net/]) 166 && AC_MSG_ERROR([no required htmltidy library found. get one from http://tidy.sourceforge.net/])
167]) 167])
168 168
169if test -n "$PCRE_LIBS" -a -n "$PCRE_CFLAGS" ; then
170 AC_SUBST([PCRE_CFLAGS])
171 AC_SUBST([PCRE_LIBS])
172 :
173else
174 PKG_CHECK_MODULES([PCRE],[libpcre],,[
175 AC_MSG_ERROR([no libpcre found, go get it at http://www.pcre.org/])
176 ])
177fi
178
179PKG_CHECK_MODULES([SQLITE3],[sqlite3],[have_sqlite3=true],[have_sqlite3=false]) 169PKG_CHECK_MODULES([SQLITE3],[sqlite3],[have_sqlite3=true],[have_sqlite3=false])
180AM_CONDITIONAL([HAVE_SQLITE3],[$have_sqlite3]) 170AM_CONDITIONAL([HAVE_SQLITE3],[$have_sqlite3])
181PKG_CHECK_MODULES([KINGATE],[kingate-plaincgi],[have_kingate=true],[have_kingate=false]) 171PKG_CHECK_MODULES([KINGATE],[kingate-plaincgi],[have_kingate=true],[have_kingate=false])
182AM_CONDITIONAL([HAVE_KINGATE],[$have_kingate]) 172AM_CONDITIONAL([HAVE_KINGATE],[$have_kingate])
183PKG_CHECK_MODULES([UUID],[uuid],[have_uuid=true],[have_uuid=false]) 173PKG_CHECK_MODULES([UUID],[uuid],[have_uuid=true],[have_uuid=false])
184AM_CONDITIONAL([HAVE_UUID],[$have_uuid]) 174AM_CONDITIONAL([HAVE_UUID],[$have_uuid])
185if $have_uuid ; then 175if $have_uuid ; then
186 AC_DEFINE([HAVE_LIBUUID],,[defined in presence of libuuid]) 176 AC_DEFINE([HAVE_LIBUUID],,[defined in presence of libuuid])
187 AC_SUBST([UUID_UUID],[uuid]) 177 AC_SUBST([UUID_UUID],[uuid])
188fi 178fi
189 179
190curl_ssl_verify_host="true" 180curl_ssl_verify_host="true"
191AC_ARG_ENABLE([ssl-verify-host], 181AC_ARG_ENABLE([ssl-verify-host],
192 AC_HELP_STRING([--disable-ssl-verify-host],[disable cURL cert/host relationships verification]), 182 AC_HELP_STRING([--disable-ssl-verify-host],[disable cURL cert/host relationships verification]),
193 [ test "${enableval}" = "no" && curl_ssl_verify_host="false" ] 183 [ test "${enableval}" = "no" && curl_ssl_verify_host="false" ]
194) 184)
195${curl_ssl_verify_host} || AC_DEFINE([DISABLE_CURL_SSL_VERIFYHOST],,[defined if cURL is not to verify cert/host]) 185${curl_ssl_verify_host} || AC_DEFINE([DISABLE_CURL_SSL_VERIFYHOST],,[defined if cURL is not to verify cert/host])
196 186
197curl_ssl_verify_peer="true" 187curl_ssl_verify_peer="true"
198AC_ARG_ENABLE([ssl-verify-peer], 188AC_ARG_ENABLE([ssl-verify-peer],
199 AC_HELP_STRING([--disable-ssl-verify-peer],[disable cURL cert validity verification]), 189 AC_HELP_STRING([--disable-ssl-verify-peer],[disable cURL cert validity verification]),
200 [ test "${enableval}" = "no" && curl_ssl_verify_peer="false" ] 190 [ test "${enableval}" = "no" && curl_ssl_verify_peer="false" ]
201) 191)
202${curl_ssl_verify_peer} || AC_DEFINE([DISABLE_CURL_SSL_VERIFYPEER],,[defined if cURL is not to verify cert validity]) 192${curl_ssl_verify_peer} || AC_DEFINE([DISABLE_CURL_SSL_VERIFYPEER],,[defined if cURL is not to verify cert validity])
203 193
204postels_law=true 194postels_law=true
205AC_ARG_ENABLE([postels-law], 195AC_ARG_ENABLE([postels-law],
206 AC_HELP_STRING([--disable-postels-law],[Be strict, do not adhere to Postel's Law ("be conservative in what you do, be liberal in what you accept from others", RFC 793)]), 196 AC_HELP_STRING([--disable-postels-law],[Be strict, do not adhere to Postel's Law ("be conservative in what you do, be liberal in what you accept from others", RFC 793)]),
207 [ test "${enableval}" = "no" && postels_law=false ] 197 [ test "${enableval}" = "no" && postels_law=false ]
208) 198)
209$postels_law && AC_DEFINE([POSTELS_LAW],,[defined if we want to adhere to Postel's Law]) 199$postels_law && AC_DEFINE([POSTELS_LAW],,[defined if we want to adhere to Postel's Law])
210 200
211AC_DEFINE_UNQUOTED([OPKELE_SRC_DIR],["$PWD"],[source directory]) 201AC_DEFINE_UNQUOTED([OPKELE_SRC_DIR],["$PWD"],[source directory])
212 202
213nitpick=false 203nitpick=false
214AC_ARG_ENABLE([nitpicking], 204AC_ARG_ENABLE([nitpicking],
215 AC_HELP_STRING([--enable-nitpicking],[make compiler somewhat overly fastidious about the code it deals with]), 205 AC_HELP_STRING([--enable-nitpicking],[make compiler somewhat overly fastidious about the code it deals with]),
216 [ test "$enableval" = "no" || nitpick=true ] 206 [ test "$enableval" = "no" || nitpick=true ]
217) 207)
218if $nitpick ; then 208if $nitpick ; then
219 CPP_NITPICK="-pedantic -Wall -Wextra -Wundef -Wshadow \ 209 CPP_NITPICK="-pedantic -Wall -Wextra -Wundef -Wshadow \
220 -Wunsafe-loop-optimizations -Wconversion -Wmissing-format-attribute \ 210 -Wunsafe-loop-optimizations -Wconversion -Wmissing-format-attribute \
221 -Wredundant-decls -ansi" 211 -Wredundant-decls -ansi"
222 # -Wlogical-op -Wmissing-noreturn 212 # -Wlogical-op -Wmissing-noreturn
223 C_NITPICK="$CPP_NITPICK" 213 C_NITPICK="$CPP_NITPICK"
224 CXX_NITPICK="$C_NITPICK" 214 CXX_NITPICK="$C_NITPICK"
225 215
226 CPPFLAGS="$CPPFLAGS $CPP_NITPICK" 216 CPPFLAGS="$CPPFLAGS $CPP_NITPICK"