-rw-r--r-- | configure.ac | 47 |
1 files changed, 3 insertions, 44 deletions
diff --git a/configure.ac b/configure.ac index 00c6bc4..53e22ba 100644 --- a/configure.ac +++ b/configure.ac | |||
@@ -8,125 +8,84 @@ AC_PROG_CXX | |||
8 | AC_PROG_CC | 8 | AC_PROG_CC |
9 | AC_PROG_LIBTOOL | 9 | AC_PROG_LIBTOOL |
10 | 10 | ||
11 | AC_HEADER_STDC | 11 | AC_HEADER_STDC |
12 | 12 | ||
13 | AC_PATH_PROG([XSLTPROC],[xsltproc],[true]) | 13 | AC_PATH_PROG([XSLTPROC],[xsltproc],[true]) |
14 | AC_WITH_PKGCONFIG | 14 | AC_WITH_PKGCONFIG |
15 | 15 | ||
16 | PKG_CHECK_MODULES([OPENSSL],[openssl],,[ | 16 | PKG_CHECK_MODULES([OPENSSL],[openssl],,[ |
17 | AC_MSG_ERROR([no openssl library found. get one from http://www.openssl.org/]) | 17 | AC_MSG_ERROR([no openssl library found. get one from http://www.openssl.org/]) |
18 | ]) | 18 | ]) |
19 | 19 | ||
20 | WANT_KONFORKA="yes" | 20 | WANT_KONFORKA="yes" |
21 | AC_ARG_ENABLE([konforka], | 21 | AC_ARG_ENABLE([konforka], |
22 | AC_HELP_STRING([--disable-konforka],[do not use konforka library (default: use if found)]), | 22 | AC_HELP_STRING([--disable-konforka],[do not use konforka library (default: use if found)]), |
23 | [ | 23 | [ |
24 | test "${enableval}" = "no" && WANT_KONFORKA="no" | 24 | test "${enableval}" = "no" && WANT_KONFORKA="no" |
25 | ] | 25 | ] |
26 | ) | 26 | ) |
27 | if test "${WANT_KONFORKA}" = "yes" ; then | 27 | if test "${WANT_KONFORKA}" = "yes" ; then |
28 | PKG_CHECK_MODULES([KONFORKA],[konforka],[ | 28 | PKG_CHECK_MODULES([KONFORKA],[konforka],[ |
29 | AC_SUBST([KONFORKA_CFLAGS]) | 29 | AC_SUBST([KONFORKA_CFLAGS]) |
30 | AC_SUBST([KONFORKA_LIBS]) | 30 | AC_SUBST([KONFORKA_LIBS]) |
31 | AC_DEFINE([HAVE_KONFORKA],,[defined in presence of konforka library]) | 31 | AC_DEFINE([HAVE_KONFORKA],,[defined in presence of konforka library]) |
32 | AC_DEFINE([OPKELE_HAVE_KONFORKA],,[defined in presence of konforka library]) | 32 | AC_DEFINE([OPKELE_HAVE_KONFORKA],,[defined in presence of konforka library]) |
33 | AC_SUBST([KONFORKA_KONFORKA],[konforka]) | 33 | AC_SUBST([KONFORKA_KONFORKA],[konforka]) |
34 | ],[true]) | 34 | ],[true]) |
35 | fi | 35 | fi |
36 | 36 | ||
37 | WANT_DOXYGEN="yes" | 37 | WANT_DOXYGEN="yes" |
38 | AC_ARG_ENABLE([doxygen], | 38 | AC_ARG_ENABLE([doxygen], |
39 | AC_HELP_STRING([--disable-doxygen],[do not generate documentation]), | 39 | AC_HELP_STRING([--disable-doxygen],[do not generate documentation]), |
40 | [ | 40 | [ |
41 | test "${enableval}" = "no" && WANT_DOXYGEN="no" | 41 | test "${enableval}" = "no" && WANT_DOXYGEN="no" |
42 | ] | 42 | ] |
43 | ) | 43 | ) |
44 | if test "${WANT_DOXYGEN}" = "yes" ; then | 44 | if test "${WANT_DOXYGEN}" = "yes" ; then |
45 | AC_WITH_DOXYGEN | 45 | AC_WITH_DOXYGEN |
46 | AC_WITH_DOT | 46 | AC_WITH_DOT |
47 | else | 47 | else |
48 | AM_CONDITIONAL([HAVE_DOXYGEN],[false]) | 48 | AM_CONDITIONAL([HAVE_DOXYGEN],[false]) |
49 | AM_CONDITIONAL([HAVE_DOT],[false]) | 49 | AM_CONDITIONAL([HAVE_DOT],[false]) |
50 | fi | 50 | fi |
51 | 51 | ||
52 | LIBCURL_CHECK_CONFIG(,,,[ | 52 | LIBCURL_CHECK_CONFIG(,,,[ |
53 | AC_MSG_ERROR([no required libcurl library. get one from http://curl.haxx.se/]) | 53 | AC_MSG_ERROR([no required libcurl library. get one from http://curl.haxx.se/]) |
54 | ]) | 54 | ]) |
55 | 55 | ||
56 | want_pcre_impl="" | 56 | PKG_CHECK_MODULES([PCRE],[libpcre],,[ |
57 | AC_ARG_WITH([pcre-bindings], | 57 | AC_MSG_ERROR([no libpcre found, go get it at http://www.pcre.org/]) |
58 | AC_HELP_STRING([--with-pcre-bindings=(pcrepp|none|libpcrecpp)],[Specify which pcre c++ bindings to use. 'pcrepp' stands for quite sensible library, found at http://www.daemon.de/PCRE/, 'libcrecpp' makes use of crappy bindings by google and 'none' disables internal implementation of OP discovery]), | 58 | ]) |
59 | [ | ||
60 | case "$withval" in | ||
61 | pcrepp) want_pcre_impl="pcrepp" ;; | ||
62 | libpcrecpp) want_pcre_impl="libpcrecpp" ;; | ||
63 | none) want_pcre_impl="none";; | ||
64 | *) AC_MSG_ERROR([I'm not sure I understand what do you want for a pcre c++ bindings]) ;; | ||
65 | esac | ||
66 | ] | ||
67 | ) | ||
68 | |||
69 | found_pcre_impl="" | ||
70 | |||
71 | if test -z "$want_pcre_impl" -o "$want_pcre_impl" = "pcrepp" ; then | ||
72 | AC_WITH_PCRE([ | ||
73 | AC_WITH_PCREPP([ | ||
74 | found_pcre_impl=pcrepp | ||
75 | ]) | ||
76 | ],[ | ||
77 | AC_MSG_ERROR([no pcre library found. get one at http://www.pcre.org/]) | ||
78 | ] | ||
79 | ) | ||
80 | test "$want_pcre_impl,$found_pcre_impl" = "pcrepp," && AC_MSG_ERROR([no pcre++ library found. get one at http://www.daemon.de/PCRE]) | ||
81 | fi | ||
82 | |||
83 | if test "$found_pcre_impl,$want_pcre_impl" = "," -o "$want_pcre_impl" = "libpcrecpp" ; then | ||
84 | test -z "$want_pcre_impl" || AC_MSG_NOTICE([You want to use crappy libpcre c++ bindings]) | ||
85 | PKG_CHECK_MODULES([LIBPCRECPP],[libpcrecpp],[ | ||
86 | found_pcre_impl=libpcrecpp | ||
87 | CXXFLAGS="$CXXFLAGS $LIBPCRECPP_CFLAGS" | ||
88 | LIBS="$LIBS $LIBPCRECPP_LIBS" | ||
89 | ],[ | ||
90 | test -z "$want_pcre_impl" || AC_MSG_ERROR([no libpcre c++ bindings found. why would you want it if you don't have it installed?]) | ||
91 | ] | ||
92 | ) | ||
93 | fi | ||
94 | test "$want_pcre_impl,$found_pcre_impl" = "," && AC_MSG_ERROR([no pcre c++ bindings found, use --with-pcre-bindings=none to disable code that makes use of it]) | ||
95 | |||
96 | case "$found_pcre_impl" in | ||
97 | pcrepp) AC_DEFINE([USE_PCREPP],,[defined if pcre++ is to be used]) ;; | ||
98 | libpcrecpp) AC_DEFINE([USE_LIBPCRECPP],,[defined if crappy google bindings are to be used]) ;; | ||
99 | esac | ||
100 | 59 | ||
101 | curl_ssl_verify_host="true" | 60 | curl_ssl_verify_host="true" |
102 | AC_ARG_ENABLE([ssl-verify-host], | 61 | AC_ARG_ENABLE([ssl-verify-host], |
103 | AC_HELP_STRING([--disable-ssl-verify-host],[disable cURL cert/host relationships verification]), | 62 | AC_HELP_STRING([--disable-ssl-verify-host],[disable cURL cert/host relationships verification]), |
104 | [ test "${enableval}" = "no" && curl_ssl_verify_host="false" ] | 63 | [ test "${enableval}" = "no" && curl_ssl_verify_host="false" ] |
105 | ) | 64 | ) |
106 | ${curl_ssl_verify_host} || AC_DEFINE([DISABLE_CURL_SSL_VERIFYHOST],,[defined if cURL is not to verify cert/host]) | 65 | ${curl_ssl_verify_host} || AC_DEFINE([DISABLE_CURL_SSL_VERIFYHOST],,[defined if cURL is not to verify cert/host]) |
107 | 66 | ||
108 | curl_ssl_verify_peer="true" | 67 | curl_ssl_verify_peer="true" |
109 | AC_ARG_ENABLE([ssl-verify-peer], | 68 | AC_ARG_ENABLE([ssl-verify-peer], |
110 | AC_HELP_STRING([--disable-ssl-verify-peer],[disable cURL cert validity verification]), | 69 | AC_HELP_STRING([--disable-ssl-verify-peer],[disable cURL cert validity verification]), |
111 | [ test "${enableval}" = "no" && curl_ssl_verify_peer="false" ] | 70 | [ test "${enableval}" = "no" && curl_ssl_verify_peer="false" ] |
112 | ) | 71 | ) |
113 | ${curl_ssl_verify_peer} || AC_DEFINE([DISABLE_CURL_SSL_VERIFYPEER],,[defined if cURL is not to verify cert validity]) | 72 | ${curl_ssl_verify_peer} || AC_DEFINE([DISABLE_CURL_SSL_VERIFYPEER],,[defined if cURL is not to verify cert validity]) |
114 | 73 | ||
115 | postels_law=true | 74 | postels_law=true |
116 | AC_ARG_ENABLE([postels-law], | 75 | AC_ARG_ENABLE([postels-law], |
117 | AC_HELP_STRING([--disable-postels-law],[Be strict, do not adhere to Postel's Law ("be conservative in what you do, be liberal in what you accept from others", RFC 793)]), | 76 | AC_HELP_STRING([--disable-postels-law],[Be strict, do not adhere to Postel's Law ("be conservative in what you do, be liberal in what you accept from others", RFC 793)]), |
118 | [ test "${enableval}" = "no" && postels_law=false ] | 77 | [ test "${enableval}" = "no" && postels_law=false ] |
119 | ) | 78 | ) |
120 | $postels_law && AC_DEFINE([POSTELS_LAW],,[defined if we want to adhere to Postel's Law]) | 79 | $postels_law && AC_DEFINE([POSTELS_LAW],,[defined if we want to adhere to Postel's Law]) |
121 | 80 | ||
122 | AC_DEFINE_UNQUOTED([OPKELE_SRC_DIR],["$PWD"],[source directory]) | 81 | AC_DEFINE_UNQUOTED([OPKELE_SRC_DIR],["$PWD"],[source directory]) |
123 | 82 | ||
124 | AC_CONFIG_FILES([ | 83 | AC_CONFIG_FILES([ |
125 | Makefile | 84 | Makefile |
126 | libopkele.pc | 85 | libopkele.pc |
127 | Doxyfile | 86 | Doxyfile |
128 | include/Makefile | 87 | include/Makefile |
129 | lib/Makefile | 88 | lib/Makefile |
130 | test/Makefile | 89 | test/Makefile |
131 | ]) | 90 | ]) |
132 | AC_OUTPUT | 91 | AC_OUTPUT |