summaryrefslogtreecommitdiffabout
path: root/configure.ac
Unidiff
Diffstat (limited to 'configure.ac') (more/less context) (ignore whitespace changes)
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 3484146..a7b56ff 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,49 +1,49 @@
1AC_INIT([libopkele], [2.0], [libopkele-bugs@klever.net]) 1AC_INIT([libopkele], [2.0.1], [libopkele-bugs@klever.net])
2AC_CONFIG_SRCDIR([include/opkele/opkele-config.h]) 2AC_CONFIG_SRCDIR([include/opkele/opkele-config.h])
3AC_CONFIG_HEADERS([config.h include/opkele/acconfig.h]) 3AC_CONFIG_HEADERS([config.h include/opkele/acconfig.h])
4AM_INIT_AUTOMAKE([dist-bzip2]) 4AM_INIT_AUTOMAKE([dist-bzip2])
5 5
6AC_PROG_INSTALL 6AC_PROG_INSTALL
7AC_PROG_CXX 7AC_PROG_CXX
8AC_PROG_CC 8AC_PROG_CC
9AC_PROG_LIBTOOL 9AC_PROG_LIBTOOL
10PKG_PROG_PKG_CONFIG 10PKG_PROG_PKG_CONFIG
11 11
12AC_HEADER_STDC 12AC_HEADER_STDC
13AC_CHECK_FUNCS([timegm]) 13AC_CHECK_FUNCS([timegm])
14 14
15AC_PATH_PROG([XSLTPROC],[xsltproc],[true]) 15AC_PATH_PROG([XSLTPROC],[xsltproc],[true])
16 16
17AC_MSG_CHECKING([for source tree version]) 17AC_MSG_CHECKING([for source tree version])
18if headrev=$(cd $srcdir && git rev-parse --verify HEAD 2>/dev/null) ; then 18if headrev=$(cd $srcdir && git rev-parse --verify HEAD 2>/dev/null) ; then
19 PACKAGE_SRC_VERSION="$(cd $srcdir && git describe --tags $headrev)" 19 PACKAGE_SRC_VERSION="$(cd $srcdir && git describe --tags $headrev)"
20 test "$PACKAGE_SRC_VERSION" = "$PACKAGE_VERSION" \ 20 test "$PACKAGE_SRC_VERSION" = "$PACKAGE_VERSION" \
21 -o "${PACKAGE_SRC_VERSION#${PACKAGE_VERSION}-}" != "$PACKAGE_SRC_VERSION" || PACKAGE_SRC_VERSION="${PACKAGE_VERSION}:${PACKAGE_SRC_VERSION}" 21 -o "${PACKAGE_SRC_VERSION#${PACKAGE_VERSION}-}" != "$PACKAGE_SRC_VERSION" || PACKAGE_SRC_VERSION="${PACKAGE_VERSION}:${PACKAGE_SRC_VERSION}"
22 ( cd $srcdir && git diff-index $headrev | read dirt ) && PACKAGE_SRC_VERSION="${PACKAGE_SRC_VERSION}-dirty" 22 ( cd $srcdir && git diff-index $headrev | read dirt ) && PACKAGE_SRC_VERSION="${PACKAGE_SRC_VERSION}-dirty"
23else 23else
24 PACKAGE_SRC_VERSION="$PACKAGE_VERSION" 24 PACKAGE_SRC_VERSION="$PACKAGE_VERSION"
25fi 25fi
26AC_MSG_RESULT([$PACKAGE_SRC_VERSION]) 26AC_MSG_RESULT([$PACKAGE_SRC_VERSION])
27AC_SUBST([PACKAGE_SRC_VERSION]) 27AC_SUBST([PACKAGE_SRC_VERSION])
28AC_DEFINE_UNQUOTED([PACKAGE_SRC_VERSION],["$PACKAGE_SRC_VERSION"],[more or less precise source tree version]) 28AC_DEFINE_UNQUOTED([PACKAGE_SRC_VERSION],["$PACKAGE_SRC_VERSION"],[more or less precise source tree version])
29 29
30tr1_mem_std="false" 30tr1_mem_std="false"
31tr1_mem_boost="false" 31tr1_mem_boost="false"
32AC_CHECK_SHAREDPTR(std::tr1,tr1/memory,[ tr1_mem_std=true ]) 32AC_CHECK_SHAREDPTR(std::tr1,tr1/memory,[ tr1_mem_std=true ])
33AC_CHECK_SHAREDPTR(boost,boost/shared_ptr.hpp,[ tr1_mem_boost=true ]) 33AC_CHECK_SHAREDPTR(boost,boost/shared_ptr.hpp,[ tr1_mem_boost=true ])
34tr1_mem="" 34tr1_mem=""
35AC_ARG_WITH([tr1-memory], 35AC_ARG_WITH([tr1-memory],
36 AC_HELP_STRING([--with-tr1-memory=<boost|std>],[select tr1/memory (shared_ptr<>) implementation to use]), 36 AC_HELP_STRING([--with-tr1-memory=<boost|std>],[select tr1/memory (shared_ptr<>) implementation to use]),
37 [ tr1_mem="$withval" ] 37 [ tr1_mem="$withval" ]
38) 38)
39AC_MSG_CHECKING([for tr1/memory implementation to use]) 39AC_MSG_CHECKING([for tr1/memory implementation to use])
40test -z "$tr1_mem" && $tr1_mem_std && tr1_mem=std 40test -z "$tr1_mem" && $tr1_mem_std && tr1_mem=std
41test -z "$tr1_mem" && $tr1_mem_boost && tr1_mem=boost 41test -z "$tr1_mem" && $tr1_mem_boost && tr1_mem=boost
42if test -z "$tr1_mem" ; then 42if test -z "$tr1_mem" ; then
43 AC_MSG_RESULT([none found]) 43 AC_MSG_RESULT([none found])
44else 44else
45 AC_MSG_RESULT([$tr1_mem]) 45 AC_MSG_RESULT([$tr1_mem])
46fi 46fi
47case "$tr1_mem" in 47case "$tr1_mem" in
48 std) 48 std)
49 $tr1_mem_std || AC_MSG_ERROR([std implementation requested, but not found]) 49 $tr1_mem_std || AC_MSG_ERROR([std implementation requested, but not found])