summaryrefslogtreecommitdiffabout
path: root/configure.ac
Unidiff
Diffstat (limited to 'configure.ac') (more/less context) (ignore whitespace changes)
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a6de8c3..fd68b5b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,259 +1,260 @@
1AC_INIT([libopkele], [2.0.2], [libopkele-bugs@klever.net]) 1AC_INIT([libopkele], [2.0.2], [libopkele-bugs@klever.net])
2AC_CONFIG_SRCDIR([include/opkele/opkele-config.h]) 2AC_CONFIG_SRCDIR([include/opkele/opkele-config.h])
3AC_CONFIG_HEADERS([config.h include/opkele/acconfig.h]) 3AC_CONFIG_HEADERS([config.h include/opkele/acconfig.h])
4AC_CONFIG_MACRO_DIR([aclocal.d])
4AM_INIT_AUTOMAKE([dist-bzip2]) 5AM_INIT_AUTOMAKE([dist-bzip2])
5 6
6AC_PROG_INSTALL 7AC_PROG_INSTALL
7AC_PROG_CXX 8AC_PROG_CXX
8AC_PROG_CC 9AC_PROG_CC
9AC_PROG_LIBTOOL 10AC_PROG_LIBTOOL
10PKG_PROG_PKG_CONFIG 11PKG_PROG_PKG_CONFIG
11 12
12AC_HEADER_STDC 13AC_HEADER_STDC
13AC_CHECK_FUNCS([timegm]) 14AC_CHECK_FUNCS([timegm])
14 15
15AC_PATH_PROG([XSLTPROC],[xsltproc],[true]) 16AC_PATH_PROG([XSLTPROC],[xsltproc],[true])
16 17
17AC_MSG_CHECKING([for source tree version]) 18AC_MSG_CHECKING([for source tree version])
18if headrev=$(cd $srcdir && git rev-parse --verify HEAD 2>/dev/null) ; then 19if headrev=$(cd $srcdir && git rev-parse --verify HEAD 2>/dev/null) ; then
19 PACKAGE_SRC_VERSION="$(cd $srcdir && git describe --tags $headrev)" 20 PACKAGE_SRC_VERSION="$(cd $srcdir && git describe --tags $headrev)"
20 test "$PACKAGE_SRC_VERSION" = "$PACKAGE_VERSION" \ 21 test "$PACKAGE_SRC_VERSION" = "$PACKAGE_VERSION" \
21 -o "${PACKAGE_SRC_VERSION#${PACKAGE_VERSION}-}" != "$PACKAGE_SRC_VERSION" || PACKAGE_SRC_VERSION="${PACKAGE_VERSION}:${PACKAGE_SRC_VERSION}" 22 -o "${PACKAGE_SRC_VERSION#${PACKAGE_VERSION}-}" != "$PACKAGE_SRC_VERSION" || PACKAGE_SRC_VERSION="${PACKAGE_VERSION}:${PACKAGE_SRC_VERSION}"
22 ( cd $srcdir && git diff-index $headrev | read dirt ) && PACKAGE_SRC_VERSION="${PACKAGE_SRC_VERSION}-dirty" 23 ( cd $srcdir && git diff-index $headrev | read dirt ) && PACKAGE_SRC_VERSION="${PACKAGE_SRC_VERSION}-dirty"
23else 24else
24 PACKAGE_SRC_VERSION="$PACKAGE_VERSION" 25 PACKAGE_SRC_VERSION="$PACKAGE_VERSION"
25fi 26fi
26AC_MSG_RESULT([$PACKAGE_SRC_VERSION]) 27AC_MSG_RESULT([$PACKAGE_SRC_VERSION])
27AC_SUBST([PACKAGE_SRC_VERSION]) 28AC_SUBST([PACKAGE_SRC_VERSION])
28AC_DEFINE_UNQUOTED([PACKAGE_SRC_VERSION],["$PACKAGE_SRC_VERSION"],[more or less precise source tree version]) 29AC_DEFINE_UNQUOTED([PACKAGE_SRC_VERSION],["$PACKAGE_SRC_VERSION"],[more or less precise source tree version])
29 30
30tr1_mem_std="false" 31tr1_mem_std="false"
31tr1_mem_boost="false" 32tr1_mem_boost="false"
32AC_CHECK_SHAREDPTR(std::tr1,tr1/memory,[ tr1_mem_std=true ]) 33AC_CHECK_SHAREDPTR(std::tr1,tr1/memory,[ tr1_mem_std=true ])
33AC_CHECK_SHAREDPTR(boost,boost/shared_ptr.hpp,[ tr1_mem_boost=true ]) 34AC_CHECK_SHAREDPTR(boost,boost/shared_ptr.hpp,[ tr1_mem_boost=true ])
34tr1_mem="" 35tr1_mem=""
35AC_ARG_WITH([tr1-memory], 36AC_ARG_WITH([tr1-memory],
36 AC_HELP_STRING([--with-tr1-memory=<boost|std>],[select tr1/memory (shared_ptr<>) implementation to use]), 37 AC_HELP_STRING([--with-tr1-memory=<boost|std>],[select tr1/memory (shared_ptr<>) implementation to use]),
37 [ tr1_mem="$withval" ] 38 [ tr1_mem="$withval" ]
38) 39)
39AC_MSG_CHECKING([for tr1/memory implementation to use]) 40AC_MSG_CHECKING([for tr1/memory implementation to use])
40test -z "$tr1_mem" && $tr1_mem_std && tr1_mem=std 41test -z "$tr1_mem" && $tr1_mem_std && tr1_mem=std
41test -z "$tr1_mem" && $tr1_mem_boost && tr1_mem=boost 42test -z "$tr1_mem" && $tr1_mem_boost && tr1_mem=boost
42if test -z "$tr1_mem" ; then 43if test -z "$tr1_mem" ; then
43 AC_MSG_RESULT([none found]) 44 AC_MSG_RESULT([none found])
44else 45else
45 AC_MSG_RESULT([$tr1_mem]) 46 AC_MSG_RESULT([$tr1_mem])
46fi 47fi
47case "$tr1_mem" in 48case "$tr1_mem" in
48 std) 49 std)
49 $tr1_mem_std || AC_MSG_ERROR([std implementation requested, but not found]) 50 $tr1_mem_std || AC_MSG_ERROR([std implementation requested, but not found])
50 OPKELE_TR1_MEM_NS=std::tr1 51 OPKELE_TR1_MEM_NS=std::tr1
51 OPKELE_TR1_MEM_HEADER=tr1/memory 52 OPKELE_TR1_MEM_HEADER=tr1/memory
52 ;; 53 ;;
53 boost) 54 boost)
54 $tr1_mem_boost || AC_MSG_ERROR([boost implementation requested, but not found]) 55 $tr1_mem_boost || AC_MSG_ERROR([boost implementation requested, but not found])
55 OPKELE_TR1_MEM_NS=boost 56 OPKELE_TR1_MEM_NS=boost
56 OPKELE_TR1_MEM_HEADER=boost/shared_ptr.hpp 57 OPKELE_TR1_MEM_HEADER=boost/shared_ptr.hpp
57 ;; 58 ;;
58 *) 59 *)
59 AC_MSG_ERROR([no shared_ptr<> implementation found]) 60 AC_MSG_ERROR([no shared_ptr<> implementation found])
60 ;; 61 ;;
61esac 62esac
62AC_SUBST([OPKELE_TR1_MEM_NS]) 63AC_SUBST([OPKELE_TR1_MEM_NS])
63AC_SUBST([OPKELE_TR1_MEM_HEADER]) 64AC_SUBST([OPKELE_TR1_MEM_HEADER])
64 65
65AC_MSG_CHECKING([for deprecated attribute support]) 66AC_MSG_CHECKING([for deprecated attribute support])
66AC_COMPILE_IFELSE([ 67AC_COMPILE_IFELSE([
67 int __attribute__((deprecated)) deprecated_function(); 68 int __attribute__((deprecated)) deprecated_function();
68 ],[ 69 ],[
69 AC_MSG_RESULT([yes]) 70 AC_MSG_RESULT([yes])
70 AC_DEFINE([OPKELE_DEPRECATE],[__attribute__((deprecated))],[deprecated function attribute]) 71 AC_DEFINE([OPKELE_DEPRECATE],[__attribute__((deprecated))],[deprecated function attribute])
71 ],[ 72 ],[
72 AC_MSG_RESULT([no]) 73 AC_MSG_RESULT([no])
73 AC_DEFINE([OPKELE_DEPRECATE],,[deprecated function attribute]) 74 AC_DEFINE([OPKELE_DEPRECATE],,[deprecated function attribute])
74 ] 75 ]
75) 76)
76 77
77AC_LANG_PUSH([C++]) 78AC_LANG_PUSH([C++])
78AC_MSG_CHECKING([for abi::__cxa_demangle]) 79AC_MSG_CHECKING([for abi::__cxa_demangle])
79AC_COMPILE_IFELSE([ 80AC_COMPILE_IFELSE([
80 #include <typeinfo> 81 #include <typeinfo>
81 using namespace std; 82 using namespace std;
82 #include <cxxabi.h> 83 #include <cxxabi.h>
83 int main(int c,char **v) { 84 int main(int c,char **v) {
84 int dstat; 85 int dstat;
85 char *demangled = abi::__cxa_demangle(typeid(dstat).name(),0,0,&dstat); 86 char *demangled = abi::__cxa_demangle(typeid(dstat).name(),0,0,&dstat);
86 return 0; 87 return 0;
87 } 88 }
88 ],[ 89 ],[
89 AC_MSG_RESULT([yes]) 90 AC_MSG_RESULT([yes])
90 AC_DEFINE([HAVE_DEMANGLE],,[defined if abi::__cxa_demangle is available]) 91 AC_DEFINE([HAVE_DEMANGLE],,[defined if abi::__cxa_demangle is available])
91 ],[ 92 ],[
92 AC_MSG_RESULT([no]) 93 AC_MSG_RESULT([no])
93 ] 94 ]
94) 95)
95AC_LANG_POP([C++]) 96AC_LANG_POP([C++])
96 97
97 98
98 99
99 100
100PKG_CHECK_MODULES([OPENSSL],[openssl],,[ 101PKG_CHECK_MODULES([OPENSSL],[openssl],,[
101 AC_MSG_ERROR([no openssl library found. get one from http://www.openssl.org/]) 102 AC_MSG_ERROR([no openssl library found. get one from http://www.openssl.org/])
102]) 103])
103 104
104WANT_KONFORKA="yes" 105WANT_KONFORKA="yes"
105AC_ARG_ENABLE([konforka], 106AC_ARG_ENABLE([konforka],
106 AC_HELP_STRING([--disable-konforka],[do not use konforka library (default: use if found)]), 107 AC_HELP_STRING([--disable-konforka],[do not use konforka library (default: use if found)]),
107 [ 108 [
108 test "${enableval}" = "no" && WANT_KONFORKA="no" 109 test "${enableval}" = "no" && WANT_KONFORKA="no"
109 ] 110 ]
110) 111)
111if test "${WANT_KONFORKA}" = "yes" ; then 112if test "${WANT_KONFORKA}" = "yes" ; then
112 PKG_CHECK_MODULES([KONFORKA],[konforka],[ 113 PKG_CHECK_MODULES([KONFORKA],[konforka],[
113 AC_SUBST([KONFORKA_CFLAGS]) 114 AC_SUBST([KONFORKA_CFLAGS])
114 AC_SUBST([KONFORKA_LIBS]) 115 AC_SUBST([KONFORKA_LIBS])
115 AC_DEFINE([HAVE_KONFORKA],,[defined in presence of konforka library]) 116 AC_DEFINE([HAVE_KONFORKA],,[defined in presence of konforka library])
116 AC_DEFINE([OPKELE_HAVE_KONFORKA],,[defined in presence of konforka library]) 117 AC_DEFINE([OPKELE_HAVE_KONFORKA],,[defined in presence of konforka library])
117 AC_SUBST([KONFORKA_KONFORKA],[konforka]) 118 AC_SUBST([KONFORKA_KONFORKA],[konforka])
118 ],[true]) 119 ],[true])
119fi 120fi
120 121
121WANT_DOXYGEN="yes" 122WANT_DOXYGEN="yes"
122AC_ARG_ENABLE([doxygen], 123AC_ARG_ENABLE([doxygen],
123 AC_HELP_STRING([--disable-doxygen],[do not generate documentation]), 124 AC_HELP_STRING([--disable-doxygen],[do not generate documentation]),
124 [ 125 [
125 test "${enableval}" = "no" && WANT_DOXYGEN="no" 126 test "${enableval}" = "no" && WANT_DOXYGEN="no"
126 ] 127 ]
127) 128)
128if test "${WANT_DOXYGEN}" = "yes" ; then 129if test "${WANT_DOXYGEN}" = "yes" ; then
129 AC_WITH_DOXYGEN 130 AC_WITH_DOXYGEN
130 AC_WITH_DOT 131 AC_WITH_DOT
131else 132else
132 AM_CONDITIONAL([HAVE_DOXYGEN],[false]) 133 AM_CONDITIONAL([HAVE_DOXYGEN],[false])
133 AM_CONDITIONAL([HAVE_DOT],[false]) 134 AM_CONDITIONAL([HAVE_DOT],[false])
134fi 135fi
135 136
136LIBCURL_CHECK_CONFIG(,,,[ 137LIBCURL_CHECK_CONFIG(,,,[
137 AC_MSG_ERROR([no required libcurl library. get one from http://curl.haxx.se/]) 138 AC_MSG_ERROR([no required libcurl library. get one from http://curl.haxx.se/])
138]) 139])
139 140
140AC_CHECK_HEADER([expat.h],[ 141AC_CHECK_HEADER([expat.h],[
141 AC_CHECK_LIB([expat],[XML_ParserCreate],[ 142 AC_CHECK_LIB([expat],[XML_ParserCreate],[
142 EXPAT_LIBS=-lexpat 143 EXPAT_LIBS=-lexpat
143 EXPAT_CFLAGS= 144 EXPAT_CFLAGS=
144 AC_SUBST([EXPAT_LIBS]) 145 AC_SUBST([EXPAT_LIBS])
145 AC_SUBST([EXPAT_CFLAGS]) 146 AC_SUBST([EXPAT_CFLAGS])
146 ],[ 147 ],[
147 AC_MSG_ERROR([no required expat library. get one from http://expat.sourceforge.net/]) 148 AC_MSG_ERROR([no required expat library. get one from http://expat.sourceforge.net/])
148 ]) 149 ])
149],[ 150],[
150 AC_MSG_ERROR([no required expat library. get one from http://expat.sourceforge.net/]) 151 AC_MSG_ERROR([no required expat library. get one from http://expat.sourceforge.net/])
151]) 152])
152 153
153AC_CHECK_HEADERS([tidy.h tidy/tidy.h],[ 154AC_CHECK_HEADERS([tidy.h tidy/tidy.h],[
154 AC_CHECK_LIB([tidy],[tidyParseBuffer],[ 155 AC_CHECK_LIB([tidy],[tidyParseBuffer],[
155 TIDY_LIBS=-ltidy 156 TIDY_LIBS=-ltidy
156 TIDY_CFLAGS= 157 TIDY_CFLAGS=
157 AC_SUBST([TIDY_LIBS]) 158 AC_SUBST([TIDY_LIBS])
158 AC_SUBST([TIDY_CFLAGS]) 159 AC_SUBST([TIDY_CFLAGS])
159 ],[ 160 ],[
160 AC_MSG_ERROR([no required htmltidy library found. get one from http://tidy.sourceforge.net/]) 161 AC_MSG_ERROR([no required htmltidy library found. get one from http://tidy.sourceforge.net/])
161 ]) 162 ])
162],[ 163],[
163 test "$ac_header" = "tidy/tidy.h" \ 164 test "$ac_header" = "tidy/tidy.h" \
164 && AC_MSG_ERROR([no required htmltidy library found. get one from http://tidy.sourceforge.net/]) 165 && AC_MSG_ERROR([no required htmltidy library found. get one from http://tidy.sourceforge.net/])
165]) 166])
166 167
167if test -n "$PCRE_LIBS" -a -n "$PCRE_CFLAGS" ; then 168if test -n "$PCRE_LIBS" -a -n "$PCRE_CFLAGS" ; then
168 AC_SUBST([PCRE_CFLAGS]) 169 AC_SUBST([PCRE_CFLAGS])
169 AC_SUBST([PCRE_LIBS]) 170 AC_SUBST([PCRE_LIBS])
170 : 171 :
171else 172else
172 PKG_CHECK_MODULES([PCRE],[libpcre],,[ 173 PKG_CHECK_MODULES([PCRE],[libpcre],,[
173 AC_MSG_ERROR([no libpcre found, go get it at http://www.pcre.org/]) 174 AC_MSG_ERROR([no libpcre found, go get it at http://www.pcre.org/])
174 ]) 175 ])
175fi 176fi
176 177
177PKG_CHECK_MODULES([SQLITE3],[sqlite3],[have_sqlite3=true],[have_sqlite3=false]) 178PKG_CHECK_MODULES([SQLITE3],[sqlite3],[have_sqlite3=true],[have_sqlite3=false])
178AM_CONDITIONAL([HAVE_SQLITE3],[$have_sqlite3]) 179AM_CONDITIONAL([HAVE_SQLITE3],[$have_sqlite3])
179PKG_CHECK_MODULES([KINGATE],[kingate-plaincgi],[have_kingate=true],[have_kingate=false]) 180PKG_CHECK_MODULES([KINGATE],[kingate-plaincgi],[have_kingate=true],[have_kingate=false])
180AM_CONDITIONAL([HAVE_KINGATE],[$have_kingate]) 181AM_CONDITIONAL([HAVE_KINGATE],[$have_kingate])
181PKG_CHECK_MODULES([UUID],[uuid],[have_uuid=true],[have_uuid=false]) 182PKG_CHECK_MODULES([UUID],[uuid],[have_uuid=true],[have_uuid=false])
182AM_CONDITIONAL([HAVE_UUID],[$have_uuid]) 183AM_CONDITIONAL([HAVE_UUID],[$have_uuid])
183if $have_uuid ; then 184if $have_uuid ; then
184 AC_DEFINE([HAVE_LIBUUID],,[defined in presence of libuuid]) 185 AC_DEFINE([HAVE_LIBUUID],,[defined in presence of libuuid])
185 AC_SUBST([UUID_UUID],[uuid]) 186 AC_SUBST([UUID_UUID],[uuid])
186fi 187fi
187 188
188curl_ssl_verify_host="true" 189curl_ssl_verify_host="true"
189AC_ARG_ENABLE([ssl-verify-host], 190AC_ARG_ENABLE([ssl-verify-host],
190 AC_HELP_STRING([--disable-ssl-verify-host],[disable cURL cert/host relationships verification]), 191 AC_HELP_STRING([--disable-ssl-verify-host],[disable cURL cert/host relationships verification]),
191 [ test "${enableval}" = "no" && curl_ssl_verify_host="false" ] 192 [ test "${enableval}" = "no" && curl_ssl_verify_host="false" ]
192) 193)
193${curl_ssl_verify_host} || AC_DEFINE([DISABLE_CURL_SSL_VERIFYHOST],,[defined if cURL is not to verify cert/host]) 194${curl_ssl_verify_host} || AC_DEFINE([DISABLE_CURL_SSL_VERIFYHOST],,[defined if cURL is not to verify cert/host])
194 195
195curl_ssl_verify_peer="true" 196curl_ssl_verify_peer="true"
196AC_ARG_ENABLE([ssl-verify-peer], 197AC_ARG_ENABLE([ssl-verify-peer],
197 AC_HELP_STRING([--disable-ssl-verify-peer],[disable cURL cert validity verification]), 198 AC_HELP_STRING([--disable-ssl-verify-peer],[disable cURL cert validity verification]),
198 [ test "${enableval}" = "no" && curl_ssl_verify_peer="false" ] 199 [ test "${enableval}" = "no" && curl_ssl_verify_peer="false" ]
199) 200)
200${curl_ssl_verify_peer} || AC_DEFINE([DISABLE_CURL_SSL_VERIFYPEER],,[defined if cURL is not to verify cert validity]) 201${curl_ssl_verify_peer} || AC_DEFINE([DISABLE_CURL_SSL_VERIFYPEER],,[defined if cURL is not to verify cert validity])
201 202
202postels_law=true 203postels_law=true
203AC_ARG_ENABLE([postels-law], 204AC_ARG_ENABLE([postels-law],
204 AC_HELP_STRING([--disable-postels-law],[Be strict, do not adhere to Postel's Law ("be conservative in what you do, be liberal in what you accept from others", RFC 793)]), 205 AC_HELP_STRING([--disable-postels-law],[Be strict, do not adhere to Postel's Law ("be conservative in what you do, be liberal in what you accept from others", RFC 793)]),
205 [ test "${enableval}" = "no" && postels_law=false ] 206 [ test "${enableval}" = "no" && postels_law=false ]
206) 207)
207$postels_law && AC_DEFINE([POSTELS_LAW],,[defined if we want to adhere to Postel's Law]) 208$postels_law && AC_DEFINE([POSTELS_LAW],,[defined if we want to adhere to Postel's Law])
208 209
209AC_DEFINE_UNQUOTED([OPKELE_SRC_DIR],["$PWD"],[source directory]) 210AC_DEFINE_UNQUOTED([OPKELE_SRC_DIR],["$PWD"],[source directory])
210 211
211nitpick=false 212nitpick=false
212AC_ARG_ENABLE([nitpicking], 213AC_ARG_ENABLE([nitpicking],
213 AC_HELP_STRING([--enable-nitpicking],[make compiler somewhat overly fastidious about the code it deals with]), 214 AC_HELP_STRING([--enable-nitpicking],[make compiler somewhat overly fastidious about the code it deals with]),
214 [ test "$enableval" = "no" || nitpick=true ] 215 [ test "$enableval" = "no" || nitpick=true ]
215) 216)
216if $nitpick ; then 217if $nitpick ; then
217 CPP_NITPICK="-pedantic -Wall -Wextra -Wundef -Wshadow \ 218 CPP_NITPICK="-pedantic -Wall -Wextra -Wundef -Wshadow \
218 -Wunsafe-loop-optimizations -Wconversion -Wmissing-format-attribute \ 219 -Wunsafe-loop-optimizations -Wconversion -Wmissing-format-attribute \
219 -Wredundant-decls -ansi" 220 -Wredundant-decls -ansi"
220 # -Wlogical-op -Wmissing-noreturn 221 # -Wlogical-op -Wmissing-noreturn
221 C_NITPICK="$CPP_NITPICK" 222 C_NITPICK="$CPP_NITPICK"
222 CXX_NITPICK="$C_NITPICK" 223 CXX_NITPICK="$C_NITPICK"
223 224
224 CPPFLAGS="$CPPFLAGS $CPP_NITPICK" 225 CPPFLAGS="$CPPFLAGS $CPP_NITPICK"
225 CFLAGS="$CFLAGS $C_NITPICK" 226 CFLAGS="$CFLAGS $C_NITPICK"
226 CXXFLAGS="$CXXFLAGS $CXX_NITPICK" 227 CXXFLAGS="$CXXFLAGS $CXX_NITPICK"
227fi 228fi
228 229
229ndebug=true 230ndebug=true
230AC_ARG_ENABLE([debug], 231AC_ARG_ENABLE([debug],
231 AC_HELP_STRING([--enable-debug],[enable debugging code]), 232 AC_HELP_STRING([--enable-debug],[enable debugging code]),
232 [ test "$enableval" = "no" || ndebug=false ] 233 [ test "$enableval" = "no" || ndebug=false ]
233) 234)
234if $ndebug ; then 235if $ndebug ; then
235 CPPFLAGS_DEBUG="-DNDEBUG" 236 CPPFLAGS_DEBUG="-DNDEBUG"
236else 237else
237 CPPFLAGS_DEBUG="" 238 CPPFLAGS_DEBUG=""
238fi 239fi
239AC_SUBST([CPPFLAGS_DEBUG]) 240AC_SUBST([CPPFLAGS_DEBUG])
240 241
241xri_proxy_url="https://xri.net/" 242xri_proxy_url="https://xri.net/"
242AC_MSG_CHECKING([for XRI resolver proxy]) 243AC_MSG_CHECKING([for XRI resolver proxy])
243AC_ARG_ENABLE([xri-proxy], 244AC_ARG_ENABLE([xri-proxy],
244 AC_HELP_STRING([--with-xri-proxy=url],[set xri proxy for use when resolving xri identities, default is https://xri.net/]), 245 AC_HELP_STRING([--with-xri-proxy=url],[set xri proxy for use when resolving xri identities, default is https://xri.net/]),
245 [ xri_proxy_url="$withval" ] 246 [ xri_proxy_url="$withval" ]
246) 247)
247AC_MSG_RESULT([$xri_proxy_url]) 248AC_MSG_RESULT([$xri_proxy_url])
248AC_DEFINE_UNQUOTED([XRI_PROXY_URL],["$xri_proxy_url"],[XRI proxy resolver URL]) 249AC_DEFINE_UNQUOTED([XRI_PROXY_URL],["$xri_proxy_url"],[XRI proxy resolver URL])
249 250
250AC_CONFIG_FILES([ 251AC_CONFIG_FILES([
251 Makefile 252 Makefile
252 libopkele.pc 253 libopkele.pc
253 Doxyfile 254 Doxyfile
254 include/Makefile 255 include/Makefile
255 include/opkele/tr1-mem.h 256 include/opkele/tr1-mem.h
256 lib/Makefile 257 lib/Makefile
257 test/Makefile 258 test/Makefile
258]) 259])
259AC_OUTPUT 260AC_OUTPUT