summaryrefslogtreecommitdiffabout
path: root/configure.ac
Unidiff
Diffstat (limited to 'configure.ac') (more/less context) (ignore whitespace changes)
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index eb3f4d6..2094273 100644
--- a/configure.ac
+++ b/configure.ac
@@ -79,14 +79,17 @@ postels_law=true
79AC_ARG_ENABLE([postels-law], 79AC_ARG_ENABLE([postels-law],
80 AC_HELP_STRING([--disable-postels-law],[Be strict, do not adhere to Postel's Law ("be conservative in what you do, be liberal in what you accept from others", RFC 793)]), 80 AC_HELP_STRING([--disable-postels-law],[Be strict, do not adhere to Postel's Law ("be conservative in what you do, be liberal in what you accept from others", RFC 793)]),
81 [ test "${enableval}" = "no" && postels_law=false ] 81 [ test "${enableval}" = "no" && postels_law=false ]
82) 82)
83$postels_law && AC_DEFINE([POSTELS_LAW],,[defined if we want to adhere to Postel's Law]) 83$postels_law && AC_DEFINE([POSTELS_LAW],,[defined if we want to adhere to Postel's Law])
84 84
85AC_DEFINE_UNQUOTED([OPKELE_SRC_DIR],["$PWD"],[source directory])
86
85AC_CONFIG_FILES([ 87AC_CONFIG_FILES([
86 Makefile 88 Makefile
87 libopkele.pc 89 libopkele.pc
88 Doxyfile 90 Doxyfile
89 include/Makefile 91 include/Makefile
90 lib/Makefile 92 lib/Makefile
93 test/Makefile
91]) 94])
92AC_OUTPUT 95AC_OUTPUT