-rw-r--r-- | configure.ac | 1 |
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac index 3194718..3484146 100644 --- a/configure.ac +++ b/configure.ac | |||
@@ -1,76 +1,77 @@ | |||
1 | AC_INIT([libopkele], [2.0], [libopkele-bugs@klever.net]) | 1 | AC_INIT([libopkele], [2.0], [libopkele-bugs@klever.net]) |
2 | AC_CONFIG_SRCDIR([include/opkele/opkele-config.h]) | 2 | AC_CONFIG_SRCDIR([include/opkele/opkele-config.h]) |
3 | AC_CONFIG_HEADERS([config.h include/opkele/acconfig.h]) | 3 | AC_CONFIG_HEADERS([config.h include/opkele/acconfig.h]) |
4 | AM_INIT_AUTOMAKE([dist-bzip2]) | 4 | AM_INIT_AUTOMAKE([dist-bzip2]) |
5 | 5 | ||
6 | AC_PROG_INSTALL | 6 | AC_PROG_INSTALL |
7 | AC_PROG_CXX | 7 | AC_PROG_CXX |
8 | AC_PROG_CC | 8 | AC_PROG_CC |
9 | AC_PROG_LIBTOOL | 9 | AC_PROG_LIBTOOL |
10 | PKG_PROG_PKG_CONFIG | 10 | PKG_PROG_PKG_CONFIG |
11 | 11 | ||
12 | AC_HEADER_STDC | 12 | AC_HEADER_STDC |
13 | AC_CHECK_FUNCS([timegm]) | ||
13 | 14 | ||
14 | AC_PATH_PROG([XSLTPROC],[xsltproc],[true]) | 15 | AC_PATH_PROG([XSLTPROC],[xsltproc],[true]) |
15 | 16 | ||
16 | AC_MSG_CHECKING([for source tree version]) | 17 | AC_MSG_CHECKING([for source tree version]) |
17 | if headrev=$(cd $srcdir && git rev-parse --verify HEAD 2>/dev/null) ; then | 18 | if headrev=$(cd $srcdir && git rev-parse --verify HEAD 2>/dev/null) ; then |
18 | PACKAGE_SRC_VERSION="$(cd $srcdir && git describe --tags $headrev)" | 19 | PACKAGE_SRC_VERSION="$(cd $srcdir && git describe --tags $headrev)" |
19 | test "$PACKAGE_SRC_VERSION" = "$PACKAGE_VERSION" \ | 20 | test "$PACKAGE_SRC_VERSION" = "$PACKAGE_VERSION" \ |
20 | -o "${PACKAGE_SRC_VERSION#${PACKAGE_VERSION}-}" != "$PACKAGE_SRC_VERSION" || PACKAGE_SRC_VERSION="${PACKAGE_VERSION}:${PACKAGE_SRC_VERSION}" | 21 | -o "${PACKAGE_SRC_VERSION#${PACKAGE_VERSION}-}" != "$PACKAGE_SRC_VERSION" || PACKAGE_SRC_VERSION="${PACKAGE_VERSION}:${PACKAGE_SRC_VERSION}" |
21 | ( cd $srcdir && git diff-index $headrev | read dirt ) && PACKAGE_SRC_VERSION="${PACKAGE_SRC_VERSION}-dirty" | 22 | ( cd $srcdir && git diff-index $headrev | read dirt ) && PACKAGE_SRC_VERSION="${PACKAGE_SRC_VERSION}-dirty" |
22 | else | 23 | else |
23 | PACKAGE_SRC_VERSION="$PACKAGE_VERSION" | 24 | PACKAGE_SRC_VERSION="$PACKAGE_VERSION" |
24 | fi | 25 | fi |
25 | AC_MSG_RESULT([$PACKAGE_SRC_VERSION]) | 26 | AC_MSG_RESULT([$PACKAGE_SRC_VERSION]) |
26 | AC_SUBST([PACKAGE_SRC_VERSION]) | 27 | AC_SUBST([PACKAGE_SRC_VERSION]) |
27 | AC_DEFINE_UNQUOTED([PACKAGE_SRC_VERSION],["$PACKAGE_SRC_VERSION"],[more or less precise source tree version]) | 28 | AC_DEFINE_UNQUOTED([PACKAGE_SRC_VERSION],["$PACKAGE_SRC_VERSION"],[more or less precise source tree version]) |
28 | 29 | ||
29 | tr1_mem_std="false" | 30 | tr1_mem_std="false" |
30 | tr1_mem_boost="false" | 31 | tr1_mem_boost="false" |
31 | AC_CHECK_SHAREDPTR(std::tr1,tr1/memory,[ tr1_mem_std=true ]) | 32 | AC_CHECK_SHAREDPTR(std::tr1,tr1/memory,[ tr1_mem_std=true ]) |
32 | AC_CHECK_SHAREDPTR(boost,boost/shared_ptr.hpp,[ tr1_mem_boost=true ]) | 33 | AC_CHECK_SHAREDPTR(boost,boost/shared_ptr.hpp,[ tr1_mem_boost=true ]) |
33 | tr1_mem="" | 34 | tr1_mem="" |
34 | AC_ARG_WITH([tr1-memory], | 35 | AC_ARG_WITH([tr1-memory], |
35 | AC_HELP_STRING([--with-tr1-memory=<boost|std>],[select tr1/memory (shared_ptr<>) implementation to use]), | 36 | AC_HELP_STRING([--with-tr1-memory=<boost|std>],[select tr1/memory (shared_ptr<>) implementation to use]), |
36 | [ tr1_mem="$withval" ] | 37 | [ tr1_mem="$withval" ] |
37 | ) | 38 | ) |
38 | AC_MSG_CHECKING([for tr1/memory implementation to use]) | 39 | AC_MSG_CHECKING([for tr1/memory implementation to use]) |
39 | test -z "$tr1_mem" && $tr1_mem_std && tr1_mem=std | 40 | test -z "$tr1_mem" && $tr1_mem_std && tr1_mem=std |
40 | test -z "$tr1_mem" && $tr1_mem_boost && tr1_mem=boost | 41 | test -z "$tr1_mem" && $tr1_mem_boost && tr1_mem=boost |
41 | if test -z "$tr1_mem" ; then | 42 | if test -z "$tr1_mem" ; then |
42 | AC_MSG_RESULT([none found]) | 43 | AC_MSG_RESULT([none found]) |
43 | else | 44 | else |
44 | AC_MSG_RESULT([$tr1_mem]) | 45 | AC_MSG_RESULT([$tr1_mem]) |
45 | fi | 46 | fi |
46 | case "$tr1_mem" in | 47 | case "$tr1_mem" in |
47 | std) | 48 | std) |
48 | $tr1_mem_std || AC_MSG_ERROR([std implementation requested, but not found]) | 49 | $tr1_mem_std || AC_MSG_ERROR([std implementation requested, but not found]) |
49 | OPKELE_TR1_MEM_NS=std::tr1 | 50 | OPKELE_TR1_MEM_NS=std::tr1 |
50 | OPKELE_TR1_MEM_HEADER=tr1/memory | 51 | OPKELE_TR1_MEM_HEADER=tr1/memory |
51 | ;; | 52 | ;; |
52 | boost) | 53 | boost) |
53 | $tr1_mem_boost || AC_MSG_ERROR([boost implementation requested, but not found]) | 54 | $tr1_mem_boost || AC_MSG_ERROR([boost implementation requested, but not found]) |
54 | OPKELE_TR1_MEM_NS=boost | 55 | OPKELE_TR1_MEM_NS=boost |
55 | OPKELE_TR1_MEM_HEADER=boost/shared_ptr.hpp | 56 | OPKELE_TR1_MEM_HEADER=boost/shared_ptr.hpp |
56 | ;; | 57 | ;; |
57 | *) | 58 | *) |
58 | AC_MSG_ERROR([no shared_ptr<> implementation found]) | 59 | AC_MSG_ERROR([no shared_ptr<> implementation found]) |
59 | ;; | 60 | ;; |
60 | esac | 61 | esac |
61 | AC_SUBST([OPKELE_TR1_MEM_NS]) | 62 | AC_SUBST([OPKELE_TR1_MEM_NS]) |
62 | AC_SUBST([OPKELE_TR1_MEM_HEADER]) | 63 | AC_SUBST([OPKELE_TR1_MEM_HEADER]) |
63 | 64 | ||
64 | AC_MSG_CHECKING([for deprecated attribute support]) | 65 | AC_MSG_CHECKING([for deprecated attribute support]) |
65 | AC_COMPILE_IFELSE([ | 66 | AC_COMPILE_IFELSE([ |
66 | int __attribute__((deprecated)) deprecated_function(); | 67 | int __attribute__((deprecated)) deprecated_function(); |
67 | ],[ | 68 | ],[ |
68 | AC_MSG_RESULT([yes]) | 69 | AC_MSG_RESULT([yes]) |
69 | AC_DEFINE([OPKELE_DEPRECATE],[__attribute__((deprecated))],[deprecated function attribute]) | 70 | AC_DEFINE([OPKELE_DEPRECATE],[__attribute__((deprecated))],[deprecated function attribute]) |
70 | ],[ | 71 | ],[ |
71 | AC_MSG_RESULT([no]) | 72 | AC_MSG_RESULT([no]) |
72 | AC_DEFINE([OPKELE_DEPRECATE],,[deprecated function attribute]) | 73 | AC_DEFINE([OPKELE_DEPRECATE],,[deprecated function attribute]) |
73 | ] | 74 | ] |
74 | ) | 75 | ) |
75 | 76 | ||
76 | AC_LANG_PUSH([C++]) | 77 | AC_LANG_PUSH([C++]) |