-rw-r--r-- | configure.ac | 2 |
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac index 23e40da..71851da 100644 --- a/configure.ac +++ b/configure.ac | |||
@@ -1,97 +1,97 @@ | |||
1 | AC_INIT([libopkele], [0.3], [libopkele-bugs@klever.net]) | 1 | AC_INIT([libopkele], [0.3.1], [libopkele-bugs@klever.net]) |
2 | AC_CONFIG_SRCDIR([include/opkele/opkele-config.h]) | 2 | AC_CONFIG_SRCDIR([include/opkele/opkele-config.h]) |
3 | AC_CONFIG_HEADERS([config.h include/opkele/acconfig.h]) | 3 | AC_CONFIG_HEADERS([config.h include/opkele/acconfig.h]) |
4 | AM_INIT_AUTOMAKE([dist-bzip2]) | 4 | AM_INIT_AUTOMAKE([dist-bzip2]) |
5 | 5 | ||
6 | AC_PROG_INSTALL | 6 | AC_PROG_INSTALL |
7 | AC_PROG_CXX | 7 | AC_PROG_CXX |
8 | AC_PROG_CC | 8 | AC_PROG_CC |
9 | AC_PROG_LIBTOOL | 9 | AC_PROG_LIBTOOL |
10 | PKG_PROG_PKG_CONFIG | 10 | PKG_PROG_PKG_CONFIG |
11 | 11 | ||
12 | AC_HEADER_STDC | 12 | AC_HEADER_STDC |
13 | 13 | ||
14 | AC_PATH_PROG([XSLTPROC],[xsltproc],[true]) | 14 | AC_PATH_PROG([XSLTPROC],[xsltproc],[true]) |
15 | 15 | ||
16 | AC_MSG_CHECKING([for source tree version]) | 16 | AC_MSG_CHECKING([for source tree version]) |
17 | if headrev=$(cd $srcdir && git rev-parse --verify HEAD 2>/dev/null) ; then | 17 | if headrev=$(cd $srcdir && git rev-parse --verify HEAD 2>/dev/null) ; then |
18 | PACKAGE_SRC_VERSION="${PACKAGE_VERSION}:$(cd $srcdir && git describe --tags $headrev)" | 18 | PACKAGE_SRC_VERSION="${PACKAGE_VERSION}:$(cd $srcdir && git describe --tags $headrev)" |
19 | ( cd $srcdir && git diff-index $headrev | read dirt ) && PACKAGE_SRC_VERSION="${PACKAGE_SRC_VERSION}-dirty" | 19 | ( cd $srcdir && git diff-index $headrev | read dirt ) && PACKAGE_SRC_VERSION="${PACKAGE_SRC_VERSION}-dirty" |
20 | else | 20 | else |
21 | PACKAGE_SRC_VERSION="$PACKAGE_VERSION" | 21 | PACKAGE_SRC_VERSION="$PACKAGE_VERSION" |
22 | fi | 22 | fi |
23 | AC_MSG_RESULT([$PACKAGE_SRC_VERSION]) | 23 | AC_MSG_RESULT([$PACKAGE_SRC_VERSION]) |
24 | AC_SUBST([PACKAGE_SRC_VERSION]) | 24 | AC_SUBST([PACKAGE_SRC_VERSION]) |
25 | AC_DEFINE_UNQUOTED([PACKAGE_SRC_VERSION],["$PACKAGE_SRC_VERSION"],[more or less precise source tree version]) | 25 | AC_DEFINE_UNQUOTED([PACKAGE_SRC_VERSION],["$PACKAGE_SRC_VERSION"],[more or less precise source tree version]) |
26 | 26 | ||
27 | PKG_CHECK_MODULES([OPENSSL],[openssl],,[ | 27 | PKG_CHECK_MODULES([OPENSSL],[openssl],,[ |
28 | AC_MSG_ERROR([no openssl library found. get one from http://www.openssl.org/]) | 28 | AC_MSG_ERROR([no openssl library found. get one from http://www.openssl.org/]) |
29 | ]) | 29 | ]) |
30 | 30 | ||
31 | WANT_KONFORKA="yes" | 31 | WANT_KONFORKA="yes" |
32 | AC_ARG_ENABLE([konforka], | 32 | AC_ARG_ENABLE([konforka], |
33 | AC_HELP_STRING([--disable-konforka],[do not use konforka library (default: use if found)]), | 33 | AC_HELP_STRING([--disable-konforka],[do not use konforka library (default: use if found)]), |
34 | [ | 34 | [ |
35 | test "${enableval}" = "no" && WANT_KONFORKA="no" | 35 | test "${enableval}" = "no" && WANT_KONFORKA="no" |
36 | ] | 36 | ] |
37 | ) | 37 | ) |
38 | if test "${WANT_KONFORKA}" = "yes" ; then | 38 | if test "${WANT_KONFORKA}" = "yes" ; then |
39 | PKG_CHECK_MODULES([KONFORKA],[konforka],[ | 39 | PKG_CHECK_MODULES([KONFORKA],[konforka],[ |
40 | AC_SUBST([KONFORKA_CFLAGS]) | 40 | AC_SUBST([KONFORKA_CFLAGS]) |
41 | AC_SUBST([KONFORKA_LIBS]) | 41 | AC_SUBST([KONFORKA_LIBS]) |
42 | AC_DEFINE([HAVE_KONFORKA],,[defined in presence of konforka library]) | 42 | AC_DEFINE([HAVE_KONFORKA],,[defined in presence of konforka library]) |
43 | AC_DEFINE([OPKELE_HAVE_KONFORKA],,[defined in presence of konforka library]) | 43 | AC_DEFINE([OPKELE_HAVE_KONFORKA],,[defined in presence of konforka library]) |
44 | AC_SUBST([KONFORKA_KONFORKA],[konforka]) | 44 | AC_SUBST([KONFORKA_KONFORKA],[konforka]) |
45 | ],[true]) | 45 | ],[true]) |
46 | fi | 46 | fi |
47 | 47 | ||
48 | WANT_DOXYGEN="yes" | 48 | WANT_DOXYGEN="yes" |
49 | AC_ARG_ENABLE([doxygen], | 49 | AC_ARG_ENABLE([doxygen], |
50 | AC_HELP_STRING([--disable-doxygen],[do not generate documentation]), | 50 | AC_HELP_STRING([--disable-doxygen],[do not generate documentation]), |
51 | [ | 51 | [ |
52 | test "${enableval}" = "no" && WANT_DOXYGEN="no" | 52 | test "${enableval}" = "no" && WANT_DOXYGEN="no" |
53 | ] | 53 | ] |
54 | ) | 54 | ) |
55 | if test "${WANT_DOXYGEN}" = "yes" ; then | 55 | if test "${WANT_DOXYGEN}" = "yes" ; then |
56 | AC_WITH_DOXYGEN | 56 | AC_WITH_DOXYGEN |
57 | AC_WITH_DOT | 57 | AC_WITH_DOT |
58 | else | 58 | else |
59 | AM_CONDITIONAL([HAVE_DOXYGEN],[false]) | 59 | AM_CONDITIONAL([HAVE_DOXYGEN],[false]) |
60 | AM_CONDITIONAL([HAVE_DOT],[false]) | 60 | AM_CONDITIONAL([HAVE_DOT],[false]) |
61 | fi | 61 | fi |
62 | 62 | ||
63 | LIBCURL_CHECK_CONFIG(,,,[ | 63 | LIBCURL_CHECK_CONFIG(,,,[ |
64 | AC_MSG_ERROR([no required libcurl library. get one from http://curl.haxx.se/]) | 64 | AC_MSG_ERROR([no required libcurl library. get one from http://curl.haxx.se/]) |
65 | ]) | 65 | ]) |
66 | 66 | ||
67 | if test -n "$PCRE_LIBS" -a -n "$PCRE_CFLAGS" ; then | 67 | if test -n "$PCRE_LIBS" -a -n "$PCRE_CFLAGS" ; then |
68 | AC_SUBST([PCRE_CFLAGS]) | 68 | AC_SUBST([PCRE_CFLAGS]) |
69 | AC_SUBST([PCRE_LIBS]) | 69 | AC_SUBST([PCRE_LIBS]) |
70 | : | 70 | : |
71 | else | 71 | else |
72 | PKG_CHECK_MODULES([PCRE],[libpcre],,[ | 72 | PKG_CHECK_MODULES([PCRE],[libpcre],,[ |
73 | AC_MSG_ERROR([no libpcre found, go get it at http://www.pcre.org/]) | 73 | AC_MSG_ERROR([no libpcre found, go get it at http://www.pcre.org/]) |
74 | ]) | 74 | ]) |
75 | fi | 75 | fi |
76 | 76 | ||
77 | curl_ssl_verify_host="true" | 77 | curl_ssl_verify_host="true" |
78 | AC_ARG_ENABLE([ssl-verify-host], | 78 | AC_ARG_ENABLE([ssl-verify-host], |
79 | AC_HELP_STRING([--disable-ssl-verify-host],[disable cURL cert/host relationships verification]), | 79 | AC_HELP_STRING([--disable-ssl-verify-host],[disable cURL cert/host relationships verification]), |
80 | [ test "${enableval}" = "no" && curl_ssl_verify_host="false" ] | 80 | [ test "${enableval}" = "no" && curl_ssl_verify_host="false" ] |
81 | ) | 81 | ) |
82 | ${curl_ssl_verify_host} || AC_DEFINE([DISABLE_CURL_SSL_VERIFYHOST],,[defined if cURL is not to verify cert/host]) | 82 | ${curl_ssl_verify_host} || AC_DEFINE([DISABLE_CURL_SSL_VERIFYHOST],,[defined if cURL is not to verify cert/host]) |
83 | 83 | ||
84 | curl_ssl_verify_peer="true" | 84 | curl_ssl_verify_peer="true" |
85 | AC_ARG_ENABLE([ssl-verify-peer], | 85 | AC_ARG_ENABLE([ssl-verify-peer], |
86 | AC_HELP_STRING([--disable-ssl-verify-peer],[disable cURL cert validity verification]), | 86 | AC_HELP_STRING([--disable-ssl-verify-peer],[disable cURL cert validity verification]), |
87 | [ test "${enableval}" = "no" && curl_ssl_verify_peer="false" ] | 87 | [ test "${enableval}" = "no" && curl_ssl_verify_peer="false" ] |
88 | ) | 88 | ) |
89 | ${curl_ssl_verify_peer} || AC_DEFINE([DISABLE_CURL_SSL_VERIFYPEER],,[defined if cURL is not to verify cert validity]) | 89 | ${curl_ssl_verify_peer} || AC_DEFINE([DISABLE_CURL_SSL_VERIFYPEER],,[defined if cURL is not to verify cert validity]) |
90 | 90 | ||
91 | postels_law=true | 91 | postels_law=true |
92 | AC_ARG_ENABLE([postels-law], | 92 | AC_ARG_ENABLE([postels-law], |
93 | AC_HELP_STRING([--disable-postels-law],[Be strict, do not adhere to Postel's Law ("be conservative in what you do, be liberal in what you accept from others", RFC 793)]), | 93 | AC_HELP_STRING([--disable-postels-law],[Be strict, do not adhere to Postel's Law ("be conservative in what you do, be liberal in what you accept from others", RFC 793)]), |
94 | [ test "${enableval}" = "no" && postels_law=false ] | 94 | [ test "${enableval}" = "no" && postels_law=false ] |
95 | ) | 95 | ) |
96 | $postels_law && AC_DEFINE([POSTELS_LAW],,[defined if we want to adhere to Postel's Law]) | 96 | $postels_law && AC_DEFINE([POSTELS_LAW],,[defined if we want to adhere to Postel's Law]) |
97 | 97 | ||